LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-06-2005, 12:44 AM   #1
pinoez
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Rep: Reputation: 0
Question Disable the Mandrake automount feature


Dear,

I have two operating system : WinXP and Mandrake (Bamboo), and I use LILO as the bootloader.

Two days ago, I reinstall WinXP and change all FAT32 File System to NTFS File system.

My problem is when I try to update the bootloader with Mandrake install CD, it won't continue.

It said Error Occured - unable to mount /dev/hdax on /mnt/win_c (invalid parameter)

Is there any way to disable this automatic feature, so I can install LILO and then change the drive parameter later ?

Note : Reinstalling Mandrake (Clean) is my last option - it's hurt to do that, is there any option available ?

Thank You
 
Old 06-06-2005, 01:47 AM   #2
andygo
Member
 
Registered: May 2005
Location: Ukraine, Kiev
Distribution: Gentoo, Kubuntu
Posts: 112

Rep: Reputation: 15
show me what do these commands say:
#less /etc/fstab | grep win
and then
#fdisk -l
or just show me your /etc/fstab
pssibly the filesystem is wrong
 
Old 06-06-2005, 01:49 AM   #3
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
Am a newbee, but here is where I would look:

http://www.tldp.org/HOWTO/BootPrompt-HOWTO-7.html

Please tell us if this helps.

Once you have managed to boot, a dirty way of solving
your problem will be to comment out the automount
command in the file /etc/fstab that is for Zinblows
with a #
make a backup copy of fstab just in case
 
Old 06-06-2005, 09:26 AM   #4
pinoez
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Original Poster
Rep: Reputation: 0
OK Guys, another explanation ...

I can't boot my Mandrake, because the bootloader (LILO) was replaced by the windows bootloader, after I reinstall WinXP.

So I use the Mandrake install CD i order to reinstall the linux bootloader(LILO), just the bootloader not a clean install. This is done by choosing "Upgrade" on the second Mandrake installation UI screen other than "Install".

usually, this step worked well, but this time it doesn't, because I had changed all windows partition with NTFS while my Mandrake recognize the partition (win_c and so on) as an FAT, this raise the error message above and the installation can not continue - too bad

my question is : Is there any way to disable this automatic partition recognition before I enter the Mandrake system (Means : Mandrake doesn't have to mount any other partition other than the root one) so I can install the bootloader with Mandrake intall CD ?

Thank You - Sorry for my bad English
 
Old 06-07-2005, 01:04 AM   #5
pinoez
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Original Poster
Rep: Reputation: 0
To the top

I'm waiting ...
 
Old 06-07-2005, 01:10 AM   #6
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
What about using the rescue mode of the mandrake boot CD?
You probably do not need to reinstall.
(if you press F1 it will give you a few options, if bamboo
is like the CE version I have).

Just a note about the noprobe option, I have never tried
to use it no to recognise a partition, so this might not
be the solution (it might just hide the whole hard drive).
Worth testing nevertheless

Have you got a backup of your linux and XP files?
(just in case)

I can see another solution:
If you get hold of a CD bootable linux distribution like Knopix
(no instalation required), you will be able to
boot from the CD
(mount you hard drive - should be automatic)
edit fstab
reboot without the CD, should be fine

In all that I assume that nothing is wrong with the partition table.

About the bootloader, there is plenty out there about
dual boot, so there should be help available to fix that as well.
I am sorry I cannot help much with that
 
Old 06-10-2005, 08:41 AM   #7
pinoez
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Thank You Emmanuel

Knoppix ! Brilliant !

I'll try that next time because i've already convert my Drive C (XP Term) bak into FAT32, and my Mandrake run smoothly

But, what you've told me is a great one, I didn't even think of that before

Thanks Emmanuel - God Bless U !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto disable automount feature in Mandrake 10.1 MJatIFAD Linux - General 6 09-27-2005 03:26 AM
how to disable showdetails feature in RHGB m.harshavardhan Linux - Software 5 07-15-2005 01:07 AM
temporarily disable automount bnj Linux - Newbie 4 06-26-2005 08:41 AM
How to disable automount in Mandrake 10.1 deathbyswiftwin Linux - Hardware 3 04-11-2005 02:54 AM
Disable automount zokik Linux - General 5 12-07-2003 06:59 AM


All times are GMT -5. The time now is 05:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration