LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2012, 05:13 PM   #1
marsigme
LQ Newbie
 
Registered: Nov 2012
Location: New York
Posts: 3

Rep: Reputation: Disabled
Disable Shutdown Request on Control-Alt-Delete KeyPress


Hello...

I'm new to this forum and new to Linux so I've started the hands-on experience of working with Linux by installing CentOS 6.3 as a guest OS in my VMware Workstation v8 environment. Didn't catch it the first time but the second time around, I found that my CentOS VM installation powered off after locking my workstation. Found a number of posts regarding the inittab and control-alt-delete.conf file. I followed the instructions of commenting out the shutdown command and reloading the config by running 'init q' but unfortunately, the ctrl-alt-del still posts the shutdown request. Also, restarted the OS since it was diffcult to determine whether the 'init q' was successful or not.

Wondering if there are other config files that need to be modified? Perhaps, VMware has slipped a config hook or two into the guest OS ctrl-alt-del signal.

Any help with this issue would be greatly appreciated...

Thanks,
Mike
 
Old 11-01-2012, 08:14 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch
Posts: 1,599

Rep: Reputation: 97
Hya,

I do not know much about CentOS, but have you checked /etc/inittab?

cheers
 
Old 11-02-2012, 08:47 AM   #3
marsigme
LQ Newbie
 
Registered: Nov 2012
Location: New York
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thanks for the reply. Yes, I checked the inittab file. There is a comment in the file stating that the /etc/init/control-alt-delete.conf file manages the ctrl-alt-del event handler. I commented out the following in the ctrl-alt-del file...

# start on control-alt-delete
# exec /sbin/shutdown -r now "Control-Alt-Delete pressed"

Saved the file, ran the 'init q' command. When I pressing ctrl-alt-del in my Windows session, VMware passes the key sequence to the running guest OS. In the CentOS case, a dialog prompt is displayed stating the system will shutdown in 60 seconds. The dialog gives me the opportunity to cancel the shutdown request.

Kind of a pain given out Windows group policy locks our workstation after 15 minutes of idle time.
 
Old 11-02-2012, 09:53 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,332
Blog Entries: 55

Rep: Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533
Quote:
Originally Posted by marsigme View Post
VMware has slipped a config hook or two into the guest OS ctrl-alt-del signal.
Yes, the Knowledge Base says VMware intercepts CTRL-ALT+{DEL,INS} and passes the key combo on to the guest OS.


Quote:
Originally Posted by marsigme View Post
When I pressing ctrl-alt-del in my Windows session
Maybe you shouldn't but try using different key combos instead? Like "windows flag"+L, etc, etc?
 
Old 11-02-2012, 02:17 PM   #5
mmheera
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Ubuntu, Debian, Fedora,Windows 7
Posts: 107

Rep: Reputation: 11
Quote:
To make VMware ignore this key combination all you have to do is add the line: mks.ctlAltDel.ignore = "TRUE" to the "C:\Users\All Users\VMware\VMware Workstation\config.ini" file.
From here: http://vmblog.com/archive/2007/08/29...nd-tricks.aspx

Thanks!
 
Old 11-02-2012, 03:06 PM   #6
marsigme
LQ Newbie
 
Registered: Nov 2012
Location: New York
Posts: 3

Original Poster
Rep: Reputation: Disabled
Also, I noticed that if ctrl-alt-del is pressed in the guest OS is not the selected tab in VMware Workstation then the signal will not be sent to the guest OS. Think I'll use the VMware config change as a last resort.

I guess what's more curious to me at this point is why CentOS continues to execute a shutdown even after modifying the control-alt-delete.conf file?
 
Old 11-02-2012, 04:49 PM   #7
mmheera
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Ubuntu, Debian, Fedora,Windows 7
Posts: 107

Rep: Reputation: 11
If you are using a graphical desktop it might happen because of separate desktop environment configuration. As for Ubuntu, they are mentioning it clearly in https://help.ubuntu.com/community/UpstartHowto:


Quote:
Note that this only affects the behaviour of Control-Alt-Delete when at a text console. In a desktop environment, this key combination is handled by the desktop itself and must be reconfigured there.

You might try to change your short-cut key settings for your desktop or desktop configuration.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Control-Alt-Delete modifications geelsu Linux - General 7 05-24-2012 12:58 PM
BillGates and control-alt-delete kalleanka General 6 03-27-2006 11:50 AM
Control-Alt-Delete to bring up logoff prompt ocgltd Linux - Software 5 09-16-2005 10:01 PM
Control Alt Delete Restarts Computer, how to fix? PeaceTank Linux - Software 1 02-22-2005 02:00 AM


All times are GMT -5. The time now is 10:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration