LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-20-2004, 06:20 PM   #1
yiang
LQ Newbie
 
Registered: Sep 2004
Location: US, California
Distribution: Fedora Core 2/Redhat 9/knoppix 3.6/Linare 2.0/Mandrake 10.1/Linspire 4.5/SuSE 9.1
Posts: 26

Rep: Reputation: 15
Arrow disable reboot/shutdown beep


Hello

I'm using SUSE 9.1. Is there a way to disable the two system beeps at end of a reboot/shutdown session?

Thanks

Last edited by yiang; 11-20-2004 at 06:51 PM.
 
Old 11-20-2004, 08:20 PM   #2
Dummy-in-Linux
Member
 
Registered: Jun 2004
Location: Bangkok, Thailand
Distribution: Fedora 19 86_64
Posts: 355

Rep: Reputation: 31
Hello yiang,

I belief that the beeps at boot/reboot are generated by the BIOS of your mainboard.

If you want to disable this beeps you have to disconnect the small speaker from your mainboard.

With kind regards,

Richard
 
Old 11-20-2004, 09:01 PM   #3
yiang
LQ Newbie
 
Registered: Sep 2004
Location: US, California
Distribution: Fedora Core 2/Redhat 9/knoppix 3.6/Linare 2.0/Mandrake 10.1/Linspire 4.5/SuSE 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
okay, i just thought there was somewhere in the configuration file where you could specify to disable it because when i tried other distros, not all of them have the beeps during a reboot/shutdown session.

thanks for the reply

Last edited by yiang; 11-20-2004 at 09:05 PM.
 
Old 12-12-2004, 05:55 PM   #4
lixy
Member
 
Registered: Apr 2004
Posts: 120

Rep: Reputation: 15
In YAST -> System -> /etc/sysconfig editor and search for the word beep; Set the values to no

Cheers,
 
Old 12-12-2004, 08:04 PM   #5
yiang
LQ Newbie
 
Registered: Sep 2004
Location: US, California
Distribution: Fedora Core 2/Redhat 9/knoppix 3.6/Linare 2.0/Mandrake 10.1/Linspire 4.5/SuSE 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
do you know exactly where in sysconfig? I looked through it but couldn't find anything referencing to it. I might have skipped it but I don't think I saw anything with a beep.

Thanks for your reply
 
Old 02-10-2005, 04:35 PM   #6
bitmand
LQ Newbie
 
Registered: Jan 2005
Location: Denmark
Distribution: suse9.2
Posts: 6

Rep: Reputation: 0
I am using Suse 9.2 and I also would like to stop the two beeps from the pc
speaker on shutdown / reboot.

The first advice about disconnecting the pc speaker is impossible for me, I'm
on a laptop. Besides, I am pretty sure this is OS related, cause no other OS
I have tried beeps on shutdown (Win2000, WinXP, FreeBSD).

The second advice about searching for beeps in /etc/sysconfig editor: I have
done that and it did find 2 entries, but both were allready set to 'no'.

Doesn't anyone have some idea of what is making the 2 beeps and/or how to stop
them? They are really loud and really anoying
 
Old 02-27-2005, 10:05 AM   #7
jluckett
LQ Newbie
 
Registered: Jul 2003
Location: South Bend, IN, USA
Posts: 3

Rep: Reputation: 0
This worked for me. In my case, I'm using SuSE 9.2 and it was the pcmcia setting that was set to "yes".

Maybe try switching the pcmcia to "yes", save, restart, and then switch it back to "no", save, and restart? It's just a guess as I'm not sure why yours is set to "no" and you're still hearing the beeps.

Just to clarify, I'd found the setting in sysconfig by searching for "beep". One of the two results was already set to "no". The pcmcia one was set to "yes".
 
Old 02-28-2005, 10:20 AM   #8
Northpole
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
Edit the /etc/rc.d/halt script and remove or comment out (add a # in front of) the lines containing

echo -en "\033[<some things here>]\a"
and
echo -en "\a"

which are not in the case for $HALT_SOUND in "yes", "quint" or "octave" (line 138, 143 and 147 in my script).

No more beeps during shutdown or reboot
 
Old 03-01-2005, 05:18 AM   #9
bitmand
LQ Newbie
 
Registered: Jan 2005
Location: Denmark
Distribution: suse9.2
Posts: 6

Rep: Reputation: 0
*WOW*

It really works

I have searched the entire web (i feel like it) and haven't found any clue to the problem - and suddenly, BAM, Northpole is writing the solution. I thank you so much Northpole

Btw. i changed a total of 5 lines with echo - but it worked - and I'm happy
 
Old 03-05-2005, 03:10 PM   #10
yiang
LQ Newbie
 
Registered: Sep 2004
Location: US, California
Distribution: Fedora Core 2/Redhat 9/knoppix 3.6/Linare 2.0/Mandrake 10.1/Linspire 4.5/SuSE 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Finally! Thanks Northpole. No more beeps!!!
 
Old 10-18-2005, 01:49 PM   #11
deargin
LQ Newbie
 
Registered: Dec 2004
Posts: 3

Rep: Reputation: 0
excellent !

i wanted to ADD shutdown beeps to my machine, a box i use as a server with no monitor etc.

it's old and doesn't have the ability to power off the psu when done.

so i wanted to know the shutdown sequence was finished.

this done the trick nicely, i downloaded "beep" in debian "apt-get install beep", and added the following to /etc/init.d/halt

#
#beeps
#d, 2005-10-18
/usr/bin/beep -l 75 -f 3000
/usr/bin/beep -l 75 -f 2000
/usr/bin/beep -l 75 -f 1000
/usr/bin
#/beeps

nice jingle (thanks to ipcop also)

d
 
Old 04-25-2006, 09:50 AM   #12
Jdlyn
LQ Newbie
 
Registered: Apr 2006
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by Northpole
Edit the /etc/rc.d/halt script and remove or comment out (add a # in front of) the lines containing

echo -en "\033[<some things here>]\a"
and
echo -en "\a"

which are not in the case for $HALT_SOUND in "yes", "quint" or "octave" (line 138, 143 and 147 in my script).

No more beeps during shutdown or reboot
Sorry for asking such a newbie ?... but where can I find the above script to edit.
 
Old 04-25-2006, 02:05 PM   #13
lixy
Member
 
Registered: Apr 2004
Posts: 120

Rep: Reputation: 15
Welcome to LQ Jdlyn!

Like he said, it's in /etc/rc.d/halt !
If you can't figure out what that means, I urge you to drop that for now and read about more vital issues than a beep.

And remember that we're always here to help you.
 
Old 04-26-2006, 11:47 PM   #14
Jdlyn
LQ Newbie
 
Registered: Apr 2006
Posts: 2

Rep: Reputation: 0
Fair enough... never installed linux before, never seen running for that matter. I found it ok... all done thanks for the tips, im like'n this.

Last edited by Jdlyn; 04-29-2006 at 10:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable system beep in emacs? Snyke Linux - Newbie 5 12-14-2011 02:55 AM
How to disable that annoying BEEP? icy-flame Linux - Newbie 19 05-01-2007 06:16 PM
Disable remote login shutdown/reboot student04 Linux - Security 1 03-06-2005 08:29 PM
Disable the console beep? csvke Linux - General 6 03-01-2004 04:00 AM
Disable reboot/halt/shutdown as normal user carstenbjensen Mandriva 4 09-09-2003 11:42 AM


All times are GMT -5. The time now is 03:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration