LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-06-2007, 08:27 PM   #1
Brocolli
Member
 
Registered: May 2007
Distribution: PCLinuxOS 2007
Posts: 34

Rep: Reputation: 15
disable Kmix from starting automatically


Everytime I start kde, Kmix automatically starts. I have tried this...

From System -> Configuration -> KDE -> KDE Components -> Session Manager -> On Login, I clicked start with an empty session.. the problem with this, superkaramba and the other desktop widgets that I have wont automatically start. If I click restore manually saved session, I also dont have superkaramba etc.. If I click restore previous session, kmix will automatically start.

What I want is to disable Kmix from automatically starting. How do you save session in kde?

thanks..
 
Old 06-06-2007, 08:30 PM   #2
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
click K-menu button, and there should be a button a few up that says "Save Session"

If you don't have this, then let me know.

If you do, I promise I'll only laugh to myself
 
Old 06-06-2007, 08:35 PM   #3
Brocolli
Member
 
Registered: May 2007
Distribution: PCLinuxOS 2007
Posts: 34

Original Poster
Rep: Reputation: 15
I am sorry, I dont have this button. I was searching for it but wasnt able to find it.. maybe it's hiding somewhere else...
 
Old 06-06-2007, 08:49 PM   #4
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Actually, that gives me more faith in you (and look, I don't have to waste all that energy trying not to laugh now).

try:

Code:
dcop ksmserver default saveCurrentSession
 
Old 06-06-2007, 08:57 PM   #5
Brocolli
Member
 
Registered: May 2007
Distribution: PCLinuxOS 2007
Posts: 34

Original Poster
Rep: Reputation: 15
From KDE control center -> Panels, I tried to add kate session menu. But I also can't find it on the K-Menu button..

When I run this command. ' dcop ksmserver default saveCurrentSession ', do I need to close the applications that I don't want to start on my next boot?

thanks for the help.. I appreciate it...
 
Old 06-06-2007, 09:01 PM   #6
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Yes, get the system running with all the apps you want to start automatically, and the save the session w/ the command above.
 
Old 06-06-2007, 09:05 PM   #7
Brocolli
Member
 
Registered: May 2007
Distribution: PCLinuxOS 2007
Posts: 34

Original Poster
Rep: Reputation: 15
is there a way for me to add the 'save session' option on the k-menu?
 
Old 06-06-2007, 09:16 PM   #8
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
run kmenuedit, it should allow you to do it.
 
Old 06-06-2007, 09:33 PM   #9
Brocolli
Member
 
Registered: May 2007
Distribution: PCLinuxOS 2007
Posts: 34

Original Poster
Rep: Reputation: 15
thanks forestt! I appreciate all your help...
 
Old 06-06-2007, 09:40 PM   #10
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
You are very welcome.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable SCIM from starting up automatically i_s SUSE / openSUSE 7 10-13-2009 01:08 AM
disable KsCD from starting automatically Brocolli Linux - Newbie 3 06-06-2007 06:12 PM
When amaroK jumps to next track, volume automatically increases (kmix) eBopBob SUSE / openSUSE 0 05-28-2006 08:51 AM
kmix window starting automatically jam222 Slackware 3 08-18-2005 12:18 PM
how to automatically disable unreachable primary DNS? Eabin Linux - Networking 6 10-09-2003 05:48 PM


All times are GMT -5. The time now is 11:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration