LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-10-2006, 01:30 AM   #1
thomasw92
LQ Newbie
 
Registered: Mar 2006
Posts: 13

Rep: Reputation: 0
Disable dhcpcd for eth0 on boot


Hi,
I have an unused ethernet port (eth0) on my laptop and instead a wireless card (wlan0). Is it possible to disable the eth0 from trying to get an IP address when it starts up because it takes a very long time and slows down boot times a lot. It seems to stick for about a minute on

dhcpcd: MAC address: <eth0 mac address>

Thanks, Thomas

P.S forgot to mention I'm running Slakcware 10.2

Last edited by thomasw92; 04-10-2006 at 01:31 AM.
 
Old 04-10-2006, 01:35 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,962
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Edit /etc/rc.d/rc.inet1.conf
and
remove whatever is in the "" in
USE_DHCP[0]=""

Of course I don't use wireless, so have no idea how you integrated
it with the slackware boot-/network-scripts


Cheers,
Tink
 
Old 04-10-2006, 01:49 AM   #3
thomasw92
LQ Newbie
 
Registered: Mar 2006
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the help.. worked fine.

Thomas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcpcd ath0 fails, works for eth0 Josh328 Linux - Wireless Networking 7 02-07-2006 10:45 PM
/etc/dhcpc/dhcpcd-eth0.exe mattp Linux - Networking 2 10-17-2005 08:41 AM
eth0 removed from ifconfig after dhcpcd eth0 johnklvr Linux - Networking 3 01-15-2004 08:21 PM
K12LTSP, dhcpcd-eth0.info file beajedi Linux - Networking 0 11-25-2003 06:07 PM
howto disable eth0 at boot time rydogg Linux - Newbie 2 06-16-2003 09:33 AM


All times are GMT -5. The time now is 11:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration