LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-02-2009, 02:16 AM   #1
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Rep: Reputation: 47
disable current window manager


Hello,I am using openSUSE 10.3 with GNOME desktop environment.I installed karmen window manager but it can be run only when current window manager is disabled.How to do that?
 
Old 03-02-2009, 05:23 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Have you tried karmen --replace command so that it replaces the current window manager? It works for most of them.
 
Old 03-04-2009, 12:59 AM   #3
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
Nothing happened instead error reported because karmen has only four options display,font and something else(I don't remember).
Also when I ran karmen then following output
karmen: another window manager is already running on display ":0.0"
 
Old 03-04-2009, 02:23 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Then may be you can use display option with display other than 0:0
 
Old 03-05-2009, 12:20 AM   #5
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
to linuxlover.chaitanya,
Can you be more specific.I mean i know that there are 6 virtual terminals accessible by ctrl+alt+F1..6 and ctrl+alt+F7 for X window system.What should I write instead of 0:0.
I will soon give full info about option available man page of karmen.
 
Old 03-06-2009, 01:49 AM   #6
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
on running following command
# karmen -display 0:2
Following error occured
karmen: can't open display "0:2"
Also
usage: karmen [-display name] [-font name] [-help] [-version]

Any suggestion?
 
Old 03-06-2009, 04:12 AM   #7
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 61
Try that:
startx /path/to/karmen -- :1

Your session should then be on CtrlAltF8 while the previous one will still be on CtrlAltF9.

Yves.
 
Old 03-16-2009, 03:37 AM   #8
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
TO theYinYeti
I did as told and following happened

lxuser@linux-goap:~> startx karmen -- :1
xauth: creating new authority file /home/lxuser/.serverauth.5958
X Window System Version 7.2.0
Release Date: Sat Sep 22 22:10:58 UTC 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-goap 2.6.22.5-31-default #1 SMP 2007/09/21 22:29:00 UTC i686
Build Date: 22 September 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Mar 10 13:16:58 2009
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
(II) Module already built-in
xterm: bad command line option "xterm"
usage: xterm [-/+132] [-C] [-Sccn] [-T string] [-/+ah] [-/+ai] [-/+aw]
[-b number] [-/+bc] [-bcf milliseconds] [-bcn milliseconds] [-bd color]
[-/+bdc] [-bg color] [-bw number] [-/+cb] [-cc classrange] [-/+cjk_width]
[-class string] [-/+cm] [-/+cn] [-cr color] [-/+cu] [-/+dc]
[-display displayname] [-e command args ...] [-fa pattern] [-fb fontname]
[-/+fbb] [-/+fbx] [-fd pattern] [-fg color] [-fi fontname] [-fn fontname]
[-fs size] [-fw fontname] [-fwb fontname] [-fx fontname] [%geom] [#geom]
[-geometry geom] [-help] [-/+hf] [-/+hold] [-iconic] [-/+ie] [-/+im]
[-into windowId] [-/+j] [-/+k8] [-kt keyboardtype] [-/+l] [-/+lc]
[-lcc path] [-leftbar] [-lf filename] [-/+ls] [-/+mb] [-mc milliseconds]
[-/+mesg] [-/+mk_width] [-ms color] [-n string] [-name string] [-nb number]
[-/+nul] [-/+pc] [-/+pob] [-rightbar] [-/+rv] [-/+rvc] [-/+rw] [-/+s]
[-/+samename] [-/+sb] [-selbg color] [-selfg color] [-/+sf] [-/+si] [-/+sk]
[-sl number] [-/+sm] [-/+sp] [-/+t] [-ti termid] [-title string]
[-tm string] [-tn name] [-/+u8] [-/+ulc] [-/+ulit] [-/+ut] [-/+vb]
[-version] [-/+wc] [-/+wf] [-xrm resourcestring] [-ziconbeep percent]
Type xterm -help for a full description.
waiting for X server to shut down .FreeFontPath: FPE "/usr/share/fonts/misc:unscaled" refcount is 2, should be 1; fixing.
Couldnt get a file descriptor referring to the console

I saw a glimpse of karmen then terminal came back with above error.
ctrl+alt+F8 and ctrl+alt+F9 gave screen with a blinking cursor.
Also ctrl+alt+backspace killed x manager & terminal bringing me to logon screen.
How can I kill tab window manager in GNOME?
 
Old 03-16-2009, 07:01 AM   #9
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 61
There's obviously a bug in karmen (or its launcher, or wrapper), related to the way it uses xterm. Or maybe karmen was not found, and the bug in your distribution's fallback X session script.

I suggest you try replacing “karmen” with the full path to it in the command above, eg:
Code:
startx /usr/local/bin/karmen -- :1
(as I instructed beforehand, although not that clearly)

Yves.
 
Old 03-20-2009, 03:39 AM   #10
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
QUESTION
As theYinYeti said I found karmen window manager in ctrl+alt+F8 but in terminal following error occured.
search karmen: can't load font "-*-helvetica-bold-r-*-*-12-*-*-*-*-*-iso8859-1"
 
Old 03-20-2009, 04:32 AM   #11
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 61
This kind of error usually does no harm, but that is not always the case…

Yves.
 
Old 04-26-2009, 09:48 AM   #12
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
My question is how to kill tabbedwindow manager in gnome so that I can start karmen window manager .Is there a way?
 
Old 04-26-2009, 04:18 PM   #13
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
You should look at man startx where a description of the various xinitrc files can be found.

For example (from the man output), if you create a file .xinirc in your $HOME directory like this:
Code:
xrdb -load $HOME/.Xresources
xsetroot -solid gray &
xbiff -geometry -430+5 &
oclock -geometry 75x75-0-0 &
xload -geometry -80-0 &
xterm -geometry +0+60 -ls &
xterm -geometry +0-100 &
xconsole -geometry -0+0 -fn 5x7 &
exec twm
and another one, say .Xclient-<sys_name>:1 like this
Code:
#! /bin/bash
WM="karmen"
WMPATH="/usr/bin /usr/X11R6/bin /usr/local/bin"
for p in $WMPATH ; do
        [ -x $p/$WM ] && exec $p/$WM
done
exit 1
Make both file executable, and then a startx -- :1 should start a karmen session with two xterm windows in TTY8 for you. (Note that the twm console will not actually start without further tweaking.)

Note that leaving the .xinitrc file in your home directory may over-ride the initialization of any other manager.

<edit>
Oh, the <sys_name> in the .Xclient name means "host name of your system." Using $(hostname) should work.
</edit>

Last edited by PTrenholme; 04-26-2009 at 04:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beryl Window Manager / Emerald Theme Manager Not Changing With ATi Drivers. Z3R0o Linux - Desktop 2 01-07-2007 12:23 AM
Close all window in a window manager zghh Linux - Software 1 12-20-2006 04:18 PM
What's the best X-Window System window manager in your opinion? t3gah Linux - Software 9 12-16-2006 11:10 PM
Change/add window manager to login manager kunalagon Debian 3 06-04-2006 04:33 AM
changing desktop manager and window manager Tux Red Hat 4 04-04-2006 02:56 PM


All times are GMT -5. The time now is 08:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration