LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-11-2009, 03:37 AM   #1
dkj
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
disable beep sound in linux system


Q. This beep sound is annoying under Linux, how do I disable it forever?
A. To be frank there are many ways exists - to turn off terminal beep. Use any one of the following method as per your requirements.

If you are using Gnome terminal
a) Open Gnome terminal
b) Click on Settings > Preferences > Silence Terminal Bell
Or Click on General Tab -> General -> Un-Check Terminal bell option

If you are using xterm
Open ~/.xsession file (i.e. /home/you/.xession)
$ cd
$ vi .xession
Append following line
xset b off
Save and close the file.

If you are using bash
Open you ~/.inputrc file (i.e. /home/you/.inputrc file)
Or /etc/inputrc file
$ cd
$ vi .inputrc
Append following line:
set bell-style none
Save and close the file.

If you just want to turn off beep for VIM text editor:
Open vim config file ~/.vimrc (i.e. /home/you/.vimrc)
$ cd
$ Vi .vimrc
Append following line
set vb
Save and close the file.

If you are using Ubuntu Linux
a) Click on Applications > Accessories > Terminal
b) Now click on Edit Menu > Current Profile
c) Click on General Tab > General > Remove check box (Terminal bell)
 
Old 07-11-2009, 03:40 AM   #2
karamarisan
Member
 
Registered: Jul 2009
Location: Illinois, US
Distribution: Fedora 11
Posts: 374

Rep: Reputation: 55
Alternatively, if you're comfortable poking around a computer, you could simply pull the two-pin jumperish connector that is the only tie between your computer and its PC speaker.
 
Old 07-11-2009, 03:52 AM   #3
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
or just add
Quote:
blacklist pcspkr
to
/etc/modprobe.d/blacklist.conf
 
Old 07-11-2009, 04:13 AM   #4
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
If you're using /bin/tcsh: set nobeep in ~/.cshrc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable system beep in emacs? Snyke Linux - Newbie 5 12-14-2011 03:55 AM
Disable System Beep Darth Cupcake Linux - Kernel 2 10-23-2008 03:44 PM
Disable system beep on Acer netbook? Daravon Linux - Laptop and Netbook 1 10-15-2008 04:35 AM
System Beep No Sound Sauls Linux - Newbie 4 08-21-2008 07:06 AM
How to disable the warning sound "beep, beep" ICO Red Hat 1 04-04-2006 02:59 AM


All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration