LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2005, 03:13 AM   #1
Swakoo
Member
 
Registered: Apr 2005
Distribution: Red Hat / Fedora / CentOS
Posts: 508

Rep: Reputation: 30
Directory index of web folder


What settings do I need to enable directory indexing?

I tried
<directory....>
Options Indexes
</directory>

doesn't work.. am i missing out or some sutff?

I am using RHEL 4. thanks

Last edited by Swakoo; 06-17-2005 at 03:16 AM.
 
Old 06-17-2005, 03:47 AM   #2
SiLiCoN
Member
 
Registered: Sep 2004
Location: India
Distribution: Solaris 9, FreeBSD 4.10, Slackware, RedHat, Knoppix,
Posts: 84

Rep: Reputation: 15
<Directory /home/whatever>
Options Indexes
</Directory>

is the right option - will allow indexing for /home/whatever ... but u need to check a few things before that

is the "AllowOverride" option set for the directory and is there an .htaccess file under the document root for that host?
is /home/whatever the right directory where u want to place the Indexes option?

the setting works fine for me...incase u r not able to do it u must check httpd.conf if the option has been overriden some where.
 
Old 06-17-2005, 04:54 AM   #3
Swakoo
Member
 
Registered: Apr 2005
Distribution: Red Hat / Fedora / CentOS
Posts: 508

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by SiLiCoN


is the "AllowOverride" option set for the directory and is there an .htaccess file under the document root for that host?
is /home/whatever the right directory where u want to place the Indexes option?
.
Where do i check this?

I am running plesk on this machine.. so... a bit lost too
 
Old 06-17-2005, 05:28 AM   #4
hardcorelinux
Member
 
Registered: Jan 2005
Location: India
Distribution: RHEL,CentOS,SUSE,Solaris10
Posts: 183

Rep: Reputation: 31
check your /etc/httpd/conf/httpd.conf for allow AllowOverride option. .httaccess file may be in your public_html folder.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
web server dont start index.php Kanon Linux - Software 4 03-04-2005 04:36 AM
Apache directory index layout lupus9537 Linux - Software 1 04-26-2004 04:23 PM
Virtual Hosts/Directory Index Forbidden by Rule Alan Powell Linux - Newbie 4 04-26-2004 07:35 AM
apache directory index spank Linux - Newbie 1 12-10-2003 12:47 PM
How to make folder index? alexaltair Linux - General 7 11-25-2003 04:54 AM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration