LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2015, 06:46 AM   #1
aws23
LQ Newbie
 
Registered: Sep 2014
Posts: 2

Rep: Reputation: Disabled
digiKam fails to open in Lubuntu


installed digiKam 4:3.5.0-Oubuntu 10 and dependent packages from Synaptic Package Manager.

Graphics/digiKam selected - no action

Operating system Ubuntu 14.04.2 LTS. (LUBUNTU)

I have used digiKam successfully in previous versions of Ubuntu.

(In your LQ tutorial you refer to using 'how-tos' -where are these?-and search for occurence of 'digikam' - have attempted this without success)

(Your tutorial suggests I introduce myself - I have used Ubuntu for many years but only in GUI. My Unix knowledge is near zero - whenever I attempt to understand descriptions in the forums I get stumped by acronyms and terms that are common to other Linux users)

I hope you can help.
 
Old 04-16-2015, 11:16 PM   #2
praveensalagar
LQ Newbie
 
Registered: Jul 2014
Posts: 6

Rep: Reputation: Disabled
Security is not my area of work, but most of the places, I have been bombarded with questions like , is it possible to implement security protocol in ns2.
The answer is yes, here is the solution for that. Here is the document to read
This work is done in 2005 and developed for ns version 2.26 or 2.27. I have done the compilation for ns-2.35
The files to be modified
1. Create a new agent called "Security_packet" and two files Security_packet.h and Security_packet.cc are created.
2. Add a new packet type in ~ns-2.35/common/packet.h
3. Add a new packet type in ~ns-2.35/tcl/lib/ns-default.tcl
4. Add a new packet type in ~ns-2.35/tcl/lib/ns-packet.tcl
5. modify the ~ns-2.35/Makefile.in

Steps
1. Download the two files here
2. Copy the security.cc and security.h file in ~ns-2.35/security folder (create the security/ folder and paste both the files)
3. Open ~ns-2.35/Makefile.in and make an entry as shown below,
OBJ_CC =
4. Open the ~ns-2.35/common/packet.h file
There will be two changes
Change one
static const packet_t PT_SECURITY_PACKET=74
5. Open the file ~ns-2.35/tcl/lib/ns-default.tcl, and paste the following line at the end of the file
Agent/Security_packet set packetSize_ 0
6. open the file ~ns-2.35/tcl/lib/ns-packet.tcl, Input the following line
Security_packet
Open the terminal,
$] cd ~ns-allinone-2.35/ns-2.35/
$] ./configure
after this i am getting error so please help me out in dis
THIS IS THE ERROR SIR HELP ME OUT SOON
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
No .configure file found in current directory
Continuing with default options...
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking for ANSI C header files... (cached) yes
checking for string.h... (cached) yes
checking for main in -lXbsd... no
checking for socket in -lsocket... no
checking for gethostbyname in -lnsl... yes
checking for dcgettext in -lintl... no
checking for getnodebyname in -ldnet_stub... no
checking that g++ can handle -O2... no
checking if C++ libraries work without any namespace... no
checking if C++ libraries work with namespace std... no
checking if STL works without any namespace... no
checking if STL works with namespace std... no
checking if STL works with namespace stl... no
checking should use STL... no, couldn't find STL
checking for tcl.h... -I../include
checking for tclInt.h... -I../include
checking for libtcl8.5... -L../lib -ltcl8.5
checking for init.tcl... ../lib/tcl8.5
checking for http.tcl... ../lib/tcl8.5/http1.0
checking Tcl http.tcl library... yes
checking for tclsh8.5.11... no
checking for tclsh8.5... ../bin/tclsh8.5
checking for tk.h... no
checking for libtk8.5... no
checking for tk.tcl... /usr/share/tcltk/tk8.5
configure: error: Installation of tk seems incomplete or can't be found automatically.
Please correct the problem by telling configure where tk is
using the argument --with-tk=/path/to/package
(perhaps after installing it),
or the package is not required, disable it with --with-tk
 
Old 04-17-2015, 06:42 AM   #3
aws23
LQ Newbie
 
Registered: Sep 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
digiKam will not start

Thank you for your reply. I regret very much that I cannot see that my problem re digiKam is a matter of security. If you can show me how it is, I would be very thankful - aws23
 
Old 04-17-2015, 06:59 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,834

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
Totally irrelevant - maybe a misplaced post.

You say you get no messages - what about dmesg ?. Try to start digiKam then immediately open a terminal, and enter these commands. Post the output
Code:
dmesg | tail -n 20
 
Old 04-17-2015, 07:08 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,931

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Looks like it could be just a menu problem. Trying running it from the terminal.

http://ubuntuforums.org/showthread.php?t=2233175
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: digiKam Quick Tip: Transfer Photos from digiKam Directly to a Mobile Device LXer Syndicated Linux News 0 01-23-2015 10:30 AM
[SOLVED] digiKam cannot open database CollieJim Linux - Software 3 02-24-2014 01:39 AM
[SOLVED] digikam fails to compile Bazzaah Slackware 31 04-02-2013 03:08 AM
Lubuntu install mysteriously fails rkski Ubuntu 10 06-20-2012 06:31 PM
digikam install fails on dependecy ZaphyR Debian 4 03-10-2007 01:55 PM


All times are GMT -5. The time now is 06:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration