LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-10-2004, 12:36 PM   #1
arion
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 8
Posts: 26

Rep: Reputation: 15
difficulty to ping the network


my network card is a external network card but i cant ping because my eth0 cant activate.
when i run the command ' ifconfig '. they just show me one paragraph only. that is ....

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:92 errors:0 dropped:0 overruns:0 frame:0
TX packets:92 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5976 (5.8 Kb) TX bytes:5976 (5.8 Kb)

there should be 2 paragraph right?
so anyone has any idea about this problem?

i am using the antech 10/100m ethernet PCI adapter.

i hope that you guy can help me it is because my project is coming up soon.
thanks!
 
Old 12-10-2004, 12:40 PM   #2
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Hmmm, I don't see it in the hardware compatibility list. It may simply not be supported.

post the output of

dmesg |grep antech

or if that gives you nothing, just look through the output of

less /var/log/dmesg

and see if you see anything there pertaining to your card. You can always look through /var/log/messages as well for pertinent error messages.

Let us know...
 
Old 12-10-2004, 02:33 PM   #3
a10392
Member
 
Registered: Sep 2004
Posts: 30

Rep: Reputation: 15
check the file /etc/network/interfaces , you should configure your interface with the ip address,etc.

then

ifup eth1

if you choose eth1 for that interface

regards

MM
 
Old 12-12-2004, 02:08 PM   #4
arion
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 8
Posts: 26

Original Poster
Rep: Reputation: 15
I didn't get anything for dmesg grep antech...
Is there a line or bracket in front of grep?

And both less /var/log/dmesg and less /var/log messages gave me a list of stuff I don't know...Looked through it and didn't see anything concerning the network card or eth0.

Also, I don't have a network folder under my /etc directory so, I can't check the files in etc/network/interfaces. Am I supposed to have this directory? And when I ran ifup eth0 without configuring anything, the terminal just went to the next line without doing anything. Help...
 
Old 12-12-2004, 04:14 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Please post the output of /sbin/lspci to confirm that Linux is seeing your ethernet card. Chances are, you simply haven't inserted the correct driver module into the kernel. Do a Google search on the name of your card and Linux, to see if you can find out what the driver name is. Once you've done that you can hopefully (as root) do 'modprobe <drivername>' (no quotes). If that doesn't work, post the error -- you may need to get the driver from somewhere.
 
Old 12-13-2004, 06:41 AM   #6
arion
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 8
Posts: 26

Original Poster
Rep: Reputation: 15
Ok, when I did /sbin/lspci, I got

00:12.0 Ethernet controller: MYSON Technology Inc SURECOM EP-320X-S 100/10M Ethernet PCI Adapter

So that means that my network card is detected right? Anyway, I found a driver at www.driverguide.com and the readme told me to do this:

Installation:

1. copy the source code mtd80x.c to Linux,

2. compile the source code, the instruction for compiling the driver is
as follows:

#gcc -DMODULE -D__KERNEL__ -I/usr/src/linux/net/inet -Wall
-Wstrict-prototypes -O6 -c mtd80x.c

3. insert the driver as module,

#insmod mtd80x.o

4. bind your card to an IP address

#ifconfig eth0 ${IPADDR} broadcast ${BROADCAST} netmask ${NETMASK}

5. add your card to IP routing table,

#route add -net ${NETWORK} netmask ${NETMADK} eth0

6. now, you should be able to ping local network.

When I tried the second instruction, I got a long list of stuff ending with the lines

/usr/include/asm/pgalloc.h:63: initializer list being treated as a compound expression
/usr/include/asm/pgalloc.h:63: confused by earlier errors, bailing out

I don't know what to do about that. Anyway, I ignored those and ran the next instruction and I got:

MTD80X.O: The module you are trying to load (MTD80X.O) is compiled with a gcc version 2 compiler while the kernel you are running is compiled with a gcc version 3 compiler. This is known to not work.

So, this problem can be solved by downgrading my gcc compiler right? But that still leaves the earlier one...
 
Old 12-13-2004, 07:25 AM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
run 'gcc -v'.

Since you compiled the souce code yourself, sounds like you have gcc vers. 2 installed instead of something like 3.3.
 
Old 12-13-2004, 07:17 PM   #8
a10392
Member
 
Registered: Sep 2004
Posts: 30

Rep: Reputation: 15
Hi,

Try
updatedb, and then
locate interfaces or
locate network, in debian the file
/etc/network/interfaces, if you are using other distribution could be in a diferent location or other name related to network or interface.

the file should contain the configuration of each interface.

when you run ifup eth0 the configurations in that file will be applied.

regards
MM
 
Old 12-17-2004, 03:58 PM   #9
arion
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 8
Posts: 26

Original Poster
Rep: Reputation: 15
When I ran 'gcc -v', I found out that I'm running gcc version 3.2. So, do I need to downgrade in this case?

And updatedb doesn't work...Also, I don't have the directory /etc/network/interfaces. I'm actually running Red Hat 8...I tried looking for the network interfaces file but I have no luck there...
 
Old 12-17-2004, 08:14 PM   #10
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
With any luck, you don't need to actually compile the module yourself -- what does 'modprobe mtd80x' do? If it works, you may be set already.
 
Old 12-18-2004, 03:26 AM   #11
arion
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 8
Posts: 26

Original Poster
Rep: Reputation: 15
I get:

modprobe: Can't locate module MTD80X

Tried it with MTD80X.O and MTD80X.C too but it didn't work...
 
Old 12-18-2004, 01:48 PM   #12
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Just for fun, please do 'cat /proc/version' on the command line so we can see a few details of how your kernel was compiled. This is just to confirm that the error message you got from compiling the module is legit and not a red herring.
 
Old 12-18-2004, 02:57 PM   #13
arion
LQ Newbie
 
Registered: Oct 2004
Distribution: Red Hat 8
Posts: 26

Original Poster
Rep: Reputation: 15
[root@localhost root]# cat /proc/version
Linux version 2.4.18-14 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 13:35:50 EDT 2002
[root@localhost root]#

Is this what you're looking for?
 
Old 01-22-2005, 09:47 PM   #14
nirav_patel
LQ Newbie
 
Registered: Jan 2005
Posts: 11

Rep: Reputation: 0
[n] anyone got the solution of this problem?

bump
 
Old 01-23-2005, 12:34 AM   #15
Radical_Dreamer
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Rep: Reputation: 0
Ive been working on this same problem all night, no luck ether, however, I dont think a downgrade will work, because its not gcc 3 that is the problem, its the fact that your system was built using that version of gcc. What we need, is someone who can decompile MTD80X.O and .C and recompile them using a newer version of gcc. I dont have the knowledge to do that but maybe someone here does.

Untill then Im going to sleep...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Ping Issue - Can't ping localhost but can ping others on LAN code_slinger Linux - Networking 15 03-30-2015 03:39 PM
can ping network computer, cannot ping google.com (help needed) ben_build#2.1.0 Linux - Wireless Networking 23 11-07-2010 01:55 PM
Difficulty setting up wireless network, running route thiqued Linux - Wireless Networking 9 02-05-2006 05:58 PM
Can't PING to outside Network dibakar5173 Linux - Networking 2 09-16-2005 09:23 AM
Can ping network but can't ping any internet ip when I hard set the ip Streme Linux - Wireless Networking 4 04-13-2004 10:18 AM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration