LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2008, 03:57 PM   #16
cctv
LQ Newbie
 
Registered: Mar 2008
Posts: 16

Original Poster
Rep: Reputation: 0

Yesterday nothing would work with what you want'ed me to type in but this morning all typed in lines seem to work I have had this happen with windows befor but by leaving the computer off so the electronic caps drain of all power things seem to come right.

Certain files and permissions results

bone@bone-desktop:~$ ls -l /dev/modem
lrwxrwxrwx 1 root root 6 2008-03-24 07:00 /dev/modem -> ttySL0
bone@bone-desktop:~$ ls -l /dev/ttySL0
lrwxrwxrwx 1 root root 10 2008-03-24 07:00 /dev/ttySL0 -> /dev/pts/0
bone@bone-desktop:~$ ls -l /etc/wvdial.conf
-rw-r----- 1 root dialout 161 2008-03-23 14:14 /etc/wvdial.conf
bone@bone-desktop:~$

Enter in a terminal

bone@bone-desktop:~$ sudo ln -T /dev/ttySL0 /dev/modem
[sudo] password for bone:
ln: creating hard link `/dev/modem' to `/dev/ttySL0': File exists
bone@bone-desktop:~$


File to look like this

bone@bone-desktop:~$ sudo gedit /etc/wvdial.conf


[Dialer Defaults]
Modem = /dev/modem
Baud = 57600
Init = ATZ
Init2 = AT S11=50
Phone = 08672327
Username = pvs.video
Password = XXXXXXXXXX
New PPPD = yes
Stupid Mode = yes


Question should there be gaps were the equal = eg Stupid Mode=yes or Stupid Mode = yes ?


Yesterday I alltered this file by using
Alt+F2
gksudo gedit (type in)
run
gedit
sl-modem-daemon (just drag the file to the window)
click on the X to save the file.

This morning your sudo gedit /etc/wvdial,cinf (opened up what I had done yesterday)


I checked with clear. and have writen down pop and smtp.

I alltered the sl-modem-daemon file so that usa is now New_Zealand.

Question with ubuntu or any linux when a modem dials out do you here the sound of it dialing as in windows?

Trying to dial internet

bone@bone-desktop:~$ sudo wvdial
WvDial<*1>: WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial<*1>: Sending: ATQ0TQ0
WvDial<*1>: Re-Sending: ATZZ
bone@bone-desktop:~$


Trying to dial internet using Gnome PPP

/home/bone/.wvdial.conf<Warn>: Ignoring malformed input line: ";Do NOT edit this file by hand!"
WvDial<*1>: WvDial: Internet dialer version 1.56
WvDial<Err>: Cannot open /dev/modem: No such file or directory
WvDial<Err>: Cannot open /dev/modem: No such file or directory
WvDial<Err>: Cannot open /dev/modem: No such file or directory

What next?
 
Old 03-24-2008, 10:55 PM   #17
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
bone@bone-desktop:~$ sudo ln -T /dev/ttySL0 /dev/modem
[sudo] password for bone:
ln: creating hard link `/dev/modem' to `/dev/ttySL0': File exists
I did say to check first.

Quote:
I alltered the sl-modem-daemon file so that usa is now New_Zealand.
Which file? Where? What?

Last I heard, you had reinstalled Ubuntu 7.10 from an official install disk.
Then sl-modem-daemon was installed from the restricted drivers manager. Hence, it will be set up for the country you specified during the install.

This is also why we don't need to see scanModem any more.

Try:

sudo cp /etc/wvdial.conf ~/.wvdial.conf

and run gnome-ppp again.

If that dosn't dial out for you then:

I need to see output of:

ls -l /dev/modem
ls -l /dev/ttySL0

cat ~/.wvdial.conf

Quote:
Question should there be gaps were the equal = eg Stupid Mode=yes or Stupid Mode = yes ?
What you've got is fine ... enter "man wvdial.conf" to see some examples. If you want to be able to hear the modem dial, you have to set the volume. Change the initialization string to:

Init = ATZ V1 M2 L2

But you haven't got as far as dialing yet, and the speaker is usually on by default.
 
Old 03-25-2008, 07:22 PM   #18
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I should probably explain - it appears that the file ~/.wvdial.conf exists. This is a local-user version of /etc/wvdial.conf - it does exactly the same thing, but only for the user who owns it.

It is not normally created by default - which suggests you've done something (probably unknowing) to create it.

It is actually the preferred setup because it is possible that some users of the computer have a different ISP to dial. I usually advise editing the global file as it is usually easier on new users. If ~/.wvdial.conf does not exist, then gppp and wvdial just use the global one.

In your case, it seems that it does exist, and contains erroneous information.

There is some indication that /dev/modem may not be set up properly - so I'll probably need to see that.
 
Old 03-26-2008, 10:02 PM   #19
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Sooo... you had a chance to have a go yet?
 
Old 03-27-2008, 03:27 PM   #20
cctv
LQ Newbie
 
Registered: Mar 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge View Post
Sooo... you had a chance to have a go yet?

Hi David called yesterday and spent an hour no go so has taken the computer to his place ,waiting on david to let me know haow he gets on?

I'm still no ofay with using LQ is there a simple way to get back to this post

eg I save the link but on loging in I then find I have to look for newbees and then this post?

Cheers K
 
Old 03-27-2008, 09:00 PM   #21
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
In your profile, you can set your preferences so you get an email each time there is a new post. In the email is a link taking you right to it.
Quote:
David called yesterday
... as in "David Apimerika" from TLUG?

It is increasingly looking like you need an experienced body in front of that keyboard.
 
Old 03-28-2008, 01:04 AM   #22
cctv
LQ Newbie
 
Registered: Mar 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge View Post
In your profile, you can set your preferences so you get an email each time there is a new post. In the email is a link taking you right to it.
... as in "David Apimerika" from TLUG?

It is increasingly looking like you need an experienced body in front of that keyboard.

Hi Simon Yep it takes us back to what Tony and I are saying that Ubuntu is not ready for moms and dads and for it to become a user replacement for windows as in dial up then enough said.


Yes David of LUG New Plymouth

It can't be long befor the new Ubuntu is released. They seem to do that about April each year maybe they will have addressed the problem.

Will let you know how David gets on or if you know his email you could ask him.

Cheers K
 
Old 03-28-2008, 02:03 AM   #23
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Ubuntu dialup needs that last config step to be automated - after the modem driver is loaded. It probably worth my while to write a script for it.

Remember, the Aussie mag had basically broken your first install by not including vital components. Once you had the official release, things suddenly started making sence. (But then someone edited a vital file... yr ave mom and pop wouldn't try that.) The reason for the warm body approach is to eliminate the communication difficulties.

Also - this is with one modem. Had you used a serial modem, you'd have been amazed at how easy it was. I've seen a similar effect in windows, when it wouldn't recognise the most basic HW without a driver I didn't have. By your argument, this means Windows isn't ready for the mom&pop desktop.

I'd be curious to know what the issue turned out to be... I installed Ubuntu 7.10 to an hp 5000nx which has the same modem as you. It was a matter of running the driver manager and editing wvdial.conf

Another thing is if you guys have been using a program called "Automatix". I've been having a similar issue with another modem user which turned out that automatix had messed something up.

Since you have access to David, you may want to ask about fedora and SimplyMepis - fedora has a menu item to auto-configure modems (supported modems are configured from start) but the driver you need is not included - SimplyMepis seems to have everything though, as does PCLinuxOS.

I think I'll try figure which distro handles win-modems simplest. Meanwhile, I've added a modem section to my Ubuntu notes.
 
Old 03-28-2008, 07:23 PM   #24
cctv
LQ Newbie
 
Registered: Mar 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge View Post
Ubuntu dialup needs that last config step to be automated - after the modem driver is loaded. It probably worth my while to write a script for it.

Remember, the Aussie mag had basically broken your first install by not including vital components. Once you had the official release, things suddenly started making sence. (But then someone edited a vital file... yr ave mom and pop wouldn't try that.) The reason for the warm body approach is to eliminate the communication difficulties.

Also - this is with one modem. Had you used a serial modem, you'd have been amazed at how easy it was. I've seen a similar effect in windows, when it wouldn't recognise the most basic HW without a driver I didn't have. By your argument, this means Windows isn't ready for the mom&pop desktop.

I'd be curious to know what the issue turned out to be... I installed Ubuntu 7.10 to an hp 5000nx which has the same modem as you. It was a matter of running the driver manager and editing wvdial.conf

Another thing is if you guys have been using a program called "Automatix". I've been having a similar issue with another modem user which turned out that automatix had messed something up.

Since you have access to David, you may want to ask about fedora and SimplyMepis - fedora has a menu item to auto-configure modems (supported modems are configured from start) but the driver you need is not included - SimplyMepis seems to have everything though, as does PCLinuxOS.

I think I'll try figure which distro handles win-modems simplest. Meanwhile, I've added a modem section to my Ubuntu notes.
Hi Simon found this to day when looking for 24volt moter controllers and dynalink modem drivers

http://www.driversearch.com/cgi/sear...+modem+drivers

Looks interesting allso down loaded

hsfmodem_7.60.00.06oem_i386.deb

Conexant D110,HDA,MDC,v.92,modem

Driver

Release Title: Communications: Conexant D110,HDA,MDC,v.92,modem, Driver, Ubuntu Desktop Edition 7.04, English, Inspiron MM061, v.V7.60.00.06, A00
Release Date: 7/10/2007
Criticality: Recommended
Description: Linux driver for ubuntu OS x86 32bit V7.60.00.06

Still waiting to hear from David cheere K
 
Old 03-31-2008, 12:36 AM   #25
cctv
LQ Newbie
 
Registered: Mar 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by cctv View Post
Hi Simon found this to day when looking for 24volt moter controllers and dynalink modem drivers

http://www.driversearch.com/cgi/sear...+modem+drivers

Looks interesting allso down loaded

hsfmodem_7.60.00.06oem_i386.deb

Conexant D110,HDA,MDC,v.92,modem

Driver

Release Title: Communications: Conexant D110,HDA,MDC,v.92,modem, Driver, Ubuntu Desktop Edition 7.04, English, Inspiron MM061, v.V7.60.00.06, A00
Release Date: 7/10/2007
Criticality: Recommended
Description: Linux driver for ubuntu OS x86 32bit V7.60.00.06

Still waiting to hear from David cheere K

Ok David returned the computer to day he has used one of my other modems!

Modem

Put in other modem.

All downloads in ~/Documents
- scanModem
- martian-full-20071011.tar.gz

Ran scanModem and examined Modem/ModemData.txt
- Detected Agere Systems F-1156IV WinModem

Requires martian-full-20071011.tar.gz. Extract this in Documents:
tar xvzfp martian-full-20071011.tar.gz

This may be necessary:
sudo apt-get install libc6-dev

Compile and install from inside ./martian-full-20071011/ directory:
make all
sudo make install

Add modem to modprobe:
sudo modprobe martian_dev

Testing:
dmesg | grep martian
martian_modem --help
sudo martian_modem --info countries


--- All done. All you need to do from now is from here ---
Need to run two programmes:
sudo martian_modem --country=nz
sudo wvdial

All go!

As to how to connect up with Network tool, I'll leave that to you. Backup first!

This is what is in documents
martian-full-20071011
martin-full-20071011.tar.gz
minicom-2.3.tar.gz
scanModem
Sl-modem simon
Modem

Gnome PPP i386 (I had in stalled this pro but it looks like it is not needed)?

Question I need some explaining of what/how he has done it?

Allso how to back up Ubuntu /with what David has done?

I use BartPE to back up windows ,will this back up Ubuntu ?

Cheers K
 
Old 03-31-2008, 06:14 AM   #26
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Question I need some explaining of what/how he has done it?
... you'll have to ask David. If he had to resort to swapping it out, your smartlink can't have been working properly. (Or he got confused...)
Quote:
Also how to back up Ubuntu /with what David has done?
... depends what he has altered.

But if you keep the driver tarball in your home directory, you won't lose anything with just a backup of that.

Quote:
I use BartPE to back up windows ,will this back up Ubuntu ?
No it won't.

There are a range of backup tools for Ubuntu. The basic one is just to use "cp -a /home /media/cdrom" from the CLI. For really advanced, you can image the entire drive.

Copying /home and everything in it will also save any user configuration.

The lesson notes in the HBCLUG site include a couple of backup strategies. A more complete backup utility is, I think, "rsync" from the repos. There's probably a more mom-n-pop tool in there too - use the search function in synaptic. Us geeks prefer things technical

Note: this means you need to be online first. Focus on that.

Quote:
As to how to connect up with Network tool, I'll leave that to you.
According to the notes above, all you need to do is:

$ sudo martian_modem --country=nz
$ sudo wvdial

Try this. Once you know this is going, you will want to automate the first step:

System > Preferences > Sessions > Startup Programs > + Add

Name: martian modem setup
Command: martian_modem --country=nz
Comment: sets up the martian-modem driver

press "OK". Now you only need to do "sudo wvdial".

BTW: Gnome PPP runs wvdial. It's available because people seem to like KPPP in KDE so Gnome has to have one too.
 
Old 04-01-2008, 12:52 AM   #27
cctv
LQ Newbie
 
Registered: Mar 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge View Post
... you'll have to ask David. If he had to resort to swapping it out, your smartlink can't have been working properly. (Or he got confused...)

... depends what he has altered.

But if you keep the driver tarball in your home directory, you won't lose anything with just a backup of that.

No it won't.

There are a range of backup tools for Ubuntu. The basic one is just to use "cp -a /home /media/cdrom" from the CLI. For really advanced, you can image the entire drive.

Copying /home and everything in it will also save any user configuration.

The lesson notes in the HBCLUG site include a couple of backup strategies. A more complete backup utility is, I think, "rsync" from the repos. There's probably a more mom-n-pop tool in there too - use the search function in synaptic. Us geeks prefer things technical

Note: this means you need to be online first. Focus on that.


According to the notes above, all you need to do is:

$ sudo martian_modem --country=nz
$ sudo wvdial

Try this. Once you know this is going, you will want to automate the first step:

System > Preferences > Sessions > Startup Programs > + Add

Name: martian modem setup
Command: martian_modem --country=nz
Comment: sets up the martian-modem driver

press "OK". Now you only need to do "sudo wvdial".

BTW: Gnome PPP runs wvdial. It's available because people seem to like KPPP in KDE so Gnome has to have one too.
1 April 08
Hi Simon.

I tried to dial out this morning and got nothing ,will send David an email and ask him that he did go on line with what he set up.

quote Typing in Davids instructions

bone@bone-desktop:~$ sudo martian_modem --country=nz
martian: info: Your port is /dev/ttySM0
sudo wvdial

quote(no curser once I had typed in sudo wvdial and it did not attemp to dial out)

end quote


Quote just typing in sudo wvdial

bone@bone-desktop:~$ sudo wvdial
WvDial<*1>: WvDial: Internet dialer version 1.56
WvDial<Err>: Cannot open /dev/ttySM0: No such file or directory
WvDial<Err>: Cannot open /dev/ttySM0: No such file or directory
WvDial<Err>: Cannot open /dev/ttySM0: No such file or directory
bone@bone-desktop:~$

end quote

It looks like we still do not have a goer Cheers K
 
Old 04-02-2008, 06:48 PM   #28
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
ls -l /dev/ttySM0
(

Ask David if he tested it by dialling out.

setup steps are:

sudo martian_modem stop
sudo modprobe martian_dev
sudo ln -s /dev/ttySM0 /dev/modem
sudo martian_modem
... sets up the modem, you shouldn't have to do this every time.


lsmod | grep mart
ls -l /dev/modem
... checks everything is there with correct permissions.

wvdial.conf should look like this:
Code:
[Dialer Defaults]
Modem = /dev/ttySM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Carrier Check = No
New PPPD = Yes
Phone = <Target Phone Number>
Username = <Your Login Name>
Password = <Your Password>
 
Old 04-03-2008, 03:19 AM   #29
cctv
LQ Newbie
 
Registered: Mar 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Hi Simon Ok David said to add a & to the end of the

Quote

sudo martian_modem --country=nz &

or open a 2nd terminal so as the program keeps running.

on doing both ideas the modem went on line (ok)

end quote

Ok now I need to learn how to back up and put a firewall on next?

Allsso how to get the first modem to work ,I don't know why David changed the modem from the one you and I started out with.

Cheers Keith
 
Old 04-04-2008, 02:14 AM   #30
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
how to get the first modem to work
I'm not going to second guess Davids decision here. He had his hands on the modem and decided it was a no-go. I am too far away to offer an informed opinion.

If I were you, I'd be happy I'm online.


Quote:
Ok now I need to learn how to back up and put a firewall on next?
By now you should be all familiar with the way linux likes to do things.

The firewall is handled by iptables and backup is handled with cp or tar. There are other utilities you can install to help, like firestarter and rsync. But all this is covered in different threads. Use the search option at the top of this page.

Linux has extensive security built-in though. Suggest you read through the security lesson from www.hbclinux.net.nz/oschome.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to get printer (even tho drivers are installed) to work with Xandros eyoung651 Linux - Newbie 2 01-30-2008 11:34 AM
Puppy Linux 2.1 now works with LT Modem Dial-Up!!! john biles General 0 09-15-2006 08:17 PM
everything works, thanks to xandros Motown Linux - Laptop and Netbook 3 11-30-2004 12:50 PM
Dial Up Internet in China only works with XP elevel Linux - Networking 4 10-08-2004 07:18 PM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration