LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-24-2010, 06:08 AM   #1
jerrybuilt
LQ Newbie
 
Registered: Sep 2010
Posts: 12

Rep: Reputation: 0
DHCPD error, Fedora 13


I am trying to configure a Fedora 13 server, simple installation, for PXE boot installation to install Xenserver

I have obviously made a basic error in my dhcpd.conf file (please see below)

The effect is that the DHCPD service does not run automatically, I have to run /etc/init.d/network restart before DHCPD runs on my server. Any ideas anyone?

Many thanks

#
# DHCP Server Configuration file.
# see /usr/share/doc/dhcp*/dhcpd.conf.sample
# see 'man 5 dhcpd.conf'
#
DHCPDARGS=eth0;

subnet 192.168.1.0 netmask 255.255.255.0 {
range dynamic-bootp 192.168.1.10 192.168.1.30;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
option routers 192.168.1.1;
option domain-name-servers 192.168.1.100;
default-lease-time 600;
max-lease-time 7200;
}
host clientname{
filename "/tftpboot/xenserver/install.img";
}


allow booting;
allow bootp;
class "pxeclients" {
match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";
next-server 192.168.1.8;
filename "linux-install/pxelinux.0";
}
 
Old 09-24-2010, 06:46 AM   #2
jerrybuilt
LQ Newbie
 
Registered: Sep 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Sorry guys but my problems seems mor basic than with the dhcpd.conf file, I've just noticed that eth0 does not start on boot up, I have to run /etc/init.d/network restart before the NIC will start, here are my eth0 configs

Many thanks

# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
HWADDR=F2:BF:5F:80:3F:1B
IPADDR=192.168.1.8
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
TYPE=Ethernet
 
Old 09-24-2010, 06:59 AM   #3
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
do this
Quote:
system-config-network
click on eth0
Check the Option Activate the device when computer start

restart network service
Quote:
/etc/init.d/network restart

/etc/init.d/NetworkManger restart
 
Old 09-24-2010, 07:12 AM   #4
jerrybuilt
LQ Newbie
 
Registered: Sep 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Sorry Prayag, I should have said, I am non GUI, command line only.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error installing dhcpd bdavide Linux - Newbie 6 07-07-2008 08:36 PM
location of dhcpd.conf in fedora 7 vchawla Linux - Server 3 11-21-2007 11:37 AM
Fedora 5 dhcpd server failure Fegero Linux - Networking 4 06-14-2006 07:06 PM
Curious dhcpd error thosm Linux - Networking 7 08-31-2005 02:22 PM
Fedora core 1 dhcpd problem ybxdradford Fedora 1 06-18-2004 07:14 AM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration