LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   DHCP skip on boot (http://www.linuxquestions.org/questions/linux-newbie-8/dhcp-skip-on-boot-224556/)

zchoyt 08-30-2004 08:34 PM

DHCP skip on boot
 
When I boot my PC, it gets to ETH0 and attempts to contact a DHCP server. If I am not on a network I have to sit there and wait for what seems like an hour. What are some ways around this?

Is there a way to change the time out to just a few seconds?

Is there an equal to window's "ipconfig /renew"

Or other alternatives?

comprookie2000 08-30-2004 09:12 PM

What dist. are you using?

zchoyt 08-31-2004 09:20 AM

Fedora 2

scuzzman 08-31-2004 09:34 AM

an equal to window's "ipconfig /renew"
is
# service network restart

zchoyt 08-31-2004 06:41 PM

So, let me redescribe the situation.

I am using fedora. When the system boots it starts all these things......
It gets to ETH0 and if I am not connected to a 10/100 port with DHCP, it will sit there and time out. which takes a long time.

I would rather that it did not start on boot, then I can start it manually if I want with the redhat-config-network command.
There must be a file to edit somewhere to make this happen, right? Any info please.

thanks

JayCnrs 08-31-2004 09:17 PM

If you go into System Settings-->Network, highlight eth0, click edit. Under the general tab you will see a checkbox by Activate device when starting take the check out of here, you might want to place a check in Allow all users to activate and disable device. Now it won't try and start at boot up. Once in to Fedora you can then go to System Tools --> Network Device Control, highlight eth0 and click activate. It will then activate your eth0 without asking for roots password. You will have to save the changes and restart the Network service for changes to take effect.

In Fedora Core 2 the command is system-config-network

HTH :)


All times are GMT -5. The time now is 08:09 AM.