LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2008, 09:36 PM   #1
pranavw
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
Unhappy DHCP/PXE configuration problem[URGENT]


Hi
I need to setup dhcp server on my opensuse 10.3.

# /etc/dhcpd.conf

default-lease-time 600;
max-lease-time 7200;
ddns-update-style none;
ddns-updates off;
allow booting;

class "pxe"
{
match if substring(option vendor-class-identifier,0,9)="PXEClient";
}
class "etherboot"
{
match if substring(option vendor-class-identifier,0,9)="Etherboot";
}

# Subnet for PXE boot installation
subnet 192.168.0.0 netmask 255.255.255.0
{
option broadcast-address 192.168.0.255;
pool
{
range 192.168.0.202 192.168.0.203;
default-lease-time 180;
max-lease-time 360;
server-name "192.168.0.103"; # IP of DHCP server means own IP
allow members of "pxe";
allow members of "etherboot";
}
}



host # rcdhcpd restart

My host is cramiping showing following error

Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Wrote 0 leases to leases file.

No subnet declaration for “eth0” (0.0.0.0).
** Ignoring requests on “eth0”. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface “eth0” is attached. **

Not configured to listen on any interfaces!

Anybody has idea what's going wrong ?
Thanks in advance

Pranav
 
Old 01-15-2008, 03:31 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
please do not mark threads as urgent. This is a voluntary forum and it is not urgent for our members who kindly donate their time to help others.
 
Old 01-15-2008, 04:16 AM   #3
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 37
Have you given any network interfaces the IP address 192.168.1.1 for example so the dhcpd knows which interface to listen?
 
Old 01-15-2008, 04:45 AM   #4
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
regarding the input of Zmyrgel

The option is missing if you server has more then one Nic:

server-identifier

looks like this:

Code:
server-identifier 192.168.0.2;
there you go
 
Old 01-15-2008, 11:26 PM   #5
dadapeer.md
LQ Newbie
 
Registered: Dec 2007
Posts: 1

Rep: Reputation: 0
Hi,

This is Mohammed Dadapeer.i am Working on Redhat v6.6.Please give me the details to

install the linux v6.6 with minimum drive partitions. And DHCP Configuration

commands.


THANKING YOU.





REGARDS
MOHAMMED.
 
Old 01-16-2008, 01:37 AM   #6
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
@dadapeer.md please open a new thread or can you tell us what this post hast to do with DHCP/PXE configuration problem and OpenSuse ?
 
Old 01-16-2008, 05:55 PM   #7
pranavw
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Original Poster
Rep: Reputation: 0
error still persists

Thanks for the reply(@Zmyrgel and @odcheck)
I have tried DHCPARGS with eth0
as well as network interface with ip but problem still persists.
Any more ideas.

Pranav
 
Old 01-17-2008, 12:34 AM   #8
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
Are you sure that dhcpd service is started?
And Do you really only want a DHCP Server nothing else? If so then backup this dhcpd.conf in /etc and replace it
with the one .../share/doc/dhc****/dhcpd.sample.conf

change the values within it and then you've got a working config.
Next step check with chkconfig --list dhcpd if the DHCPD Server Daemon is startet in Runlevel 235
if not do a chkconfig -level 235 dhcpd on and then /etc/init.d/dhcpd start

Cause in Your config shown above it looks like you want to tread it like a pxe / tftp server without the tftp kernel files...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcp - PXE booting icedude Linux - Enterprise 10 09-28-2010 06:36 AM
DHCP / PXE and DNS on separate NIC's unclecameron Linux - Networking 1 10-12-2007 01:11 AM
Why my pxe clinet doesnt get ip address from DHCP server? maya_mason Red Hat 1 11-27-2006 09:16 PM
PXE booting problem with DHCP amagi Linux - Networking 4 08-15-2006 03:38 AM
DHCP vs PXE woes :S kevingpo Linux - Networking 2 11-05-2005 02:02 PM


All times are GMT -5. The time now is 01:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration