LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Device named with mkfifo disappears on reboot (http://www.linuxquestions.org/questions/linux-newbie-8/device-named-with-mkfifo-disappears-on-reboot-283501/)

ColKurtz 01-28-2005 05:37 PM

Device named with mkfifo disappears on reboot
 
I'm trying to get the scrolling function on my laptop's trackpoint to work (under Ubuntu in this case), and to do so I'm instructed to do the following:

*) mkfifo /dev/imouse This is my main problem I think. The command creates /dev/imouse but it disappears on reboot

*) edit XF86Config-4 and change the mouse input line to the following:
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/imouse"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "off"
Option "ZAxisMapping" "4 5"
EndSection

*) Disable gpm (I can't find this running on my system but I'm running under VMware).

*) add "/usr/local/bin/tp-scroll /dev/mouse /dev/imouse" to rc.local. (actually, its /etc/init.d/local under Debian/Ubuntu - I have added the line correctly and have the tp-scroll file in /usr/local/bin)

===================================
However, when I do this and reboot, X fails to start. I get an error "no core pointer device specified" . At this point, /dev/imouse is no longer present.

How do I make /dev/imouse static?

Thanks.

foo_bar_foo 01-28-2005 10:46 PM

now that we are using dynamic device node creation (thanks to the guys at IBM) you need to put the mkfifo command above the other command in your rc.local as well so it get done at boot


All times are GMT -5. The time now is 03:00 PM.