LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-06-2004, 11:45 AM   #1
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Rep: Reputation: 15
/dev/hda1 write permission....?


hi there:

i have just managed to mount my Windows partition during the boot time but i can't seems to have write access to the partition. i can copy files from it though? how would i set it up so that i can write to it to? i use fedora core 2.

i have tried adding

/dev/hda1________vfat________rw 00

at the

/etc/mtab

and here is what i ahve in /etc/fstab

/dev/hda1 /mnt/windows vfat defaults 0 0

also? how would make alias to /mnt/windows so that i can access to it quicker?

cheers

CHUN
 
Old 07-06-2004, 11:55 AM   #2
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
try adding "umask=002" after "default" in fstab. SHould do the trick
 
Old 07-06-2004, 12:13 PM   #3
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
hi there:

thanks for your reply.

do you mean:

/dev/hda1 /mnt/windows vfat defaults, umask=002 0 0

just tried this and hda1 did not mount....

cheers

CHUN
 
Old 07-06-2004, 01:58 PM   #4
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
try elimiating the space between defaults and umask.
This is one of my fstab entries:

/dev/hda1 /mnt/windows/win_c vfat defaults,umask=002 0 0
 
Old 07-06-2004, 06:11 PM   #5
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
ummmm, i am not quite sure what it is. i still cant write into /mnt/windows.

any other ideas?

is it possible to do like

chmod -R 777 /mnt/windows

?

CHUN
 
Old 07-06-2004, 06:57 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
You can do that, however, that will only affect the
mountpoint itself ...

Did you actually re-mount the partition after having
played with fstab?


Cheers,
Tink
 
Old 07-07-2004, 06:27 AM   #7
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
hi there:

i reboot the system after modifying the fstab. this will re-mount the partition, right?

cheers

CHUN
 
Old 07-07-2004, 06:52 AM   #8
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
Hi Chun,

try following:

first un-mount /mnt/windows
umount /mnt/windows

Then edit the entry in /etc/fstab

Change from:
/dev/hda1 /mnt/windows vfat defaults 0 0
To:
/dev/hda1 /mnt/windows vfat rw,auto,umask=0000,users,exec 0 0
or
/dev/hda1 /mnt/windows vfat defaults,umask=0000 0 0

Then mount the filesystem
mount /mnt/windows

I suppose that umask=002 did not help due to following:
umask=002 (umask has inverse logic, so
it tells which bits should *not* be masked unlike chmod that tells which bits should *be* masked)
means the user and the group have all permisions and others not. Since you are *not * specifying
the user and the group under whom's ID the filesystem shall be mounted,
plus the mount option "defaults" contains automount, the filesystem
is mounted as root and the root's default group which is also root. So when you try to
access the filesystem as normal user, your write requests are masked out,
since you are "others" (neither root nor belonging to the root group)

BTW: I use 4 digits for umask. The first digit 0 indicates an octal number.

The easiest way for an "alias" is a symbolic link:

ln -s /mnt/windows /windows

This will create an entry windows under / which is a symbolic link to /mnt/windows.

So cd /windows will have the same result as if you would be executing cd /mnt/windows

If you want it shorter
ln -s /mnt/windows /win

So you can change into /mnt/windows simply by cd /win

Last edited by Vlad-A; 07-07-2004 at 06:55 AM.
 
Old 07-07-2004, 07:05 AM   #9
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
great! that worked!

windows drive also appeared on my desktop so that i don't need to go into /mnt/windows. which part of the "/dev/hda1 /mnt/windows vfat rw,auto,umask=0000,users,exec 0 0" made it do this? i would like to know.

cheers

CHUN
 
Old 07-07-2004, 07:08 AM   #10
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
umask=0000 made it.
umask=0000 means everybody has all permisions.
 
Old 07-07-2004, 07:15 AM   #11
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
cool, thanks again
 
Old 07-08-2004, 10:38 PM   #12
biblefreak
Member
 
Registered: Dec 2002
Location: West Texas
Distribution: Ubuntu Hardy
Posts: 44

Rep: Reputation: 15
time to revive a thread!

I have had a similar problem with my new Suse 9.1 Pro install, used the search function (which is our friend!) and came across this. Followed the directions and I can now write to my Fat32 partition. The problem is under "my computer" it no longer shows "hard disk" which had the Suse partition, and the "windows" drive when you click on it only gives you the option to open it with Kwrite as it thinks it is a text file. Here is my FSTAB, which is the only thing I have edited. BTW, before I found this thread, I tried the Suse partition tool under YAST and it didn't seem to do anything, but then againI didn't really completely understand what I was doing.


/dev/hdb5 / reiserfs acl,user_xattr 1 1
/dev/hdb6 /home reiserfs acl,user_xattr 1 2
/dev/hda7 swap swap pri=42 0 0
/dev/hdb3 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/cdrom /media/cdrom subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/hda5 /windows/d vfat rw,auto,umask=0000,users,exec 0 0

Any help would be appreciated. Thanks.
 
Old 07-08-2004, 11:06 PM   #13
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 32
Biblefreak,

please open a new thread. Your problem is somehow different and it would be only fair
to open a own thread. Thanx.
 
Old 07-08-2004, 11:37 PM   #14
biblefreak
Member
 
Registered: Dec 2002
Location: West Texas
Distribution: Ubuntu Hardy
Posts: 44

Rep: Reputation: 15
Done.

New thread here:

http://www.linuxquestions.org/questi...hreadid=202849
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission denied on /dev/hda1 after chrooting pwaring Linux - General 11 09-05-2005 04:53 AM
Grub Dual Boot /dev/sda1 /dev/hda1 jono268 Debian 4 01-14-2005 05:54 AM
\dev\hda1 ?! maoinchina Linux - General 6 10-06-2003 08:23 AM
/dev/hda1 plisken Linux - General 2 03-14-2003 07:34 PM
read and write permissions for /dev/hda1... windows philfighter Linux - Security 3 10-27-2001 08:58 AM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration