LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2004, 01:30 PM   #1
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Rep: Reputation: 15
Desktop Settings


Ok Fedora Core 2 Test 3 is making more and more and more problems.. or maybe it's me.

Ok for this n00b question I need a little story:

It was yesterday (09.05.04) I figured out, that my monitor isn't set perfect for example my Monitor is perfect at 1280 x 1024 and my settings were 1400 x 1280 so I setted them to 1280 x 1024.

Right.. I remember that i've done that in (start "the red hat" -> Preferences -> display settings)
Today (10.05.04) I booted up my computer as always.. and I just saw, what IN THE HELL.. my monitor settings must be like 1800 x 1800 because everything is blured, even this fonts im typing here are bigger then my hand

And yes I tried to changing my monitor settings as root nothing worked.. thank you

Mortified Pengu
 
Old 05-10-2004, 02:07 PM   #2
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Try CTRL and ALT and - to lower your resolution, CTRL and ALT and + to increase resolution.
 
Old 05-10-2004, 02:16 PM   #3
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
Hey TheOther1

thanks this helped. But if I press ctrl alt - then once my monitor goes smaller.. and the next time I press it .. it goes back to the big default.. The bad thing on this is, that the small solution is still too small but thanks anyway im going to play with this
 
Old 05-10-2004, 10:18 PM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
In your XF86Config-4 file,

Section "Screen"

should have a subsection "Display", where you can adjust your resolutions for a given color depth. For your preferred depth, set the resolutions to the one you want as the first in the row. Second choice second. For example,

1280x1024 1024x768 800x600

That makes your preferred resolution first to be tried. Nothing higher will be tried. If not on the list, it won't be tried. Good luck.
 
Old 05-12-2004, 02:59 PM   #5
Mortified Pengu
LQ Newbie
 
Registered: May 2004
Location: Zurich Switzerland
Distribution: Fedora Core 2
Posts: 24

Original Poster
Rep: Reputation: 15
hey vectordrake..

Thanky ou but first of all i'd like to say.. that I can't find this file "XF86Config-4" anywhere..
Where did I search: In my whole / and in /etc/X11/

Well the only files I could find there were:
XF86Config & xorg.conf

So I added your scripts in both sections. I opened them with gEDIT (yes I don't know if that's right but I just used a solution where I can simply change and safe). So my XF86Config file looks like this now ( I marked the interesting parts with <- )


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "de_CH"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Uncomment if you don't want to default to DDC:
### Uncomment if you don't want to default to DDC:
# HorizSync 30.0 - 70.0
# VertRefresh 50.0 - 120.0
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 37.9
# VertRefresh 50.0 - 70.0
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Princeton EO15"
### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 37.9
# VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen" <-
Identifier "Screen0" <-
Device "Videocard0" <-
Monitor "Monitor0" <-
DefaultDepth 24 <-
SubSection "Display" <-
Viewport 0 0 <-
Depth 24 <-
Modes "1280x1024" "1024x768" "800x600" <-
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 05-12-2004, 05:49 PM   #6
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
The XF86Config file is the right one. Some versions of XFree go with XF86Config and some have the -4 at the end. Some distros name it their own way. You got it right. Did you get what you wanted? I noticed that your monitor section had a lot of comments to default to DDC. If it still doesn't work, I am wondering if the wrong resolution is being passed from the DDC info (shouldn't but the reading of it is a bit shaky sometimes, I think.
 
Old 06-03-2004, 03:31 PM   #7
skog
Member
 
Registered: Sep 2003
Location: TX
Distribution: slackware
Posts: 301

Rep: Reputation: 30
try adding those lines to xorg.conf

xorg is the new xfree ... go figure

to find out which your using at a console type x -version
if its xfree86-x.x.x then change XF86Config
if its x.org-x.x.x then change xorg.conf

the XF86Config-4 is like an add on to XF86Config so you can use either or both of them, i think it started getting to easy so they threw the extra config file in to confuse people.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop Nautilus settings Orkie Linux - Software 2 08-18-2005 05:53 AM
Gnome Desktop settings theplop Slackware 13 10-28-2004 05:44 PM
Desktop settings sidra Linux - Newbie 4 10-20-2004 08:48 AM
Unable to keep desktop settings? Tezdread Linux - General 5 01-10-2003 08:03 AM
Enlightenment desktop settings brassmon_k Linux - General 7 11-28-2001 11:37 AM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration