LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-06-2004, 10:54 PM   #1
ugen64
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Linux
Posts: 3

Rep: Reputation: 0
desktop resolutions and such


Right, I've got the "desktop scrolls because the resolution is too high" problem that I'm sure most of you have seen. However, I've tried everything to fix it - i've run xf86config at least five times, made the only resolution 1024x768 (by manually editing XF86Config), turned off virtual desktops, everything! This is what my XF86Config says:

Section "Screen"
Identifier "Screen 1"
Device "Radeon"
Monitor "Monitor"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768"
ViewPort 0 0
EndSubsection
EndSection


I don't see why my desktop resolution is still 1280x1024, and if I use Ctrl+Alt+Plus to change it, it goes to 800x600 and forces me to scroll around... Help! I'm using Debian (sarge) with KDM and i've done all the apt-get updating and such.

Last edited by ugen64; 10-06-2004 at 10:56 PM.
 
Old 10-06-2004, 11:01 PM   #2
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
hrm.

I dunno if this helps, but one time I had the same problem after I first installed slackware 10.

AS it turns out, the xorg.conf file I was editing wasn't being used by X11 for some reason. When I deleted all of the others ones out of /etc/x11/ , it started using the xorg.conf file I wanted it to.

Make sure it's using the right file.

I think you can specify it with a command option.
 
Old 10-07-2004, 05:10 AM   #3
ttottoro
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Rep: Reputation: 0
the correct configuration file is /etc/X11/XF86Config-4 (the "4" is important !)

try a "dpkg-reconfigure xserver-xfree86" as root, so you can configure your X server with debconf

good luck
 
Old 10-07-2004, 03:09 PM   #4
ugen64
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora Linux
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by ttottoro
the correct configuration file is /etc/X11/XF86Config-4 (the "4" is important !)

try a "dpkg-reconfigure xserver-xfree86" as root, so you can configure your X server with debconf

good luck
OMG ttottoro, I love you... in a totally platonic, brotherly, distance-hampered way... now I can use Konqueror without going blind! Yay!

And also, I used debconf to reconfigure my X server, then realized that it set my vertical refresh rate to 50-160, which was why I got an "Out of Sync Range" on my monitor... that was kinda odd. But now I'm back in 1024x768 mode, so yay!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis: resolutions and 3D jaakkop Linux - Distributions 6 02-10-2005 08:59 PM
Resolutions linuxmdknew Mandriva 1 11-05-2004 07:49 PM
Ati - Big Desktop with different resolutions bannanafish Linux - General 1 07-02-2004 03:00 PM
two resolutions the_big_frog Slackware 1 08-03-2003 04:46 PM
Resolutions Steppenwolf Linux - Newbie 4 04-25-2003 02:35 AM


All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration