LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2010, 11:26 AM   #1
Axerated
LQ Newbie
 
Registered: May 2010
Posts: 4

Rep: Reputation: 0
Desktop effects could not be enabled (Newbie for Ubuntu 9.10)


Hi,
I am a newbie on Linux system. I had install ubuntu 9.10 as my OS, but I cant activate my videocard.

I havd tried lshw to detect my videocard as: S3 supersavage IX/C
but stated: this device hasn't been claim

I had checked my Xorg.conf
below what is display:

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

I had changed it to the below, but still didnt get it working

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
EndSection

Section "Module"
Load "glx"
Load "dri"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0
Option "dpms"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
Option "NoAccel" "true"
#Option "HWCursor" # [<bool>]
#Option "SWCursor" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "Rotate" # [<str>]
# Option "UseBIOS" "True"
#Option "LCDClock" # <freq>
#Option "ShadowStatus" # [<bool>]
#Option "CrtOnly" # [<bool>]
#Option "TvOn" # [<bool>]
#Option "PAL" # [<bool>]
#Option "ForceInit" # [<bool>]
#Option "Overlay" # [<str>]
#Option "TransparencyKey" # [<str>]
#Option "ForceInit" # [<bool>]
#Option "DisableXVMC" # [<bool>]
#Option "DisableTile" # [<bool>]
#Option "DisableCOB" # [<bool>]
#Option "BCIforXv" # [<bool>]
#Option "DVI" # [<bool>]
#Option "BusType" # [<str>]
#Option "DmaType" # [<str>]
#Option "DmaMode" # [<str>]
#Option "AGPMode" # <i>
#Option "AGPSize" # <i>

Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 SuperSavage IX/C SDR"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

#Section "DRI"
# Group 0
# Mode 0666
#EndSection


Please help me... thanks
 
Old 05-10-2010, 02:40 PM   #2
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 650

Rep: Reputation: 78
do you know what kind of video card you have? ATI, NVIDIA, integrated? This will help with helping you.
 
Old 05-11-2010, 03:35 AM   #3
Axerated
LQ Newbie
 
Registered: May 2010
Posts: 4

Original Poster
Rep: Reputation: 0
VideoCard: S3 Supersavage IX/C

Hi,

My Videocard is S3 Supersavage IX/C
laptop:~$ lspci | grep VGA
01:00.0 VGA compatible controller: S3 Inc. SuperSavage IX/C SDR (rev 05)

laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 05)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 05)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB Controller #2 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 02)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
01:00.0 VGA compatible controller: S3 Inc. SuperSavage IX/C SDR (rev 05)
02:08.0 Ethernet controller: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller (rev 42)
02:0a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 01)
02:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus Bridge with ZV Support (rev 32)
02:0b.1 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus Bridge with ZV Support (rev 32)
02:0d.0 System peripheral: Toshiba America Info Systems SD TypA Controller (rev 03)

Please help. thanks
 
Old 05-11-2010, 09:02 AM   #4
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 650

Rep: Reputation: 78
have a look here:

http://ubuntuforums.org/showthread.php?t=75393
 
Old 05-12-2010, 11:18 AM   #5
Axerated
LQ Newbie
 
Registered: May 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Hi bret381,

I had check the forum, but I am not sure if those work on ubuntu 9.10 as there is no posting after Mar 2008. Sorry if I sound stupid. cos very new in this OS.

Cheers
AR

Last edited by Axerated; 05-12-2010 at 11:32 AM.
 
Old 05-12-2010, 04:26 PM   #6
alan99
Member
 
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
assuming your video driver is installed correctly,
You should probably have a section like this in you xorg.conf

Section "Extensions"
Option "Composite" "Enable"
EndSection

also, you might need to add these to your screen section

Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "true"
 
Old 05-13-2010, 11:13 AM   #7
Axerated
LQ Newbie
 
Registered: May 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by alan99 View Post
assuming your video driver is installed correctly,
You should probably have a section like this in you xorg.conf

Section "Extensions"
Option "Composite" "Enable"
EndSection

also, you might need to add these to your screen section

Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "true"
Hi Alan,

I dont have that in my Xorg.conf
by the way, how do I know if the video driver is install correctly?
When I use hardware lister and I had "this device hasn't been claimed" for my video card.

my Xorg.conf

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

AR
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop effects could not be enabled scarypajamas Linux - General 3 06-28-2009 07:09 PM
Desktop effects could not be enabled chango77745 Linux - Newbie 5 05-11-2008 01:05 PM
Desktop effects could not be enabled???? ziggy92 Linux - Software 3 05-05-2008 10:41 PM
desktop effects cannot be enabled av.dubey Linux - Newbie 10 01-21-2008 05:04 PM
desktop effects could not be enabled wuchee Linux - Desktop 7 06-19-2007 08:13 AM


All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration