LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-03-2011, 12:19 AM   #1
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Rep: Reputation: Disabled
dependency problem in centos 5.6 while updating


As said before,i have Centos 5.6 installed in my system and when i try to run the command yum update,it says the following:

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirrors.sin1.sg.voxel.net
* extras: ftp.tc.edu.tw
* updates: mirrors.sin1.sg.voxel.net
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package NetworkManager.i386 1:0.7.0-13.el5 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-13.el5 set to be updated
---> Package NetworkManager-gnome.i386 1:0.7.0-13.el5 set to be updated
---> Package authconfig.i386 0:5.3.21-7.el5 set to be updated
---> Package authconfig-gtk.i386 0:5.3.21-7.el5 set to be updated
---> Package bind.i386 30:9.3.6-16.P1.el5_7.1 set to be updated
---> Package bind-chroot.i386 30:9.3.6-16.P1.el5_7.1 set to be updated
---> Package dbus-x11.i386 0:1.1.2-16.el5_7 set to be updated
---> Package gnome-screensaver.i386 0:2.16.1-8.el5_6.3 set to be updated
---> Package gnome-terminal.i386 0:2.16.0-5.3.el5_6.1 set to be updated
--> Processing Dependency: hpijs = 1:1.6.7-6.el5 for package: hplip
---> Package hpijs.i386 1:1.6.7-6.el5_6.1 set to be updated
---> Package hplip3.i386 0:3.9.8-11.el5_6.1 set to be updated
---> Package kernel-PAE.i686 0:2.6.18-274.12.1.el5 set to be installed
---> Package libuser.i386 0:0.54.7-2.1.el5_5.2 set to be updated
---> Package m2crypto.i386 0:0.16-8.el5 set to be updated
---> Package man.i386 0:1.6d-2.el5 set to be updated
---> Package nautilus.i386 0:2.16.2-10.el5 set to be updated
---> Package nfs-utils.i386 1:1.0.9-54.el5 set to be updated
---> Package openoffice.org-draw.i386 1:3.1.1-19.5.el5_5.6 set to be updated
---> Package openoffice.org-graphicfilter.i386 1:3.1.1-19.5.el5_5.6 set to be updated
---> Package openoffice.org-impress.i386 1:3.1.1-19.5.el5_5.6 set to be updated
---> Package openoffice.org-math.i386 1:3.1.1-19.5.el5_5.6 set to be updated
---> Package openoffice.org-writer.i386 1:3.1.1-19.5.el5_5.6 set to be updated
---> Package openoffice.org-xsltfilter.i386 1:3.1.1-19.5.el5_5.6 set to be updated
---> Package python-numeric.i386 0:23.7-2.2.2.el5_6.1 set to be updated
---> Package sabayon-apply.i386 0:2.12.4-7.el5 set to be updated
---> Package sos.noarch 0:1.7-9.54.el5 set to be updated
---> Package system-config-network.noarch 0:1.3.99.19-2.el5 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.99.19-2.el5 set to be updated
---> Package system-config-printer.i386 0:0.7.32.10-1.el5_7.1 set to be updated
---> Package system-config-printer-libs.i386 0:0.7.32.10-1.el5_7.1 set to be updated
---> Package xorg-x11-drv-mga.i386 0:1.4.13-2.el5 set to be updated
---> Package xorg-x11-drv-qxl.i386 0:0.0.12-2.el5 set to be updated
---> Package xorg-x11-drv-sis.i686 0:0.9.1-7.3.el5_7.1 set to be updated
---> Package yum.noarch 0:3.2.22-37.el5.centos set to be updated
---> Package yum-fastestmirror.noarch 0:1.1.16-16.el5.centos set to be updated
--> Finished Dependency Resolution
hplip-1.6.7-6.el5.i386 from installed has depsolving problems
--> Missing Dependency: hpijs = 1:1.6.7-6.el5 is needed by package hplip-1.6.7-6.el5.i386 (installed)
Error: Missing Dependency: hpijs = 1:1.6.7-6.el5 is needed by package hplip-1.6.7-6.el5.i386 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

I tried installing hpijs but it said package not found..

What should i do?
 
Old 12-03-2011, 12:49 AM   #2
aazkan
Member
 
Registered: Jan 2008
Posts: 72

Rep: Reputation: 5
Hi Sarah,

If I'm not mistaken hplip rpm comes from hp for its printers and imaging device.

You could either do a

Code:
yum --skip-broken update
and then locate hpijs rpm from hp site and install it later.

Or if you dont need hp printer driver, rpm remove hplip, yum update and then figure out how to put hplip back in.

It would probably break something so check if you need hplip.

Btw, i found hpijs at pkgs.org and hplip at hplipopensource.com. Looks like third party rpm as in not from CentOS repo.
 
Old 12-04-2011, 11:59 PM   #3
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
when i did yum --skip-broken update it gave the following error:

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: mirror.nus.edu.sg
* extras: mirrors.sin1.sg.voxel.net
* updates: mirrors.sin1.sg.voxel.net
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
--> Processing Dependency: hpijs = 1:1.6.7-6.el5 for package: hplip
---> Package hpijs.i386 1:1.6.7-6.el5_6.1 set to be updated
--> Finished Dependency Resolution
hplip-1.6.7-6.el5.i386 from installed has depsolving problems
--> Missing Dependency: hpijs = 1:1.6.7-6.el5 is needed by package hplip-1.6.7-6.el5.i386 (installed)

Packages skipped because of dependency problems:
1:hpijs-1.6.7-6.el5_6.1.i386 from base


Now what should i do?
 
Old 12-05-2011, 12:05 AM   #4
SarahGurung
Member
 
Registered: Jul 2011
Posts: 322

Original Poster
Rep: Reputation: Disabled
Oh that's fine now,i removed dat hplip package itself..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Should I be updating my CentOS 4.6 server to CentOS 5.3? Ujjain Linux - Newbie 3 04-25-2009 08:00 AM
Missing dependency updating compiz-fusion on Fedora 8 tron_thomas Linux - Software 2 11-12-2007 11:44 AM
Updating VMWare After Updating CentOS Linux31 Red Hat 2 09-18-2007 02:49 PM
Strange missing dependency when updating 01d55 Fedora 2 06-19-2006 02:28 AM
Dependency error updating with YUM on Fedora Core 4 tron_thomas Linux - Software 7 04-18-2006 02:25 AM


All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration