LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-01-2003, 01:02 PM   #1
halfhaggis
LQ Newbie
 
Registered: Aug 2003
Location: Johannesburg, South Africa
Distribution: Ubuntu
Posts: 24

Rep: Reputation: 15
Dependency problem - I have the packages, but they're too new!


Having got used to Linux I've decided to get adventurous and try to recompile the kernel.
Problem is I didn't install the development tools when I originally installed RH9.

When I tried to install the development tools with the package manager it tells me I need krb5-libs = 1.2.7-14 and openssl = 0.9.7a-5.

But I've run up2date and updated a whole lot of stuff, so I actually have newer versions installed.

How do I get the package manager to realise this, or at least, ignore it, and install the packages anyway?

Thanks
 
Old 10-01-2003, 04:44 PM   #2
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
Up2date will only update packages that are allready installed.

To make sure you have the packages installed do the following from the konsole (or Gnome terminal):

rpm -qa | grep openssl
rpm -qa | grep krb5

If it returns a prompt with no package listing you need to install the packages from the RH CD. Otherwise it will list the installed rpm's and the version#

HTH
 
Old 10-04-2003, 05:58 AM   #3
halfhaggis
LQ Newbie
 
Registered: Aug 2003
Location: Johannesburg, South Africa
Distribution: Ubuntu
Posts: 24

Original Poster
Rep: Reputation: 15
OK, let's try that again. I seem to have explained badly.

Running redhat-config-packages I try to install the development packages. it tells me that I need:

krb5-libs-1.2.7-10
openssl-0.9.7a-2

I already have newer versions, namely

krb5-libs-1.2.7-14
openssl-0.9.7a-5

installed.

How do I get redhat-config-packages to install with no deps, or how do I downgrade the packages so that it will stop complaining?

Or, is there some other solution?
 
Old 10-04-2003, 07:07 AM   #4
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
One way would be to uninstall krb5-libs-1.2.7-14 and openssl-0.9.7a-5 completely. Then try to install the development packages and meet the dependency requirement for the two packages with he original versions from the CD.
 
Old 10-04-2003, 07:48 AM   #5
halfhaggis
LQ Newbie
 
Registered: Aug 2003
Location: Johannesburg, South Africa
Distribution: Ubuntu
Posts: 24

Original Poster
Rep: Reputation: 15
Ok. Here is the list of dependencies. Would you be brave enough to put the --nodeps argument at the end of that command? I'm not.

There must be another way.

#rpm -e krb5-libs openssl
error: Failed dependencies:
libcom_err.so.3 is needed by (installed) cyrus-sasl-2.1.10-4
libcom_err.so.3 is needed by (installed) pam_krb5-1.60-1
libcom_err.so.3 is needed by (installed) wget-1.8.2-9
libcom_err.so.3 is needed by (installed) curl-7.9.8-5
libcom_err.so.3 is needed by (installed) openssh-3.5p1-11
libcom_err.so.3 is needed by (installed) openssh-clients-3.5p1-11
libcom_err.so.3 is needed by (installed) openssh-server-3.5p1-11
libdes425.so.3 is needed by (installed) cyrus-sasl-md5-2.1.10-4
libdes425.so.3 is needed by (installed) pam_krb5-1.60-1
libgssapi_krb5.so.2 is needed by (installed) cyrus-sasl-2.1.10-4
libgssapi_krb5.so.2 is needed by (installed) wget-1.8.2-9
libgssapi_krb5.so.2 is needed by (installed) curl-7.9.8-5
libk5crypto.so.3 is needed by (installed) cyrus-sasl-2.1.10-4
libk5crypto.so.3 is needed by (installed) pam_krb5-1.60-1
libk5crypto.so.3 is needed by (installed) wget-1.8.2-9
libk5crypto.so.3 is needed by (installed) curl-7.9.8-5
libk5crypto.so.3 is needed by (installed) openssh-3.5p1-11
libk5crypto.so.3 is needed by (installed) openssh-clients-3.5p1-11
libk5crypto.so.3 is needed by (installed) openssh-server-3.5p1-11
libkrb4.so.2 is needed by (installed) pam_krb5-1.60-1
libkrb5.so.3 is needed by (installed) cyrus-sasl-2.1.10-4
libkrb5.so.3 is needed by (installed) pam_krb5-1.60-1
libkrb5.so.3 is needed by (installed) wget-1.8.2-9
libkrb5.so.3 is needed by (installed) curl-7.9.8-5
libkrb5.so.3 is needed by (installed) openssh-3.5p1-11
libkrb5.so.3 is needed by (installed) openssh-clients-3.5p1-11
libkrb5.so.3 is needed by (installed) openssh-server-3.5p1-11
libcrypto.so.4 is needed by (installed) python-2.2.2-26
libcrypto.so.4 is needed by (installed) cyrus-sasl-2.1.10-4
libcrypto.so.4 is needed by (installed) cyrus-sasl-md5-2.1.10-4
libcrypto.so.4 is needed by (installed) openldap-2.0.27-8
libcrypto.so.4 is needed by (installed) bind-utils-9.2.1-16
libcrypto.so.4 is needed by (installed) lftp-2.6.3-3
libcrypto.so.4 is needed by (installed) libwvstreams-3.70-8
libcrypto.so.4 is needed by (installed) pyOpenSSL-0.5.1-8
libcrypto.so.4 is needed by (installed) stunnel-4.04-3
libcrypto.so.4 is needed by (installed) wget-1.8.2-9
libcrypto.so.4 is needed by (installed) curl-7.9.8-5
libcrypto.so.4 is needed by (installed) gnome-vfs2-2.2.2-4
libcrypto.so.4 is needed by (installed) gnucash-1.8.1-3
libcrypto.so.4 is needed by (installed) licq-1.2.3-5
libcrypto.so.4 is needed by (installed) cups-libs-1.1.17-13.3
libcrypto.so.4 is needed by (installed) cups-1.1.17-13.3
libcrypto.so.4 is needed by (installed) openssh-3.5p1-11
libcrypto.so.4 is needed by (installed) openssh-clients-3.5p1-11
libcrypto.so.4 is needed by (installed) kdebase-3.1-15
libcrypto.so.4 is needed by (installed) openssh-server-3.5p1-11
libcrypto.so.4 is needed by (installed) sendmail-8.12.8-9.90
libssl.so.4 is needed by (installed) python-2.2.2-26
libssl.so.4 is needed by (installed) openldap-2.0.27-8
libssl.so.4 is needed by (installed) lftp-2.6.3-3
libssl.so.4 is needed by (installed) libwvstreams-3.70-8
libssl.so.4 is needed by (installed) pyOpenSSL-0.5.1-8
libssl.so.4 is needed by (installed) stunnel-4.04-3
libssl.so.4 is needed by (installed) wget-1.8.2-9
libssl.so.4 is needed by (installed) curl-7.9.8-5
libssl.so.4 is needed by (installed) gnome-vfs2-2.2.2-4
libssl.so.4 is needed by (installed) licq-1.2.3-5
libssl.so.4 is needed by (installed) cups-libs-1.1.17-13.3
libssl.so.4 is needed by (installed) cups-1.1.17-13.3
libssl.so.4 is needed by (installed) kdebase-3.1-15
libssl.so.4 is needed by (installed) sendmail-8.12.8-9.90
 
Old 10-04-2003, 08:14 AM   #6
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
He He He...

Why Not?

Well, if you downgrade the 2 packages, you'll get the same dependency errors as removing them(I believe). Is it a specifc developement rpm you are trying to install or are you installing an entire package group? What specificly are you trying to install and why?

Also, have you tried installing the older versions of the two packages (krb5-libs-1.2.7-14 and openssl-0.9.7a-5) in parallel with the newer versions or does this give you errors as well (i.e version blah obsoletes version blah blah)
 
Old 10-04-2003, 09:16 AM   #7
halfhaggis
LQ Newbie
 
Registered: Aug 2003
Location: Johannesburg, South Africa
Distribution: Ubuntu
Posts: 24

Original Poster
Rep: Reputation: 15
OK.
All fixed now.
I forced an install of the older versions with the aptly named "--force" argument, and voila! No more dependency problems (sighs of relief that everything didn't shudder to a dead halt).

No doubt I will proceed to do some serious damage once I recompile the kernel, but I think I'll fiddle with some lesser source code first.

Thanks for your help
 
Old 10-04-2003, 09:27 AM   #8
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
cool
 
Old 10-04-2003, 09:35 AM   #9
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
if you were doing that with an rpm

rpm -i --replacepkgs --oldpackages < filename >.rpm

would have done it too
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dependency problem black_man Debian 3 12-04-2005 07:55 PM
MPlayer dependency packages kdogksu Debian 6 09-15-2005 12:38 PM
dependency problem canyon289 Linux - Software 3 11-23-2004 01:03 AM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 09:03 PM
dependency problem - need help please lpriyamb Linux - Software 9 10-09-2003 03:45 AM


All times are GMT -5. The time now is 01:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration