LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   dependencies (http://www.linuxquestions.org/questions/linux-newbie-8/dependencies-276956/)

lnebrown 01-12-2005 01:31 PM

dependencies
 
I'm trying to install the latest version of Kino, but am making the newbie realization that the "tree" of dependencies can be very large, especially when your ISP access is dial-up. Is there any database out the that tracks the dependencies of mainstream applications and could give me an idea of how many days of dial-up downloading I have ahead?

Maybe my problem is that I have SUSE personal, rather than a more robust pro. distro?

On another note, when I do a ./configure and see a required package, should I worry about downloading a version that is too new compared to the required version listed?

__J 01-12-2005 02:08 PM

On the kino site or in the source directory in the README there should be something stating what it needs dependency wise. You can then match that up with whats on your system to see what you need.
Running suse though, make sure you have the corresponding -devel packages installed to whatever libraries it needs.

As far as too new of libraries, (generally speaking) as long as you are in the same major version (for example it needs gtkhtml-2.2 and you have gtkhtml-2.4 (but not gtkhtml-3.x.x)) you should be alright

vangelis 02-04-2005 01:35 PM

i have an installation problem too with kino
after installing all the depedencies and running ./configure it printed this message

checking for pkg-config... /usr/local/bin/pkg-config
checking for libglade-2.0 libgnomeui-2.0 >= 1.110.0... Package libglade-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libglade-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libglade-2.0' found

configure: error: Library requirements (libglade-2.0 libgnomeui-2.0 >= 1.110.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

i have installed both libglade-2.0 and libgnomeui-2.0
i tried changing the environment variable PGK_CONFIG_PATH to the directory which the libglade-2.0.pc is under with:

export PKG_CONFIG_PATH=/usr/lib/pkgconfig

but again when i try ./configure it prints the same error. is there anything else i can do about it?


All times are GMT -5. The time now is 06:06 PM.