LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2003, 06:27 PM   #1
robert_81
LQ Newbie
 
Registered: Aug 2003
Posts: 10

Rep: Reputation: 0
Dell 64Mb USB KeyChain


Hi I got a Dell 64Mb USB keychain. I got linux Mandrake 9.1 and connected the keychain. How can i access the data that;s on the key chain please? I really have no idea i went to check under /dev/usb but no items are there :\
 
Old 08-31-2003, 07:19 PM   #2
KneeLess
Member
 
Registered: May 2003
Distribution: Debian GNU/Linux 3.0 Sid, OpenBSD 3.5
Posts: 190

Rep: Reputation: 30
For some reason (that I don't understand) numerous sources say that you need to mount it as a SCSI device.

You can try:
Code:
mount -t /dev/sda1 /mnt/usb
Not sure if that'll work.

Here's another thread on this topic:
http://www.linuxquestions.org/questi...003/08/3/80226
 
Old 08-31-2003, 11:04 PM   #3
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
For Mandrake 9.1 using KDE, it should work automatically. When you plug the drive in, wait a few seconds and you should see an icon for the drive appear on the desktop. It is not mounted, but if you right click the icon and select mount, you should be able to do it (even as a regular user) and access files by double clicking the icon. The directory it is mounted at is /mnt/removable and the "removable" directory is created automatically. The drive is a SCSI device as mentioned above. It is normally /dev/sda1.
 
Old 09-01-2003, 12:01 AM   #4
Zb7
Member
 
Registered: Jul 2003
Location: Cincinnati, Ohio
Distribution: Slackware 9 (current), Gentoo 1.4, Redhat shrike
Posts: 86

Rep: Reputation: 15
Quote:
Originally posted by KneeLess
For some reason (that I don't understand) numerous sources say that you need to mount it as a SCSI device.

You can try:
Code:
mount -t /dev/sda1 /mnt/usb
Not sure if that'll work.

Here's another thread on this topic:
http://www.linuxquestions.org/questi...003/08/3/80226

It should. I have a Dell 64 meg flash and I mount it with that exact command.

This is just a backup opinion and I see no reason why that command shouldn't work.
 
Old 09-03-2003, 04:55 PM   #5
robert_81
LQ Newbie
 
Registered: Aug 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Question

Hi Guys I managed to mount the usb key chain though with this command mount /dev/sda1 /mnt/usb (without the -t). Each time I try to use the -t option I get the help of mount command which means it didn't work :\ I am able to see the files but under root only. Does the -t have to do with any permissions? Also I tried giving 777 permissions on the /mnt/ directory via mandrake control centre/security but still no luck. With root i am able to see the files but with user I have access denied on such files, any idea guys? Thanks very much in advance for your precious help
 
Old 09-03-2003, 05:01 PM   #6
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
The -t stands for "type" as is filesystem type. I think it would work if you typed:

mount -t vfat /dev/sda1 /mnt/usb

That is for the FAT filesystem, but I guess you don't need to indicate the type.

I'm surprised that you need to issue any command though. I use Mandrake 9.1 and it works automatically in KDE.
 
Old 09-03-2003, 05:09 PM   #7
robert_81
LQ Newbie
 
Registered: Aug 2003
Posts: 10

Original Poster
Rep: Reputation: 0
I use gnome not KDE maybe it makes a difference :\ Well I tried this and it is telling me /mnt/usb is already mounted or perhaps busy. How can I unmount it first so that I can mount it again in vfat file system? Thanks
 
Old 09-03-2003, 05:12 PM   #8
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
The command for unmounting is:

umount /dev/sda1

It is "umount" not "unmount" . Make sure you don't have anything accessing it. You can't be in the /mnt/usb directory when you unmount and you can't have nautalis(sp?) open to the /mnt/usb directory.
 
Old 09-03-2003, 05:28 PM   #9
robert_81
LQ Newbie
 
Registered: Aug 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Hi I mounted the device successfully as vfat but still, when i access it with nautalis the files dissapear, meaning that access is denied. Also this time the usb folder came up with the icon pencil crossed, which means no writing access. I want it read write access with the current user i am logged on :\ any ideas what it could be?
 
Old 09-03-2003, 05:36 PM   #10
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
Did you happen to look and see if you have a directory called /mnt/removable? If I remember correctly, Mandrake automatically created that directory when I plugged in a usb drive and created a link to it. Perhaps there is a problem having /mnt/usb and whatever Mandrake does automatically.
 
Old 09-03-2003, 05:46 PM   #11
robert_81
LQ Newbie
 
Registered: Aug 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Yes there is a directory /mnt/removable and in fact when i mount the key chain on that folder a link from the desktop is created automatically, but still with access denied :\ This is driving me mad :\
 
Old 09-03-2003, 06:15 PM   #12
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
OK, I think I have found the solution. Mount the drive using:

mount /dev/sda1 /mnt/removable

You have to be root (no -t needed). I just did this manually on my system from the Fluxbox window manager (so it should not be KDE-specific). I was able to read and write to the /mnt/removable directory as root.
 
Old 09-03-2003, 09:53 PM   #13
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Quote:
Originally posted by robert_81
Yes there is a directory /mnt/removable and in fact when i mount the key chain on that folder a link from the desktop is created automatically, but still with access denied :\ This is driving me mad :\
As root, edit your /etc/fstab file and look for a line containing /mnt/removable.

Somewhere at the end of the line, you will see some settings similar to: owner,ro,noauto

What you have to do is: if there is a owner defined there, change it to user, and if ro is defined change it to rw.

You should now have read and write access to /mnt/removable as root or user.
 
Old 09-04-2003, 07:48 PM   #14
robert_81
LQ Newbie
 
Registered: Aug 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Hi Guys,
Very bad news :\ i always mounted the usb keychain in root user (from shell) though i access the files as a user from the gui.. also Azmen, i am the owner of that check this line, what can i change from it please?

/dev/sda1 /mnt/removable auto user,iocharset=iso8859-15,kudzu,codepage=850,noauto,umask=0,exec 0 0

I'm so lost and cannot find any answer for this USB issue :\ with windows it just works there and then :\ I want it to work on Linux though :\ Any more ideas please?
 
Old 09-04-2003, 08:11 PM   #15
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Quote:
Originally posted by robert_81
Hi Guys,
Very bad news :\ i always mounted the usb keychain in root user (from shell) though i access the files as a user from the gui.. also Azmen, i am the owner of that check this line, what can i change from it please?

/dev/sda1 /mnt/removable auto user,iocharset=iso8859-15,kudzu,codepage=850,noauto,umask=0,exec 0 0

I'm so lost and cannot find any answer for this USB issue :\ with windows it just works there and then :\ I want it to work on Linux though :\ Any more ideas please?
Change it to:

Code:
/dev/sda1     /mnt/removable         auto         user,noauto,rw     0   0
And you're done!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH/keychain problem(?) tpe SUSE / openSUSE 0 05-16-2005 06:21 AM
using and mounting keychain memory levicc00123 Debian 4 08-08-2004 11:54 AM
booting from usb keychain drive etron Linux - Software 0 01-28-2004 12:32 PM
USB Camera not working with 64mb card kenh Linux - Hardware 1 12-11-2003 01:52 AM
Keychain ssh problem (bug????) pcwulf Linux - Security 3 11-27-2003 11:55 PM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration