LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-14-2010, 03:59 PM   #1
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Rep: Reputation: 15
Question Deleting Invalid Boots


I installed Ubuntu 9.10 and when I restart I have the option of 2 different Linux boots and my Windows 7 boot. The top Linux boot just takes me to a blank screen forever, and the 2nd one starts linux just fine. So I found a site saying I can type in: sudo gedit /boot/grub/menu.lst to bring up a file and actually delete the invalid boot(s), but when I type it in I get a blank document. What's wrong with my file?

---Edit---
Ok, I found out that Grub is now updated to Grub2 which is different. The file I was in is wrong. Also I saw somethign about a program called 'apt-get remove'. Is this what I use to fix the problem?

Last edited by Mrblurr; 03-14-2010 at 04:18 PM.
 
Old 03-14-2010, 04:34 PM   #2
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,606

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Quote:
Originally Posted by Mrblurr View Post
I installed Ubuntu 9.10 and when I restart I have the option of 2 different Linux boots and my Windows 7 boot. The top Linux boot just takes me to a blank screen forever, and the 2nd one starts linux just fine. So I found a site saying I can type in: sudo gedit /boot/grub/menu.lst to bring up a file and actually delete the invalid boot(s), but when I type it in I get a blank document. What's wrong with my file?

---Edit---
Ok, I found out that Grub is now updated to Grub2 which is different. The file I was in is wrong. Also I saw somethign about a program called 'apt-get remove'. Is this what I use to fix the problem?
Hi,

try

Code:
sudo gedit /boot/grub/grub.cfg
There you can look for the section you want to delete.
 
Old 03-14-2010, 04:55 PM   #3
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Original Poster
Rep: Reputation: 15
I found the section and when I try to delete it I get a message saying "You are trying to save the file on a read-only disk. Please check that you typed the location correctly and try again." I made a copy of the file just in case I screw up btw.
 
Old 03-14-2010, 05:05 PM   #4
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,606

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Quote:
Originally Posted by Mrblurr View Post
I found the section and when I try to delete it I get a message saying "You are trying to save the file on a read-only disk. Please check that you typed the location correctly and try again." I made a copy of the file just in case I screw up btw.
Backup is ALWAYS a good idea before editing something. From the error message I assume that you do have a seperate /boot partition, right? Try remounting it with read/write permission and then try editing the file again.
 
Old 03-14-2010, 05:15 PM   #5
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Original Poster
Rep: Reputation: 15
This is going to sound silly...but I understood read/write permissions and that's about it.
Not really sure what mounting really does/is. What do I mount?
 
Old 03-14-2010, 05:19 PM   #6
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,606

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Quote:
Originally Posted by Mrblurr View Post
This is going to sound silly...but I understood read/write permissions and that's about it.
Not really sure what mounting really does/is. What do I mount?
Well, mount makes partitions 'visible' to your system. What is the output of the following command:
Code:
sudo mount
BTW, what distro are you using?
 
Old 03-14-2010, 05:36 PM   #7
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Original Poster
Rep: Reputation: 15
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/mrblurr/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=mrblurr)

---
I'm using Ubuntu 9.10

Last edited by Mrblurr; 03-14-2010 at 05:40 PM.
 
Old 03-14-2010, 05:42 PM   #8
fbsduser
Member
 
Registered: Oct 2009
Distribution: Hackintosh, SlackWare
Posts: 267

Rep: Reputation: 30
The OP said he is using ubuntu 9.10. Also, does the second entry say something like "recovery" or something similar. Because if the first entry (the normal boot is usually the first entry) fails with a blank screen it's likelly that he doesn't have the correct video drivers (ATI or NVidia), the second entry usually is the "recovery" option which boots into vesa mode, hence why it booted fine for him.
 
Old 03-14-2010, 05:55 PM   #9
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Original Poster
Rep: Reputation: 15
fbsduser, My boot screen looks something like this from what I can remember; note that the * means it's the one that works.

Ubuntu, Linux 2.6.31-20-Generic
Ubuntu, Linux 2.6.31-20-Generic (Recovery Mode)
*Ubuntu, Linux 2.6.12-14-Generic (I'm not sure about the numbers on this one)
*Ubuntu, Linux 2.6.12-14-Generic (Recovery Mode)
Memtest86
Memtest86
Windows 7
 
Old 03-14-2010, 06:01 PM   #10
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,606

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Quote:
Originally Posted by Mrblurr View Post
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/mrblurr/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=mrblurr)

---
I'm using Ubuntu 9.10
Ok, I think I have a solution for you. First of all you do not have a seperate /boot partition. But the file /boot/grub/grub.cfg is simply read only. That is what is causing the trouble. gedit's error message is a bit confusing. Try the following:

Code:
sudo chmod 644 /boot/grub/grub.cfg
sudo gedit /boot/grub/grub.cfg
Edit and save the file, then exit gedit.
After that change back the permissions
Code:
sudo chmod 444 /boot/grub/grub.cfg
 
Old 03-14-2010, 06:42 PM   #11
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Original Poster
Rep: Reputation: 15
Ok, I did that, but I'm waiting on a program to download. I'll post again once I restart.
 
Old 03-14-2010, 07:00 PM   #12
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Original Poster
Rep: Reputation: 15
Worked like a charm. Thanks dude!
 
Old 03-14-2010, 07:15 PM   #13
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
hi

if you deleted the top entries because they currently don't work for you.......when you upgrade your kernel or if grub2 upgrades....those entries will re-appear.

2) so either post a new thread in the ubuntu forum on what errors you can see when you press Control + F1....to take you to the kernel message screen or
use your package manager to delete the kernel

3) if fbsduser is correct....we don't know because you have yet to post the info....it just a case of rebuilding the nvidia or closed source video driver for each new kernel you install .....assuming you use them

BTW try smxi script.....it can do it for you
 
Old 03-16-2010, 01:59 AM   #14
Mrblurr
Member
 
Registered: Mar 2010
Distribution: Ubuntu
Posts: 41

Original Poster
Rep: Reputation: 15
Now I've finally installed Ubuntu 64bit on my laptop and had the same problem, though this time I knew how to fix it. I have this annoyance that starts with the letter WINDOWS. When I start my laptop It takes me to the windows boot screen, I select Ubuntu, then I get the Ubuntu Boot screen. I want to remove teh windows boot screen and just have the ubuntu screen. Is there a way to do this?
 
Old 03-16-2010, 02:21 AM   #15
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,606

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Quote:
Originally Posted by Mrblurr View Post
Now I've finally installed Ubuntu 64bit on my laptop and had the same problem, though this time I knew how to fix it. I have this annoyance that starts with the letter WINDOWS. When I start my laptop It takes me to the windows boot screen, I select Ubuntu, then I get the Ubuntu Boot screen. I want to remove teh windows boot screen and just have the ubuntu screen. Is there a way to do this?
Since this is a laptop I assume you only have one HDD installed. So my guess would be that when you installed Ubuntu you did not choose to install Grub on the MBR. Is my assumption correct so far?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
redhat enterprise linux 4 boots slow with 2 GB RAM , boots fast with 512MB robinsingh Linux - Hardware 14 08-27-2008 12:34 AM
Fedora 9 boots (long delay) as single core if I go to GRUB menu, otherwise boots fine saravkrish Fedora 1 05-27-2008 08:59 AM
squirremail ...it says invalid user or invalid password. rnj Fedora 9 10-25-2004 10:56 PM
Deleting linux MBR so it boots to windows patman362 Linux - Software 10 08-18-2004 10:07 AM
dual boots................rather have rubber boots metal_monster Linux - Newbie 1 01-13-2004 01:24 PM


All times are GMT -5. The time now is 12:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration