LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2005, 03:01 PM   #1
blink_00
LQ Newbie
 
Registered: Oct 2004
Distribution: Suse 9.2 OpenExchange 4.1 United Linux
Posts: 13

Rep: Reputation: 0
delete user that doesnt show up in Yast??!


I have a user that i would like to add but somehow previously I banged it up and I am getting the error that 'user already exists'. Yet the user doesnt show up anywhere nor can I login with their name/password. What files can I edit that the system is checking that will nuke the user so I can retry and add them?? Not sure this is expained properly..... If I am not mistaken I can add users thru Yast or useradd?? but what do I edit to remove a user that doesnt show in Yast as a user?? Oh my brain hurts ......any help would be appreciated!

Suse 9.2 is what i am using.
 
Old 01-01-2005, 04:09 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,790

Rep: Reputation: 292Reputation: 292Reputation: 292
"I have a user that i would like to add but somehow previously I banged it up and I am getting the error that 'user already exists'."

First try getting rid of the "ghost" user using the userdel command. See man userdel

"What files can I edit that the system is checking that will nuke the user so I can retry and add them??"

/etc/passwd

However if you screw up /etc/passwd then nothing will work. I recommend that you fix the problem with userdel and useradd.

------------------------
Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ifconfig eth0 doesnt show up dongmin Linux - Networking 16 05-02-2005 10:04 AM
apache doesnt show what it should jelgavchik Linux - Software 1 02-20-2005 05:08 PM
apache doesnt show what it should jelgavchik Linux - Networking 3 02-20-2005 03:16 PM
YaST closes and doesnt do ANYTHING MadSkillzMan SUSE / openSUSE 10 11-19-2004 04:01 PM
yast doesnt start kromatic Linux - Newbie 8 08-26-2004 05:10 AM


All times are GMT -5. The time now is 12:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration