LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2008, 06:49 PM   #1
raphtor
Member
 
Registered: Aug 2008
Location: india
Posts: 174

Rep: Reputation: 30
default gcc installed from hardy cd does not produce executables


when i tried to install vlc in my system,at ./configure stage it showed an error stating gcc cannot produce executables.but my hardy system was not altered after installation and synaptic package manager showed gcc and gcc 4.2 already installed.what should i do?
 
Old 12-26-2008, 06:56 PM   #2
googlix
LQ Newbie
 
Registered: Oct 2007
Location: São Paulo - Brazil
Distribution: Debian Etch 4.1 r1
Posts: 12

Rep: Reputation: 0
Hi,

You can try installing linux headers and build essentials as follow:

# apt-get install build-essential
# apt-get install linux-headers-2.6.15-26**

** Replace to your current kernel version.

Hope this helps!
 
Old 12-26-2008, 07:17 PM   #3
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
Quote:
Originally Posted by raphtor View Post

when i tried to install vlc in my system,at ./configure stage it showed an error stating gcc cannot produce executables.
./configure probably produced several error messages. "gcc cannot produce executables" is probably the last error message. Look through the messages to find other error messages that give details of what is wrong.

-------------------
Steve Stites
 
Old 12-26-2008, 10:19 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
raphtor did you build the rather long list of prerequisites needed to build vlc?
 
Old 12-28-2008, 06:03 PM   #5
raphtor
Member
 
Registered: Aug 2008
Location: india
Posts: 174

Original Poster
Rep: Reputation: 30
heres the output for my latest effort of installation.








checking host system type... i686-pc-linux-gnulibc1
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
 
Old 12-28-2008, 07:56 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
and did you read the `config.log' to see what through the error?

Quote:
configure: error: C compiler cannot create executables
did you install
# apt-get install build-essential
# apt-get install linux-headers-2.6.15-26**

to build you will want all the build tools
a short list
autoconf
automake
automake14
automake15
automake16
automake17
binutils
bison
ccache
cmake
cscope
ctags
elfutils
flex
gcc
gcc-c++
gcc-objc
gdb
gettext
imake
indent
libtool
make
oprofile
oprofile-gui
patchutils
pkgconfig

PLUS all of the dev packages for all of the base packages that are required by vlc

why not use
Code:
apt-get install vlc

Last edited by John VV; 12-28-2008 at 07:58 PM.
 
Old 12-30-2008, 06:37 PM   #7
raphtor
Member
 
Registered: Aug 2008
Location: india
Posts: 174

Original Poster
Rep: Reputation: 30
yeah i did.but this time it terminated saying

......
Setting up mozilla-plugin-vlc (0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3.2) ...
Setting up vlc-plugin-esd (0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3.2) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place


what doed this mean?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GCC not installed by default in SUSE 10.1? *Xenny* SUSE / openSUSE 3 08-07-2006 10:02 AM
gcc cannot create executables?! nectron101 Linux - Software 4 04-23-2006 03:24 AM
gcc cant compile executables? slinky2004 Linux - Software 5 03-20-2005 02:15 AM
Making GCC Compile Executables? The Pentium Guy Debian 3 11-06-2004 10:38 AM
Creating executables with gcc punk_roks11 Linux - Newbie 2 07-28-2004 01:00 AM


All times are GMT -5. The time now is 12:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration