LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2005, 10:51 AM   #1
yoinker
LQ Newbie
 
Registered: Sep 2005
Location: Northern Ireland
Posts: 11

Rep: Reputation: 0
Default gateway and ip, won't stay. SuSe9.1 2.6.5-7.201


Hi all

As the title says, every time I restart the box, I have to give my wireless nic an IP, and set the default gateway, its set to get the ip through DHCP, and my router is set aswell. My network uses 192.168, everything else on the network gets its ip from the router. I use static ips on my network, but this box still doesn't pick it up from the router, once I give this box an ip using ifconfig eth1 <ip address> and set the default gateway using route add default gw <routers ip address> everything works fine, until I reboot.

Does anyone know why this happens, or what I can do to rectify the problem. Any help would be greatly appreciated.

Thanks all


Yoinker
 
Old 09-20-2005, 08:00 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi yoinker, welcome to lq.

There may be something to help you here.

http://www.novell.com/documentation/...l/ch14s03.html

good luck.
 
Old 09-21-2005, 12:58 PM   #3
yoinker
LQ Newbie
 
Registered: Sep 2005
Location: Northern Ireland
Posts: 11

Original Poster
Rep: Reputation: 0
Hi peacedog

Thank you very much for the link, after reading through it I created a file called ifcfg-eth-id-<wlan mac addy> in /etc/sysconfig/network. After re-booting, I could connect to my network but not outside, without using route add default gw. I searched some more and found a thread on this site with a problem similar to mine, basically, I have an onboard network card, which I havn't configured, and SuSe was trying to configure this, as this is on eth0, when it was unable to get an ip for this it ignored the wlan request, so I promptly disabled the onboard nic, and hey presto, all is in order. I think I can now go and delete the file fcfg-eth-id-<wlan mac addy> in /etc/sysconfig/network, as its a usb wlan card, and reading more I believe its configured by the ifcfg-wlan-bus-usb file in /etc/sysconfig/network, which is there .

Thanks again for the link.


Yoinker
 
Old 09-21-2005, 02:55 PM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Your welcome, glad you got it sorted.

good luck.
 
Old 09-21-2005, 03:02 PM   #5
yoinker
LQ Newbie
 
Registered: Sep 2005
Location: Northern Ireland
Posts: 11

Original Poster
Rep: Reputation: 0
Seems I was wrong about deleting the file fcfg-eth-id-<wlan mac addy> in /etc/sysconfig/network, when I did I couldn't connect to anything without ifconfig eth1 <ip address> and route add deafualt gw. So I created the file again, configured it and all is good again.



Yoinker
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Change Default Email in Suse9.3 0kkkw SUSE / openSUSE 3 01-25-2006 08:08 PM
Why does my SUSE9.3 choose twm as default WINDOWMANGER? seawolf Linux - Newbie 3 05-03-2005 08:46 AM
Setting up gateway using SUSE9.0 w/ Window2000 nebwray Linux - Networking 0 04-01-2004 05:47 PM
How can I modify the default desktop/menus for new users (KDE/SUSE9) brunobaptista Linux - Newbie 1 12-22-2003 06:24 AM
default gateway avikosan Linux - Networking 3 12-09-2003 06:47 PM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration