LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-13-2010, 11:24 AM   #1
rjnlinux
Member
 
Registered: Sep 2009
Posts: 41

Rep: Reputation: 0
default eth id


I am running a linux on a old desktop
It has two network cards

one which is on the motherboard which is 100 mbps and an additional new card 1 gbps

now the motherboard network card is assigned eth1 and the additional card is assigned eth0


I am trying to configure Oracle RAC on this Desktop and I need
eth0 to be the motherboard card

how do i change them.
 
Old 01-13-2010, 12:46 PM   #2
rjnlinux
Member
 
Registered: Sep 2009
Posts: 41

Original Poster
Rep: Reputation: 0
version

Linux version is Centos 5.3 which is similar to redhat
 
Old 01-13-2010, 05:30 PM   #3
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
I'm using CentOS 5.4 and I had same problem..

I did the following steps.

su -l
system-config-network &


clicked on hardware and deleted both eth devices, saved and exit.

turned my pc off, removed external eth.. which was assigned eth0

turned on my pc, now builtin network card was assigned eth0, checked for MAC binding... was all ready bind. turned off my pc.. installed external card.. booted system.....

problem was solved...

Cheers!!
 
Old 01-14-2010, 10:57 AM   #4
rjnlinux
Member
 
Registered: Sep 2009
Posts: 41

Original Poster
Rep: Reputation: 0
issue resolved

This is what I did for the Centos 5.3 box (This method also works for RedHat

open a terminal window and issue the command
ifconfig

note the contents


go to administration/network
disable/deactivate both network cards

open a terminal window logged in as root.

vi /etc/sysconfig/network-scripts/ifcfg-eth0
vi /etc/sysconfig/network-scripts/ifcfg-eth1

take the following line


HWADDR=00:19:B1:2A:BA:B8

and swap the lines from ifcfg-eth0 to ifcfg-eth1

save the files and go back to the admin/network screen and activate both the cards


run the command ifconfig again and note the contents- now you will see the info has changed.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Eth device names(or macs) be correlated to the physical eth port? VG1 Linux - Networking 1 12-01-2009 07:13 PM
Static routes using routes/ifroutes-eth-id.. files and default gateway disabled TimtheEagle Linux - Networking 0 05-31-2008 08:08 PM
Eth(X) getting me crazy! Help! pkgtool Slackware 5 05-15-2007 11:35 AM
how to switch eth for the default one on my multi card machine? wucan Linux - Networking 1 04-21-2006 03:41 AM
No eth ???? codedv Debian 6 12-24-2003 05:59 AM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration