LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-20-2014, 09:51 AM   #1
pete91
LQ Newbie
 
Registered: Jan 2014
Posts: 4

Rep: Reputation: Disabled
default device on sound card


hi,

how do i set a default devices on a soundcard

here is the result of aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

i want to make device 1, the digital output, default.

Thanks.
 
Old 01-20-2014, 06:03 PM   #2
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
This thread have the answers you seek!

Regards
 
Old 01-21-2014, 10:06 AM   #3
pete91
LQ Newbie
 
Registered: Jan 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
i think i am getting there but still need more help!

i have got this

pete@pete-media:/proc/asound$ cat pcm
00-00: ALC889 Analog : ALC889 Analog : playback 1 : capture 1
00-01: ALC889 Digital : ALC889 Digital : playback 1
00-02: ALC889 Alt Analog : ALC889 Alt Analog : capture 2
00-03: HDMI 0 : HDMI 0 : playback 1

now what do i need to do?
 
Old 01-21-2014, 01:50 PM   #4
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
What exactly are you trying to do?
Could you post the result of:
Code:
lspci -k | grep -A3 -i audio
Regards
 
Old 01-22-2014, 06:23 AM   #5
pete91
LQ Newbie
 
Registered: Jan 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
here are the results

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
Subsystem: Gigabyte Technology Co., Ltd Device a002
Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)

when i start up i want it to use the digital output, card 0 device 1

here is the result of aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
 
Old 01-22-2014, 07:16 AM   #6
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
as per link
show us the output to
cat /proc/asound/pcm

but it looks like it should be the same as your aplay as in hw:0,3 so

copy and paste this into a terminal logged in as a local user

Code:
echo "pcm.!default {
type hw
card 0
device3
} 
" > .asoundrc
log out then log back in

if you still have issues consider installing pulseaudio which allows on-the-swapping of output devices

good luck

Last edited by aus9; 01-22-2014 at 07:17 AM.
 
Old 01-23-2014, 04:42 AM   #7
pete91
LQ Newbie
 
Registered: Jan 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
pcm output

00-00: ALC889 Analog : ALC889 Analog : playback 1 : capture 1
00-01: ALC889 Digital : ALC889 Digital : playback 1
00-02: ALC889 Alt Analog : ALC889 Alt Analog : capture 2
00-03: HDMI 0 : HDMI 0 : playback 1
 
Old 01-23-2014, 06:29 PM   #8
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
yep looks good card 0 device 3---sorry for not reading post 3

when you create the (dot).asoundrc do a logout login or a full reboot
before playing test sound

if you don't like commands use your text editor so contents are

pcm.!default {
type hw
card 0
device3
}

save as .asoundrc (relative to your /home/pete

good luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Default sound device wrinkledcheese Slackware 3 10-07-2011 02:31 AM
[SOLVED] Default Device for Flash Sound vttay03 Slackware 7 07-12-2011 07:54 AM
[SOLVED] jackd as the default sound device nass Slackware 4 12-26-2010 01:57 PM
USB Sound Device as Default Skazi Linux - Hardware 1 07-15-2010 10:33 AM
Default Sound Device KHAAAN Linux - Hardware 3 07-27-2004 09:35 AM


All times are GMT -5. The time now is 04:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration