LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-15-2005, 12:17 AM   #1
ShreeK
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
default audio volume


Like several people using FC3 after initial install, my sound didn't work. I checked almost every audio app that comes with the distro, and finally found a wave controller in gnome-volume-control that was set to zero. I can increase that and it works fine. However every time I need to reboot my machine (I think it may also do it if i cycle the X server) the wave volume gets reset to 0. I haven't found anywhere to change this default. As a side note there are also 2 different wave controls (not talking about 2 channels for 1 wave control, there are 2 channels and 2 controls, for a total of 4 bars that I can move), the first wave controller is set to max volume (where I normally set the other to) and the second is set to zero (the one I have to adjust).
Any advice here would be greatly appreciated
 
Old 07-15-2005, 07:54 PM   #2
sketchydave
Member
 
Registered: Nov 2004
Location: Boston, MA
Distribution: Fedora Core and Ubuntu 6.06
Posts: 48

Rep: Reputation: 15
I had the same thing happen on Fedora Core 3. It took me forever to figure it out. But I was able to move all the sliders up and didn't have a problem after that. When I installed Fedora Core 4 I didn't run into it though. Fixed in the new version maybe?
 
Old 07-16-2005, 11:32 AM   #3
mohit dhawan
Member
 
Registered: Mar 2005
Posts: 92

Rep: Reputation: 15
just see if changing the volume in alsa hels
 
Old 07-16-2005, 11:51 AM   #4
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
as root run alsamixer in a terminal and set the volume to the required levels, then run `alsactl store`

The levels you set will then be automatically set every time you boot the computer
 
1 members found this post helpful.
Old 07-16-2005, 11:05 PM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
Quote:
Originally posted by phil.d.g
as root run alsamixer in a terminal and set the volume to the required levels, then run `alsactl store`

The levels you set will then be automatically set every time you boot the computer
yes there seems to be conflicting opinions about alsa shutdown script and if it should save current settings og hold one default setting.

you apearently have scripts that do the latter so you have to change the default by hand like phil.d.g
has said -- or still better change the alsa shutdown scritp to do it for you
 
Old 07-16-2005, 11:28 PM   #6
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
from rc.alsa in slackware - this may help (assuming you're using alsa )

Code:
#!/bin/sh
# Load the mixer settings and OSS compatibility for ALSA.
# (the Advanced Linux Sound Architecture)

# A function to load the ALSA mixer settings:
load_alsa_mixer() {
  if [ -r /etc/asound.state ]; then
    echo "Loading ALSA mixer settings:  /usr/sbin/alsactl restore"
    /usr/sbin/alsactl restore
  else
    echo "ALSA warning:  No mixer settings found in /etc/asound.state."
    echo "  Sound may be muted.  Use 'alsamixer' to unmute your sound card,"
    echo "  and then 'alsactl store' to save the default ALSA mixer settings"
    echo "  to be loaded at boot."
  fi
}

Last edited by Genesee; 07-16-2005 at 11:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio works, can't adjust volume yamaduc Fedora 3 10-04-2005 08:05 PM
alsa back audio volume bunnyknight13 Linux - General 2 09-01-2005 07:56 PM
fedora 4 and audio volume? whovian Linux - Newbie 2 07-18-2005 09:28 AM
Lifeview Flyvideo98 audio volume steve_v Linux - Hardware 0 05-29-2005 07:26 AM
Default Volume Settings malkc Linux - Newbie 1 12-31-2003 03:12 PM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration