LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2011, 11:40 AM   #1
leggend
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Rep: Reputation: 0
Smile Decoder for xvid mpeg-4


Hi guys, I did that:

rpm -Uvh http://download1.rpmfusion.org/free/...ble.noarch.rpm http://download1.rpmfusion.org/nonfr...ble.noarch.rpm

yum -y install gstreamer-plugins-bad gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-ugly gstreamer-ffmpeg

and then i play a video.avi but i can't run. an error appears and says to me that i need a complement fot XVID mpeg-4 layer to run it. so at finaly I downloaded and compiled that:

http://www.xvid.org/Downloads.43.0.html

but anyway i can't run my videos. Please, what do I have to do? Thank you very much
 
Old 01-15-2011, 11:42 AM   #2
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,029

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
not sure what you are using to try to run it. but i know that the default video player for fedora (totem) usually refuses to play certain videos no matter what i do.

mite i suggest vlc or mplayer or xine:

Code:
sudo yum install vlc mplayer xine
 
Old 01-16-2011, 08:08 AM   #3
leggend
LQ Newbie
 
Registered: Jan 2011
Posts: 6

Original Poster
Rep: Reputation: 0
ok I'll try it, I hope you are right.. Thank you very much. Then i'll tell you what happens.

edit: i'm trying to run videos from AVI extension. In the other hand, i descovered that I can run in my default video player files with MPEG extension

Edit again: Thanks Now I can run my vidieos. Thank you very much, my friend!

Last edited by leggend; 01-17-2011 at 04:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GPL MPEG-1/2 Decoder linux kuwaitikid Linux - Newbie 2 09-09-2010 11:38 PM
No suitable decoder module for XVID pradeepbp Linux - Software 12 07-22-2009 03:05 PM
Mpeg decoder Mr.curious Linux - Newbie 4 04-15-2006 10:36 AM
howto install mpeg hw/decoder driver for Via board longnam Slackware 1 05-31-2005 11:43 AM
linux compatible mpeg decoder card frieza Linux - Hardware 1 03-24-2003 12:20 AM


All times are GMT -5. The time now is 05:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration