LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   (Debian) xorg.conf file, (EE) Problem parsing the config file (http://www.linuxquestions.org/questions/linux-newbie-8/debian-xorg-conf-file-ee-problem-parsing-the-config-file-743438/)

unclerick94 07-28-2009 01:00 PM

(Debian) xorg.conf file, (EE) Problem parsing the config file
 
Hi, I'm running Debian Lenny, just reinstalled the OS.

I'm installing Compiz using this guide (http://www.debianadmin.com/how-to-in....html#more-326).
I've gotten up to the point where I configure the xorg.conf file.

The file was empty to begin with (I know it for sure, I used the point-and-click method of finding and editing the file in gedit), so I went ahead and added all of the required text provided in the guide.

xorg.conf :
Code:

Section "Screen"
        Option "XAANoOffscreenPixmaps" "true"
        Option "AddARGBGLXVisuals" "true"
EndSection
Section "Device"
        Option "AllowGLXWithComposite" "true"
        Option "RenderAccel" "true"
EndSection
Section "Server Layout"
        Option "AIGLX" "on"
EndSection
Section "Extensions"
        Options "Composite" "enable"
EndSection

I restarted the system before adding “compiz --replace” to “Desktop -> Preferences -> Sessions -> Startup Programs”.

As the system was booting up, a box said the X system had an error.

Parse Error on line 4 of the section Screen in file /etc/X11/xorg.conf
This section must have an identifier line
(EE) Problem parsing the config file
(EE) Error parsing the config file
Fatal Service error:
no screens found.

At the prompt, I moved the xorg.conf file to the Desktop for viewing, and the system booted up properly.


I'm assuming I screwed up somewhere in the xorg.conf file; something with the "identifier line".
If anyone knows the problem, could they provide the correct text for the xorg.conf file as well?


EDIT: And if anyone knows how to correctly install Compiz, can you provide a short guide on how to?

Thanks!

the trooper 07-28-2009 03:27 PM

It would appear that Debian does not generate an xorg.conf file by default anymore.
As you have correctly worked out you need to generate your own.
I think the easiest way forward is to delete the file you created and create a new one as follows:

Code:

ctrl-alt-f1
To exit the gui.
Login as root.

Code:

# /etc/init.d/gdm stop  (to stop gdm/kdm as required.)
# X -configure
# mv ~/xorg.conf.new /etc/X11/xorg.conf
# /etc/init.d/gdm start

You should now be back in the gui,but you need to logout as root:

Code:

ctrl-alt-f1 again.
ctrl-d
ctrl-alt-f7

Once you get to this point you should have a working xorg.conf file.
You should now be able to edit the file as necessary to enable compiz.
Can't help with compiz as i don't use it myself.


All times are GMT -5. The time now is 09:33 AM.