LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Debian upgrade fails 4 packages udev, can only boot into safemode (http://www.linuxquestions.org/questions/linux-newbie-8/debian-upgrade-fails-4-packages-udev-can-only-boot-into-safemode-829825/)

wikapuki 09-01-2010 07:29 PM

Debian upgrade fails 4 packages udev, can only boot into safemode
 
Hi,

Debian testing: Kernel: Linux 2.6.32-5-amd64

I can now only boot into safemode because I cannot get these 4 packages to upgrade:

udev
media-player-info
xserver-xorg-core
xserver-xorg-video-intel

udev refuses to configure.

The full output is below. I have removed (I made a copy 1st) all mention of virtualbox from /var/lib/dpkg/status and /var/lib/dpkg/available but that made no difference. Probably a bad thing to do.
It looks like this bug but I have no clue what they are on about and how to fix it.
http://bugs.debian.org/cgi-bin/bugre...?bug=%23590885

Code:

Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? warning, in file '/var/lib/dpkg/status' near line 38342 package 'virtualbox-3.0':
 error in Version string '3.0.12-54655_Debian_lenny': invalid character in revision number
warning, in file '/var/lib/dpkg/status' near line 38343 package 'virtualbox-3.0':
 error in Config-Version string '3.0.12-54655_Debian_lenny': invalid character in revision number
warning, in file '/var/lib/dpkg/available' near line 39382 package 'virtualbox-3.0':
 error in Version string '3.0.12-54655_Debian_lenny': invalid character in revision number
Setting up udev (161-1) ...
update-initramfs: deferring update (trigger activated)
insserv: Service mountkernfs has to be enabled to start service udev
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing udev (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of media-player-info:
 media-player-info depends on udev; however:
  Package udev is not configured yet.
dpkg: error processing media-player-info (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
 xserver-xorg-core depends on udev (>= 149); however:
  Package udev is not configured yet.
dpkg: error processing xserver-xorg-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-intel:
 xserver-xorg-video-intel depends on xorg-video-abi-6.0; however:
  Package xorg-video-abi-6.0 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-6.0 is not configured yet.
 xserver-xorg-video-intel depends on xserver-xorg-core (>= 2:1.7.6.901); however:
  Package xserver-xorg-core is not configured yet.
dpkg: error processing xserver-xorg-video-intel (--configure):
 dependency problems - leaving unconfigured
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-5-amd64
W: Possible missing firmware /lib/firmware/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl8168d-1.fw for module r8169
Errors were encountered while processing:
 udev
 media-player-info
 xserver-xorg-core
 xserver-xorg-video-intel

udev mentions about no doing apparts? and reports?

I have no idea what to do but ask for help here and go to bed.

AlucardZero 09-01-2010 08:20 PM

The last post in the report says the bug was fixed. Can you update dpkg?

You can try to start networking in single user mode, or download the package manually.

evo2 09-01-2010 08:44 PM

As suggested by AlucardZero upgrade to the latest dpkg if you have not done so already

Code:

% wget http://ftp.us.debian.org/debian/pool/main/d/dpkg/dpkg_1.15.8.4_amd64.deb
# dpkg -i pkg_1.15.8.4_amd64.deb

If you already have this and it doesn't work or if for some reason you can't install it,
then the easiest fix is probably to edit the status file and fix the version number. Make
sure you backup the file first.

WARNING UNTESTED COMMANDS BELOW.
EXTRA WARNING: NEED TO RUN AS ROOT.
Code:

cd /var/lib/dpkg
cp status status.back
sed 's/Version: 3.0.12-54655_Debian_lenny/Version: 3.0.12-54655/' < status.back > status

Evo2.

wikapuki 09-02-2010 07:32 AM

uname -a
Linux Flo64 2.6.32-5-amd64 #1 SMP Wed Aug 25 13:59:41 UTC 2010 x86_64 GNU/Linux

When I boot into single safe mode I have to manually start udev to get network going:
/etc/init.d/udev restart

I tried both of those solutions but still get the same problem.

Quote:

Originally Posted by evo2 (Post 4085461)
As suggested by AlucardZero upgrade to the latest dpkg if you have not done so already

Code:

% wget http://ftp.us.debian.org/debian/pool/main/d/dpkg/dpkg_1.15.8.4_amd64.deb
# dpkg -i pkg_1.15.8.4_amd64.deb

If you already have this and it doesn't work or if for some reason you can't install it,
then the easiest fix is probably to edit the status file and fix the version number. Make
sure you backup the file first.

WARNING UNTESTED COMMANDS BELOW.
EXTRA WARNING: NEED TO RUN AS ROOT.
Code:

cd /var/lib/dpkg
cp status status.back
sed 's/Version: 3.0.12-54655_Debian_lenny/Version: 3.0.12-54655/' < status.back > status

Evo2.

dpkg installed ok, thank you.
dpkg --version
Debian `dpkg' package management program version 1.15.8.4 (amd64)

This is the log o/p after last apt-get upgrade (also tried check and install --reinstall udev)
Code:

Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? warning, in file '/var/lib/dpkg/status' near line 38342 package 'virtualbox-3.0':
 error in Version string '3.0.12-54655_Debian_lenny': invalid character in revision number
warning, in file '/var/lib/dpkg/status' near line 38343 package 'virtualbox-3.0':
 error in Config-Version string '3.0.12-54655_Debian_lenny': invalid character in revision number
warning, in file '/var/lib/dpkg/available' near line 39382 package 'virtualbox-3.0':
 error in Version string '3.0.12-54655_Debian_lenny': invalid character in revision number
Setting up udev (161-1) ...
update-initramfs: deferring update (trigger activated)
insserv: Service mountkernfs has to be enabled to start service udev
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing udev (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of media-player-info:
 media-player-info depends on udev; however:
  Package udev is not configured yet.
dpkg: error processing media-player-info (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
 xserver-xorg-core depends on udev (>= 149); however:
  Package udev is not configured yet.
dpkg: error processing xserver-xorg-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-intel:
 xserver-xorg-video-intel depends on xorg-video-abi-6.0; however:
  Package xorg-video-abi-6.0 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-6.0 is not configured yet.
 xserver-xorg-video-intel depends on xserver-xorg-core (>= 2:1.7.6.901); however:
  Package xserver-xorg-core is not configured yet.
dpkg: error processing xserver-xorg-video-intel (--configure):
 dependency problems - leaving unconfigured
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-5-amd64
W: Possible missing firmware /lib/firmware/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl8168d-1.fw for module r8169
Errors were encountered while processing:
 udev
 media-player-info
 xserver-xorg-core
 xserver-xorg-video-intel

This is the dpkg.log o/p
Code:

2010-09-02 11:46:22 configure udev 161-1 161-1
2010-09-02 11:46:22 status half-configured udev 161-1
2010-09-02 11:46:22 status triggers-pending initramfs-tools 0.98.1
2010-09-02 11:46:22 trigproc initramfs-tools 0.98.1 0.98.1
2010-09-02 11:46:22 status half-configured initramfs-tools 0.98.1
2010-09-02 11:46:27 status installed initramfs-tools 0.98.1

There is this in dmesg but I don't think it has anything to to with the problem:
Code:

[  13.312131] /build/buildd-linux-2.6_2.6.32-21-amd64-bEMv9E/linux-2.6-2.6.32/debian/build/source_amd64_none/drivers/hid/usbhid/hid-core.c: usb_submit_urb(ctrl) failed
It did boot into the GUI before this started happening after the 1st update, but the mouse and keyboard would not work, so I reset the box and went into safemode boot, then did the apt-get update and then apt-get upgrade when this started.

Can I manually install udev? That seems to be a problem as it's not starting automatically.

wikapuki 09-02-2010 01:29 PM

With the help of evo2 and AlucardZero I have got rid of the
Quote:

error in Version string '3.0.12-54655_Debian_lenny': invalid character in revision number
But still cannot boot to X and udev does not start automatically but will start manually'ish after I boot into safemode:
/etc/init.d/udev start

During boot I am seeing bootmisc.sh fails

Still. the 4 packages will not upgrade or install manually with dpkg -i, here is the last log:
Code:

Log started: 2010-09-02  17:54:44
Setting up udev (161-1) ...
update-initramfs: deferring update (trigger activated)
insserv: Service mountkernfs has to be enabled to start service udev
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing udev (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of media-player-info:
 media-player-info depends on udev; however:
  Package udev is not configured yet.
dpkg: error processing media-player-info (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
 xserver-xorg-core depends on udev (>= 149); however:
  Package udev is not configured yet.
dpkg: error processing xserver-xorg-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-intel:
 xserver-xorg-video-intel depends on xorg-video-abi-6.0; however:
  Package xorg-video-abi-6.0 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-6.0 is not configured yet.
 xserver-xorg-video-intel depends on xserver-xorg-core (>= 2:1.7.6.901); however:
  Package xserver-xorg-core is not configured yet.
dpkg: error processing xserver-xorg-video-intel (--configure):
 dependency problems - leaving unconfigured
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-5-amd64
W: Possible missing firmware /lib/firmware/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl8168d-1.fw for module r8169
Errors were encountered while processing:
 udev
 media-player-info
 xserver-xorg-core
 xserver-xorg-video-intel
Log ended: 2010-09-02  17:54:49

My thought was to uninstall udev but when I saw this lot was going to be removed, I Pressed n ;-)
Code:

Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be REMOVED:
  alsa-base alsa-firmware-loaders alsa-utils apt-watch apt-watch-backend
  apt-watch-gnome backintime-gnome bleachbit brasero dasher deskbar-applet
  gdm3 gnome-about gnome-accessibility gnome-applets gnome-art gnome-bluetooth
  gnome-color-chooser gnome-core gnome-device-manager gnome-dictionary
  gnome-do gnome-do-docklets gnome-do-plugins gnome-launch-box gnome-mag
  gnome-main-menu gnome-netstatus-applet gnome-orca gnome-panel
  gnome-power-manager gnome-randr-applet gnome-schedule gnome-screensaver
  gnome-session gnome-session-bin gnome-user-share gnome-utils
  gnome-volume-manager gnome3-session gtweakui gvfs gvfs-backends hal
  hamster-applet initramfs-tools libbonoboui2-0 libgail-gnome-module libgdu0
  libgnome-device-manager0 libgnome2-0 libgnome2-perl libgnome2-ruby
  libgnome2-ruby1.8 libgnome2.24-cil libgnomeui-0 libpanel-applet2-0
  libpanel-applet2-ruby libpanel-applet2-ruby1.8 libswt-gnome-gtk-3.5-jni
  linux-image-2.6-amd64 linux-image-2.6.26-2-amd64 linux-image-2.6.30-2-amd64
  linux-image-2.6.32-3-amd64 linux-image-2.6.32-5-amd64 media-player-info
  mousetweaks nautilus nautilus-image-converter nautilus-share python-gnome2
  python-gnomeapplet python-gnomeprint python-pyatspi seahorse-plugins
  sshmenu-gnome system-config-lvm udev udisks update-notifier upower vinagre
  vuze xorg xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati
  xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-dummy
  xserver-xorg-video-fbdev xserver-xorg-video-glint xserver-xorg-video-i128
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-nv
  xserver-xorg-video-openchrome xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-radeonhd
  xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-tga
  xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-v4l
  xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo
0 upgraded, 0 newly installed, 127 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 517MB disk space will be freed.
Do you want to continue [Y/n]? Abort.

Not sure what to do, any ideas please?

wikapuki 09-02-2010 04:24 PM

uname -a
Linux Flo64 2.6.32-5-amd64 #1 SMP Wed Aug 25 13:59:41 UTC 2010 x86_64 GNU/Linux

Things just got stranger... I decided to start loads of things manually in /etc/init.d from safemode. Then did exit and that started the normal boot. It has booted into X ;-)
These are what I started manually:
Code:

/etc/init.d/udev start
/etc/init.d/console-setup start
/etc/init.d/console-screen.sh start
/etc/init.d/rc start
/etc/init.d/lvm2 start
/etc/init.d/kerneloops start
/etc/init.d/mountall-bootclean.sh start
/etc/init.d/mountall.sh start
/etc/init.d/dbus start
/etc/init.d/hal start
/etc/init.d/bootmisc.sh start
/etc/init.d/checkfs.sh start
/etc/init.d/fuse start
/etc/init.d/keyboard-setup start
/etc/init.d/mountdevsubfs.sh start
/etc/init.d/mountkernfs.sh start
/etc/init.d/mtab.sh start
exit


However the same u-nconfigured udev and 3 other packages remain, only now initramfs-tools has been added to the list, making 5 in total. This is because I did: dpkg-reconfigure initramfs-tools


Code:

Log started: 2010-09-02  20:54:50
Setting up udev (161-1) ...
update-initramfs: deferring update (trigger activated)
insserv: Service mountkernfs has to be enabled to start service udev
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing udev (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on udev (>= 0.086-1); however:
  Package udev is not configured yet.
dpkg: error processing initramfs-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of media-player-info:
 media-player-info depends on udev; however:
  Package udev is not configured yet.
dpkg: error processing media-player-info (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
 xserver-xorg-core depends on udev (>= 149); however:
  Package udev is not configured yet.
dpkg: error processing xserver-xorg-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-intel:
 xserver-xorg-video-intel depends on xorg-video-abi-6.0; however:
  Package xorg-video-abi-6.0 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-6.0 is not configured yet.
 xserver-xorg-video-intel depends on xserver-xorg-core (>= 2:1.7.6.901); however:
  Package xserver-xorg-core is not configured yet.
dpkg: error processing xserver-xorg-video-intel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 udev
 initramfs-tools
 media-player-info
 xserver-xorg-core
 xserver-xorg-video-intel
Log ended: 2010-09-02  20:54:51

The recovery mode failure script:
Starting NFS common utilities: statd.
startpar: service(s) returned failure: bootmisc.sh ... failed!

Anyone got any ideas please?

wikapuki 09-03-2010 01:11 PM

Solved by the original suggestions... plus one additional and reinstalling initscripts.

WARNING COMMANDS BELOW.
EXTRA WARNING: NEED TO RUN AS ROOT.
Code:

cd /var/lib/dpkg
cp status status.back
cp available available.back
sed 's/Version: 3.0.12-54655_Debian_lenny/Version: 3.0.12-54655/' < status.back > status
sed 's/Version: 3.0.12-54655_Debian_lenny/Version: 3.0.12-54655/' < available.back > available

Same error just happened on my other debian box, so have done the above before restart. Did not as yet need to re-install initscripts. Think that was due to my messing around.
uname -a
Linux jilldando 2.6.32-5-486 #1 Thu Aug 12 12:59:56 UTC 2010 i686 GNU/Linux


All times are GMT -5. The time now is 06:08 PM.