LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-10-2009, 09:36 PM   #1
Andre Zganiacz
LQ Newbie
 
Registered: Oct 2009
Posts: 5

Rep: Reputation: 0
debian update stoped working


I get the following message when I attempt to do software updates on my "Debian machine":
"Only one software management tool is allowed to run at the same time
Please close the other application e.g. 'aptitude' or 'Synaptic' first."

How do I resolve this problem?
I am a Linux illiterate. A typical answer from a Linux pro contains many alternatives. This is confusing. Please, could somebody suggest one course of action. Doesn't have to be the best way to do it, as long as it works.
Thank you,
Andre

Last edited by Andre Zganiacz; 10-10-2009 at 09:39 PM.
 
Old 10-10-2009, 09:52 PM   #2
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
try typing
Code:
killall -s FPE "apt-get"; killall -s FPE "aptitude"
then try again
 
Old 10-10-2009, 09:53 PM   #3
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello and welcome to LinuxQuestions,

As the error states, you have more than one instance of a package management tool running. Maybe on another desktop or hanging. Check all programs to see if one of them is Synaptic, Aptitude, or maybe on console level apt-get.

If you cannot find any instance open a console and check the running processes with the command
Code:
ps -ef
Kind regards,

Eric
 
Old 10-10-2009, 10:43 PM   #4
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,031

Rep: Reputation: 63
Quote:
Originally Posted by Andre Zganiacz View Post
I get the following message when I attempt to do software updates on my "Debian machine":
"Only one software management tool is allowed to run at the same time
Please close the other application e.g. 'aptitude' or 'Synaptic' first."

How do I resolve this problem?
I am a Linux illiterate. A typical answer from a Linux pro contains many alternatives. This is confusing. Please, could somebody suggest one course of action. Doesn't have to be the best way to do it, as long as it works.
Thank you,
Andre
Code:
ps aux
sudo kill -9 <process-id>
 
Old 10-11-2009, 04:17 AM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
This happens when update notifier in gnome is running (auto update)
disable it or remove it from the start menu.
 
Old 10-11-2009, 04:26 AM   #6
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Rep: Reputation: 112Reputation: 112
Anytime I update my system I stop the xserver then update as said in the above post the desktop could be running it to and hanging it up. you can use <ctr>+<alt>+<backspace> to stop the xserver. the run your update command and the after its done try starting with
Code:
sudo startx
hope that helps
 
Old 10-11-2009, 04:42 AM   #7
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
Originally Posted by jmc1987 View Post
Anytime I update my system I stop the xserver then update as said in the above post the desktop could be running it to and hanging it up. you can use <ctr>+<alt>+<backspace> to stop the xserver. the run your update command and the after its done try starting with
Code:
sudo startx
hope that helps
Why don't you disable auto-update?
If it's enabled, no need to do update by the command-prompt..
I always disable auto-update, I like to have control.
Killing X to update seems a little over the top, no?

Last edited by repo; 10-11-2009 at 05:22 AM.
 
Old 10-11-2009, 05:12 AM   #8
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Rep: Reputation: 112Reputation: 112
Quote:
Originally Posted by repo View Post
Why don't you disable auto-update?
If it's enabled, no need to do update by the command-prompt..
I allways disable auto-update, I like to have control.
Killing X to update seems a little over the top, no?
Considering you use less system resources that way your update may go a little faster if you have a slow system
 
Old 10-11-2009, 12:21 PM   #9
Andre Zganiacz
LQ Newbie
 
Registered: Oct 2009
Posts: 5

Original Poster
Rep: Reputation: 0
aditional info from author of question.

Just wanted to clarify.
I get the error message when I double click the orange icon (updates available notifier) in the upper right hand corner. It worked in the past and stooped about 7 months ago.

here is more info:
andrez83@DELL350MHZ:~$ ps -ef
UID PID PPID C STIME TTY TIME CMD
root 1 0 0 12:27 ? 00:00:03 init [2]
root 2 1 0 12:27 ? 00:00:00 [migration/0]
root 3 1 0 12:27 ? 00:00:00 [ksoftirqd/0]
root 4 1 0 12:27 ? 00:00:00 [events/0]
root 5 1 0 12:27 ? 00:00:00 [khelper]
root 6 1 0 12:27 ? 00:00:00 [kthread]
root 9 6 0 12:27 ? 00:00:00 [kblockd/0]
root 10 6 0 12:27 ? 00:00:00 [kacpid]
root 54 6 0 12:27 ? 00:00:00 [kseriod]
root 88 6 0 12:27 ? 00:00:00 [pdflush]
root 89 6 0 12:27 ? 00:00:00 [pdflush]
root 90 6 0 12:27 ? 00:00:00 [kswapd0]
root 91 6 0 12:27 ? 00:00:00 [aio/0]
root 550 6 0 12:27 ? 00:00:00 [khubd]
root 869 6 0 12:27 ? 00:00:00 [kjournald]
root 1046 1 0 12:27 ? 00:00:00 udevd --daemon
root 1318 6 0 12:28 ? 00:00:00 [kpsmoused]
root 1377 6 0 12:28 ? 00:00:00 [kgameportd]
root 1657 6 0 12:28 ? 00:00:00 [kmirrord]
daemon 1907 1 0 12:28 ? 00:00:00 /sbin/portmap
root 2138 1 0 12:28 ? 00:00:00 /sbin/klogd -x
root 2156 1 0 12:28 ? 00:00:00 /usr/sbin/hpiod
hplip 2205 1 0 12:28 ? 00:00:00 python /usr/sbin/hpssd
root 2291 1 0 12:28 ? 00:00:00 /usr/sbin/acpid -c /etc/acpi/eve
root 2319 1 0 12:28 ? 00:00:00 /usr/sbin/cupsd
103 2327 1 0 12:28 ? 00:00:00 /usr/bin/dbus-daemon --system
105 2335 1 0 12:28 ? 00:00:05 /usr/sbin/hald
root 2336 2335 0 12:28 ? 00:00:00 hald-runner
105 2342 2336 0 12:28 ? 00:00:00 hald-addon-acpi: listening on ac
105 2346 2336 0 12:28 ? 00:00:00 hald-addon-keyboard: listening o
root 2364 2336 0 12:28 ? 00:00:01 hald-addon-storage: polling /dev
root 2371 1 0 12:28 ? 00:00:00 /usr/sbin/dhcdbd --system
root 2378 1 0 12:28 ? 00:00:00 /usr/sbin/NetworkManager --pid-f
avahi 2393 1 0 12:28 ? 00:00:00 avahi-daemon: running [DELL350MH
avahi 2394 2393 0 12:28 ? 00:00:00 avahi-daemon: chroot helper
root 2401 1 0 12:28 ? 00:00:00 /usr/sbin/NetworkManagerDispatch
100 2448 1 0 12:28 ? 00:00:00 /usr/sbin/exim4 -bd -q30m
root 2459 2371 0 12:28 ? 00:00:00 /sbin/dhclient -1 -lf /var/lib/d
root 2470 1 0 12:28 ? 00:00:00 /usr/sbin/inetd
root 2477 1 0 12:28 ? 00:00:00 /usr/sbin/nmbd -D
root 2484 1 0 12:28 ? 00:00:00 /usr/sbin/smbd -D
root 2532 2484 0 12:28 ? 00:00:00 /usr/sbin/smbd -D
root 2543 1 0 12:28 ? 00:00:00 /usr/sbin/gdm
root 2548 2543 0 12:28 ? 00:00:00 /usr/sbin/gdm
root 2560 2548 3 12:28 tty7 00:01:03 /usr/bin/X :0 -dpi 96 -audit 0 -
statd 2573 1 0 12:28 ? 00:00:00 /sbin/rpc.statd
root 2600 1 0 12:28 ? 00:00:00 /usr/sbin/rpc.idmapd
root 2638 1 0 12:28 tty1 00:00:00 /sbin/getty 38400 tty1
root 2639 1 0 12:28 tty2 00:00:00 /sbin/getty 38400 tty2
root 2640 1 0 12:28 tty3 00:00:00 /sbin/getty 38400 tty3
root 2641 1 0 12:28 tty4 00:00:00 /sbin/getty 38400 tty4
root 2642 1 0 12:28 tty5 00:00:00 /sbin/getty 38400 tty5
root 2643 1 0 12:28 tty6 00:00:00 /sbin/getty 38400 tty6
root 2820 1 0 12:35 ? 00:00:00 /sbin/syslogd
andrez83 2821 2548 0 12:38 ? 00:00:01 x-session-manager
andrez83 2864 2821 0 12:38 ? 00:00:00 /usr/bin/ssh-agent /usr/bin/dbus
andrez83 2867 1 0 12:38 ? 00:00:00 /usr/bin/dbus-launch --exit-with
andrez83 2868 1 0 12:38 ? 00:00:00 /usr/bin/dbus-daemon --fork --pr
andrez83 2870 1 0 12:38 ? 00:00:01 /usr/lib/libgconf2-4/gconfd-2 5
andrez83 2873 1 0 12:38 ? 00:00:00 /usr/bin/gnome-keyring-daemon
andrez83 2875 1 0 12:38 ? 00:00:00 /usr/lib/bonobo-activation/bonob
andrez83 2877 1 0 12:38 ? 00:00:01 /usr/lib/control-center/gnome-se
andrez83 2880 1 0 12:38 ? 00:00:02 /usr/bin/metacity --sm-client-id
andrez83 2894 1 0 12:38 ? 00:00:04 gnome-panel --sm-client-id defau
andrez83 2896 1 0 12:38 ? 00:00:06 nautilus --no-default-window --s
andrez83 2900 1 0 12:38 ? 00:00:02 /usr/lib/gnome-panel/wnck-applet
andrez83 2902 1 0 12:38 ? 00:00:00 vino-session --sm-client-id defa
andrez83 2904 1 0 12:38 ? 00:00:00 bluetooth-applet
andrez83 2905 1 0 12:38 ? 00:00:00 gnome-volume-manager --sm-client
andrez83 2907 1 0 12:38 ? 00:00:01 update-notifier
andrez83 2911 1 0 12:38 ? 00:00:01 nm-applet --sm-disable
andrez83 2914 1 0 12:38 ? 00:00:00 /usr/lib/gnome-vfs-2.0/gnome-vfs
andrez83 2917 1 0 12:38 ? 00:00:00 gnome-cups-icon --sm-client-id d
andrez83 2923 1 0 12:39 ? 00:00:00 /usr/lib/nautilus-cd-burner/mapp
andrez83 2926 1 0 12:39 ? 00:00:00 /usr/lib/gnome-panel/notificatio
andrez83 2928 1 0 12:39 ? 00:00:00 /usr/lib/gnome-panel/clock-apple
andrez83 2935 1 0 12:39 ? 00:00:01 /usr/lib/gnome-applets/mixer_app
andrez83 2938 1 0 12:39 ? 00:00:00 gnome-power-manager
andrez83 2948 1 0 12:39 ? 00:00:00 gnome-screensaver
andrez83 2954 1 0 12:39 ? 00:00:01 /usr/lib/notification-daemon/not
andrez83 3222 1 20 12:50 ? 00:01:42 /usr/lib/iceweasel/firefox-bin -
andrez83 3424 1 7 12:58 ? 00:00:02 /usr/bin/gnome-terminal
andrez83 3427 3424 0 12:58 ? 00:00:00 gnome-pty-helper
andrez83 3428 3424 2 12:58 pts/0 00:00:00 bash
andrez83 3455 3424 8 12:58 pts/1 00:00:00 bash
andrez83 3474 3428 0 12:58 pts/0 00:00:00 ps -ef
andrez83@DELL350MHZ:~$
 
Old 10-12-2009, 04:40 AM   #10
Andre Zganiacz
LQ Newbie
 
Registered: Oct 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Hi,

Thank you everyone for various helpful hints. I haven't been able to resolve my problem yet. I can't figure out which process is interfearing with what other process. I'd like to understand the problem better rather than just killing processes at random

My previous post has a listing of all my running processes.
Thank you again for your help so far and I hope somebody will take a peek at the list of my running processes.

Andre
 
Old 10-12-2009, 05:14 AM   #11
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
andrez83 2907 1 0 12:38 ? 00:00:01 update-notifier
Kill this pid, or disable update-notifier in gnome
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get stoped working mungulish Debian 22 07-15-2007 03:53 PM
amsn stoped working hgb Linux - Software 2 07-15-2006 06:27 PM
Apache stoped working letsinstalllinu Linux - General 2 01-18-2005 06:07 PM
CDROM stoped working Joey.Dale Linux - General 6 11-27-2003 11:45 PM
mozilla stoped working allohakdan Linux - Newbie 4 10-30-2003 12:49 PM


All times are GMT -5. The time now is 08:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration