LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-25-2005, 02:32 PM   #1
darkmagic
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Rep: Reputation: 0
Debian Startup Issues !!


Hi Guys,

I am an absolute newbie when it comes to linux and/or unix, so please forgive for the noobness

I had a quick question. Just installed Debian on my computer, but whenever i start the computer it takes me to the GUI login manager. Well, i don't want any GUI when i start my linux box, i want it to boot into the login prompt. I have read a little bit & i gather that i will have to change the "inittab" file I would have to change the default runlevel but what i want to know is what runlevel do i change it to so that i boot into the logon prompt.
 
Old 08-25-2005, 03:01 PM   #2
danimalz
Member
 
Registered: Jul 2005
Location: West Coast South, USA
Distribution: debian 3.1
Posts: 267

Rep: Reputation: 36
Debian runlevels are all the same (aside from 1 and 6).

The default runlevel is 2.

I think the best way to do this would be to remove or rename the link in /etc/rc2.d that points
to the gdm script in /etc/init.d

im pretty sure this would work.
 
Old 08-25-2005, 03:17 PM   #3
darkmagic
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Why only delete or rename the gdm script in /etc/init.d, why not any others ?

I told ya i am an absolute newbie, thanks for the advise though
 
Old 08-25-2005, 03:29 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,514

Rep: Reputation: 69
Quote:
Originally posted by darkmagic
Why only delete or rename the gdm script in /etc/init.d, why not any others ?

I told ya i am an absolute newbie, thanks for the advise though
Not in /etc/init.d in /etc/rc2.d is where you would remove/rename the script. The reason you do this is if link is not there then GDM/X will not be started when using the default runlevel which is 2. Oh and it is only 2-5 that are configured identically 1 is for single user/rescue mode and 6 is shutdown. Once you delete the link you will have to use startx at the command prompt to get X/GDM to start. Also I notice you do not say which graphical display manager you are using so you may have to delete/rename eith KDM, GDM, XDM or WDM depending on which you are using just look for the ones with S99 in front of them like here.

Code:
>$ ls -l /etc/rc2.d/
total 0
lrwxrwxrwx  1 root root 18 2005-08-21 10:19 S10sysklogd -> ../init.d/sysklogd
lrwxrwxrwx  1 root root 15 2005-08-21 10:19 S11klogd -> ../init.d/klogd
lrwxrwxrwx  1 root root 17 2005-08-21 18:55 S13apcupsd -> ../init.d/apcupsd
lrwxrwxrwx  1 root root 13 2005-08-21 10:19 S14ppp -> ../init.d/ppp
lrwxrwxrwx  1 root root 14 2005-08-21 20:00 S19lirc -> ../init.d/lirc
lrwxrwxrwx  1 root root 22 2005-08-21 14:56 S19spamassassin -> ../init.d/spamassassin
lrwxrwxrwx  1 root root 16 2005-08-21 19:13 S20cupsys -> ../init.d/cupsys
lrwxrwxrwx  1 root root 20 2005-08-21 14:56 S20dcc-client -> ../init.d/dcc-client
lrwxrwxrwx  1 root root 17 2005-08-21 14:12 S20dirmngr -> ../init.d/dirmngr
lrwxrwxrwx  1 root root 15 2005-08-22 12:24 S20exim4 -> ../init.d/exim4
lrwxrwxrwx  1 root root 17 2005-08-21 13:43 S20hddtemp -> ../init.d/hddtemp
lrwxrwxrwx  1 root root 15 2005-08-21 10:19 S20inetd -> ../init.d/inetd
lrwxrwxrwx  1 root root 17 2005-08-21 10:18 S20makedev -> ../init.d/makedev
lrwxrwxrwx  1 root root 20 2005-08-24 16:10 S20nvidia-glx -> ../init.d/nvidia-glx
lrwxrwxrwx  1 root root 13 2005-08-21 14:12 S20ssh -> ../init.d/ssh
lrwxrwxrwx  1 root root 13 2005-08-21 14:13 S20xfs -> ../init.d/xfs
lrwxrwxrwx  1 root root 16 2005-08-21 14:15 S20xprint -> ../init.d/xprint
lrwxrwxrwx  1 root root 14 2005-08-21 10:19 S89cron -> ../init.d/cron
lrwxrwxrwx  1 root root 16 2005-08-22 01:10 S91apache -> ../init.d/apache
lrwxrwxrwx  1 root root 13 2005-08-21 14:15 S99kdm -> ../init.d/kdm
lrwxrwxrwx  1 root root 19 2005-08-21 10:18 S99rmnologin -> ../init.d/rmnologin
lrwxrwxrwx  1 root root 23 2005-08-21 10:18 S99stop-bootlogd -> ../init.d/stop-bootlogd
lrwxrwxrwx  1 root root 13 2005-08-21 14:15 S99xdm -> ../init.d/xdm
 
Old 08-25-2005, 03:52 PM   #5
darkmagic
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Wow, very good explaination, ever thought of writing a book

And yes i am using GDM.

So, i guess

lrwxrwxrwx 1 root root 13 2005-08-21 14:15 S99xdm -> ../init.d/gdm

is the line that i need to either delete or comment out ??

Oh, & yes how do we comment out a line in a file ???

Thanx in advance.
 
Old 08-25-2005, 04:08 PM   #6
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Hi,

Alt Gr + #


regards
 
Old 08-25-2005, 04:10 PM   #7
danimalz
Member
 
Registered: Jul 2005
Location: West Coast South, USA
Distribution: debian 3.1
Posts: 267

Rep: Reputation: 36
Quote:
Originally posted by darkmagic
Wow, very good explaination, ever thought of writing a book

And yes i am using GDM.

So, i guess

lrwxrwxrwx 1 root root 13 2005-08-21 14:15 S99xdm -> ../init.d/gdm

is the line that i need to either delete or comment out ??

Oh, & yes how do we comment out a line in a file ???

Thanx in advance.
I dont think that files themselves can be commented out. In this case, u can simply rename the link by
replace the leading S with lowercase, so that it becomes s99xdm

This way you can restore it later.
 
Old 08-25-2005, 04:41 PM   #8
darkmagic
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by danimalz
I dont think that files themselves can be commented out. In this case, u can simply rename the link by
replace the leading S with lowercase, so that it becomes s99xdm

This way you can restore it later.
Thanks a lot, as far as i understand that Caps "S" there means that it has to Start the process with the id 99 so that it starts in the end & xdm ofcourse is the name of the grapical login manager.

But what happens when we change the Caps "S" to Smalls "s", i mean how would linux interpret it ?
 
Old 08-25-2005, 07:10 PM   #9
darkmagic
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Wow, perfect, i was able to boot onto the login prompt just by changing the

/etc/rc2.d entry poiting to the gdm login manager.

Thanx a ton people.

But i still have a question.

Since for browsing the internet i need to use the browser, & for doing that i need to start one of the graphical interfaces. When i started gdm as i normally get its resolution is stuck at 640x480. When i try to change the resolution it does not even gives me an option for higher resolution.

I guess that's because i have not installed the drivers for my video card, & its using some generic drivers for creating the graphics, but then how do i install the drivers for my graphics card on linux, although i still have the graphics card CD with me.
 
Old 08-25-2005, 07:22 PM   #10
corfe
Member
 
Registered: Dec 2004
Location: Washington State, USA
Distribution: Debian Sid
Posts: 128

Rep: Reputation: 16
Maybe I missed something, but why not simply remove GDM if you're not using it? "apt-get remove gdm" or "apt-get --purge remove gdm" to remove it and its config files as well.

Alternatively, if for some reason you want gdm to exist on your hard drive but you don't want it to start up with the computer, you can go to the file "/etc/X11/default-display-manager" and simply make the contents of the file blank (there should just be one line there: "/usr/bin/gdm" - just remove that line, save the file as blank).

-------

With the above 2 ways, you don't need to delete symlinks / files any packages created, or change any lines in Debian's scripts.

If you change a script that came with your system (or is part of a package you installed), then every time you upgrade the package that contains the script, Debian won't know what to do and will ask for user intervention - "user changes detected - would you like to install the maintainer's version, or keep your own?" etc. If you install the maintainer's version, then you lose your changes to the script, and if you keep your version, you lose whatever the Debian maintainer improved in that script for the new version.
 
Old 08-26-2005, 01:07 AM   #11
darkmagic
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Is there no solution to this graphics driver problem, if yes what is the solution please ?
 
Old 08-26-2005, 01:41 AM   #12
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,514

Rep: Reputation: 69
Quote:
Originally posted by darkmagic
Is there no solution to this graphics driver problem, if yes what is the solution please ?
You would need to change the refresh rates for your monitor in the X config file if using xfree86 use as root dpkg-reconfigure xserver-xfree86 if xorg then dpkg-reconfigure xserver-xorg choose the advanced option when asked. Now you should have already searched on refresh rates and your monitor name/model on google to find the proper ones or if you have the book that came with it they should be there in it. When asked for them during the reconfigure enter them in the dialog now when asked choose higher resolutions eg 1024x768, 800x600 in that dialog you should check in the search/documentation you have for the highest your monitor will support. Now when you start the X server it should use the highest resolution you have entered that your monitor will support. If this does not do it for you can you post your X config file (/etc/X11/XF86Config-4 or /etc/X11/xorg.conf) and the log file (/var/log/XFree86.0.log or /var/log/Xorg.0.log) so we can see what is being used and what the sever says it is doing.
 
Old 08-26-2005, 01:59 AM   #13
anishparameswaran
LQ Newbie
 
Registered: Aug 2005
Location: india
Distribution: Debian
Posts: 2

Rep: Reputation: 0
To Increase Resolution ....

hai friend ...

The file /etc/X1/XF86Config-4 ( or XF86Config) can help you improve theYT
screen resolution . Take the file in an editor and modify the entries
related to default color depth and modes in the section Screen . It may look like this ..



DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection

Then you retstart gdm ( or restart the system ... the easy way) using the command
(do it from a text terminal )

# /etc/init.d/gdm restart

if u are not using gdm ... retstart the appropriate display manager.


Good Luck ... Thanks ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.1 startup issues conner19 Linux - Newbie 16 09-24-2005 03:10 PM
Slack uninstall and startup issues Aphex_Twin2 Slackware 9 05-07-2005 12:43 PM
Startup Issues LinuxLoverMeg Mandriva 3 09-24-2004 01:18 AM
FC2 startup issues msie02 Fedora 0 09-19-2004 11:44 AM
VncServer - Startup issues TrueSword Linux - General 1 12-06-2002 06:13 PM


All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration