LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-05-2012, 06:38 AM   #1
cfoek
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Rep: Reputation: Disabled
Debian Squeeze Mount Problem


hai all

got problem when i insert a usb flash system assign as sda1, then i search on /dev there is no sda1

i can manually add sda1 with mknod my question is how i can make system automatic create sda , sdb ,sdc dll every time i insert a usb device ?

and how i can make it auto mount on my debian ?

i'm new to linux so anyone gan give me short tutorial plz and the command .... thx

sorry about my English thx
 
Old 02-05-2012, 06:52 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
Those device nodes should be created automatically and , depending on your desktop environment, should be auto-mounted.
Which version of Debian are you running on which hardware? Have you made a default install? Which desktop environment/ window manager are you using?
 
Old 02-05-2012, 08:45 AM   #3
cfoek
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
@tobisgd

that is my problem because i using a Android Pad (EKEN M003) and i'm use debian from slate**oid img


it has a autofs and udev installed but on lsmod no module for usb loaded
so can u help me ? because i new to linux no idea where to start
 
Old 02-05-2012, 08:51 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
Sorry, I don't know anything about Debian on Android.
If you are new to Linux I recommend to make your first steps on a PC with a "classical" distribution.
 
Old 02-05-2012, 09:04 AM   #5
cfoek
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
it's okay tobisgd but are you know why node are not create on /dev ?
when i check dmesg system already identify my usb flash and set to /dev/sda1 ? strange

basic the linux debian i use almost same on the desktop(i use vmware with ubuntu)

but thanks for help tobisgd

Last edited by cfoek; 02-05-2012 at 09:21 AM.
 
Old 02-05-2012, 09:48 AM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
This is handled by udev normally, IIRC. So you may have a problem with your udev install.
 
Old 02-05-2012, 10:05 AM   #7
cfoek
LQ Newbie
 
Registered: Feb 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
ow ic ic okay thanks for you help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount Galaxy Nexus LTE Debian Squeeze prickee Linux - Mobile 0 01-26-2012 05:34 PM
unable to mount devices in debian squeeze kjjohny1991 Linux - Newbie 3 12-30-2011 02:40 AM
[SOLVED] thunar stopped to mount USB storages (Debian squeeze) kaz2100 Debian 11 09-27-2011 02:21 AM
Various segmentation faults Debian Squeeze Virtualbox running on Debian Squeeze host fordwrench Debian 1 07-21-2011 03:55 AM
[SOLVED] Moving /usr from '/' on sda1 to sda7 -- System is Debian Squeeze: sda7 doesn't mount Learnix Linux - General 5 04-11-2011 08:32 AM


All times are GMT -5. The time now is 10:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration