LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2011, 03:22 PM   #1
b80amyt
LQ Newbie
 
Registered: Feb 2011
Location: California USA
Posts: 3

Rep: Reputation: 0
debian opens in text. not GUI


I have installed Debian from the disk in the Linux bible and the mirrors in the US and Oregon State. The first time was successful but lasted only only a couple of days before it was corrupted. Subsequent installations have all ended with an installation that opens with a text screen login. What should I enter to convert to GUI?
 
Old 02-19-2011, 03:54 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Usually you need to type 'startx' to start GUI.

What's the output of:

Code:
less /etc/inittab | grep id
 
Old 02-19-2011, 03:57 PM   #3
dudeman41465
Member
 
Registered: Jun 2005
Location: Kentucky
Distribution: Ubuntu
Posts: 794

Rep: Reputation: 56
Quote:
Originally Posted by b80amyt View Post
I have installed Debian from the disk in the Linux bible and the mirrors in the US and Oregon State. The first time was successful but lasted only only a couple of days before it was corrupted. Subsequent installations have all ended with an installation that opens with a text screen login. What should I enter to convert to GUI?
Try running the command "startx". If that doesn't work you may have to try it with sudo, "sudo startx". If this works and you get into graphical mode there's a way to edit which mode the machine starts up in, but the file you used to be able to edit doesn't exist in my version of Ubuntu for some reason. It used to be editing /etc/inittab and changing the default runlevel to 5 instead of 3.
 
0 members found this post helpful.
Old 02-19-2011, 04:00 PM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Quote:
Originally Posted by dudeman41465 View Post
Try running the command "startx". If that doesn't work you may have to try it with sudo, "sudo startx". If this works and you get into graphical mode there's a way to edit which mode the machine starts up in, but the file you used to be able to edit doesn't exist in my version of Ubuntu for some reason. It used to be editing /etc/inittab and changing the default runlevel to 5 instead of 3.
In debian runlevels 2-5 are the same.
 
Old 02-19-2011, 04:02 PM   #5
Kyffer
LQ Newbie
 
Registered: Feb 2011
Posts: 1

Rep: Reputation: 1
If startx doens't work, it might be a bug in the Debian 6.0 installer. I have also seen problem with Debian not installing Gnome, even that you choose it. So many bugs in Debian 6, which should been consider stable :s

Anyhow, if startx doesn't work, try login as root and type:

aptitude install gnome

I hope this helps?
 
1 members found this post helpful.
Old 02-19-2011, 04:03 PM   #6
dudeman41465
Member
 
Registered: Jun 2005
Location: Kentucky
Distribution: Ubuntu
Posts: 794

Rep: Reputation: 56
Just found this topic with some searching around, maybe it will help you out. It refers to Ubuntu which is Debian based.

http://www.linuxquestions.org/questi...nlevel-840310/
 
Old 02-20-2011, 05:25 AM   #7
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
Once again:
Quote:
Originally Posted by sycamorex View Post
In debian runlevels 2-5 are the same.
And why "sudo startx" ?
(usually sudo ain't configured in Debian, so the command would not work. And it does not make any sense to try that a all).

Like already said: probably gnome is not installed (to put it different: No gui at all).
 
1 members found this post helpful.
Old 02-20-2011, 06:40 AM   #8
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Quote:
Originally Posted by j1alu View Post
Like already said: probably gnome is not installed (to put it different: No gui at all).
That or possibly a driver issue?
We need to wait for OP's feedback.
 
Old 02-20-2011, 09:34 PM   #9
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,346
Blog Entries: 12

Rep: Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731
Another thing to check:

My understanding is that, if a display manager such as gdm isn't installed in Debian, it will boot to the command line. Then the procedure is to login as desired user and issue startx for the GUI.

I suspect that "sudo startx" would start x with root privileges. My guess it that user would then encounter issues in trying to use x.

I haven't tried it yet, but it's on my list, because I'd rather boot to the command line. It's the Slacker in me.
 
Old 02-21-2011, 03:17 AM   #10
austinium
Member
 
Registered: Nov 2007
Location: India
Distribution: Debian Stable, Debian Testing
Posts: 218

Rep: Reputation: 27
Check if GNOME is installed
Code:
$ dpkg -l|grep gnome-desktop-environment
Back in Lenny i used to reconfigure xserver-xorg and then run startx when I would run into a situation like the one the OP is facing(assuming GNOME is installed)
Code:
#dpkg-reconfigure xserver-xorg
I am not sure if this will work for Squeeze though.

Another option would be to run
Code:
#X -configure
or
Code:
#Xorg -configure
However, as the previous posts have mentioned, if there is no GUI installed then none of these would work...
 
Old 02-21-2011, 03:33 AM   #11
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Did Op choose to use mirrors during installation.
I only ask because on 1 of my previous installs a long long time ago I chose not to use mirrors during install and it only installed base package.
 
Old 02-21-2011, 09:43 PM   #12
b80amyt
LQ Newbie
 
Registered: Feb 2011
Location: California USA
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks, I tried them all

Nothing worked, so I'm buying a CD.
 
Old 02-22-2011, 12:43 AM   #13
silvyus_06
Member
 
Registered: Oct 2010
Distribution: Ubuntu 10.04 , Linux Mint Debian Edition , Microsoft Windows 7
Posts: 390

Rep: Reputation: 50
Quote:
Originally Posted by b80amyt View Post
Nothing worked, so I'm buying a CD.
if you have the money at least i suggested getting the dvd, as the ubuntu CD holds way less packages than the DVD
 
Old 02-22-2011, 01:19 AM   #14
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
After login
type in
aptitude

you will be able to see
packages available, installed, new packages and another package, I forget which one.
Under installed packages how many are there?
 
Old 02-22-2011, 06:04 AM   #15
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,811
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Quote:
Originally Posted by b80amyt View Post
Nothing worked, so I'm buying a CD.
Hold on, what do you mean nothing worked?!!!

What's the error when you 'startx'?
What's the error when you 'sudo apt-get install gnome'?
What's the output of :
Code:
less /etc/inittab | grep id
what about austinium's suggestion?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
any url opens same site on debian lenny fraksken Linux - Server 2 02-07-2010 07:08 AM
LXer: Howto Boot debian in text mode instead of graphical mode (GUI) LXer Syndicated Linux News 0 09-09-2007 08:41 PM
LXer: Vyatta Opens Router To Debian Application Universe LXer Syndicated Linux News 0 12-13-2006 01:54 AM
Text Mode vs. GUI Madone_SL_5.5 Linux - Server 7 12-01-2006 04:04 PM
Running program in GUI opens term window zer0hmz Linux - Newbie 2 08-05-2006 03:36 AM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration