LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2015, 06:03 PM   #31
Amarildo
Member
 
Registered: Jun 2014
Posts: 176

Rep: Reputation: Disabled

Quote:
Originally Posted by Head_on_a_Stick View Post
No, I don't think that would help.
That's by far the safest and easiest way to configure Xorg with an AMD card. It's all automated, and everything works as it should.

Quote:
Originally Posted by Lagamorph View Post
I installed Steam using a guide I found on the Steam forums, which involved downloading and running a steam.deb file, I believe those were likely added by that package.
As you can see in my long post on page 1 here, you don't need to install Steam like that. Debian already has Steam in it's non-free repos.

The best, safest, easiest way to configure Debian + AMD fglrx + Steam = http://www.linuxquestions.org/questi...8/#post5369368
 
Old 05-30-2015, 06:08 PM   #32
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by Amarildo View Post
That's by far the safest and easiest way to configure Xorg with an AMD card. It's all automated, and everything works as it should.



As you can see in my long post on page 1 here, you don't need to install Steam like that. Debian already has Steam in it's non-free repos.

The best, safest, easiest way to configure Debian + AMD fglrx + Steam = http://www.linuxquestions.org/questi...8/#post5369368
I was referring to the OP's specific situation -- the problem was clearly not related to an xorg configuration file.

The best, safest way to configure Debian, AMD (non-free) & Steam is by following the official Debian wiki pages.
https://wiki.debian.org/ATIProprietary
https://wiki.debian.org/Steam
 
Old 05-30-2015, 06:34 PM   #33
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok, reinstall done and now to work

Just ran,
Code:
sudo aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver
Though this prompted that there were 0 packages to upgrade, install or remove, so looks like it's already been installed as part of the installation process (I did use the non-free image to install), so I'm proceeding with creating the Xorg configuration file, then on with the Steam installation instructions.


EDIT - Ok....so I've literally done nothing except the following,
Code:
# apt-get update
# apt-get upgrade

# aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver

# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf
I'm now back to Debian booting straight to command line....


EDIT 2 -
Ok, removed the xorg.conf.d directory along with contents, rebooted, and I'm back to GUI mode again.

Last edited by Lagamorph; 05-30-2015 at 06:39 PM.
 
Old 05-30-2015, 07:38 PM   #34
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok, it seems my system really hates anything to do with an xorg config.

I attempted to open the ATI Catalyst Control Center (When I checked in Synpatic, it was already installed without me needing to do anything) so that I could enable Crossfire on my system, but on attempting to open it I get the following message,

Code:
There was a problem initializing Catalyst Control Center Linux Edition. It could be the following,

No AMD Graphics Driver is installed, or the AMD driver is not functioning properly.
Please install the AMD driver appropriate to your AMD hardware or configure using aticonfig
So I realise I haven't run,
Code:
sudo aticonfig --intial
yet, so I go ahead and run that, then reboot. As soon as I reboot, yep, you guessed it, I'm back to booting into the command line again!
However, if I browse to /etc/X11 and then delete the xorg.conf files (I checked and the file was no present before running the aticonfig) and then reboot again, I'm back to booting into the GUI.

According to Synpatic, the non-free AMD RadeonHD display driver (Package fglrx-driver) is installed.
 
Old 05-30-2015, 07:56 PM   #35
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
I think you should try the non-proprietary AMD driver instead -- the performance is pretty good these days and the open-source driver should be more reliable.

https://wiki.debian.org/AtiHowTo
 
Old 05-30-2015, 08:24 PM   #36
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,326
Blog Entries: 1

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
I really have NOT had a need for /etc/X11/xorg.conf for a while. Most adjustments (if any) can be made with xrandr and xinput after starting your window manager. Or amdcccle that is part of ati/amd's proprietary driver. You might need to build the fglrx kernel module and load it manually before starting kde. Depending on stuff (kernel source / video driver source). If you've used the proprietary driver by non distro specific means, you might need to reinstall that driver everytime that the kernel updates. Even if the kernel version is basically the same / security updates.

You can also start X / kde from the commandline.

# modprobe fglrx
$ echo "exec startkde" > ~/.xinitrc
$ startx -- :0

You might be missing a display manager which does most of the gui login stuff. gdm, kdm, wdm, xdm, lightdm, and others depending on what you have installed. You only need one of those installed, and I'm not sure what the default is these days as I prefer booting to the command line.
 
Old 05-30-2015, 08:31 PM   #37
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by Shadow_7 View Post
I really have NOT had a need for /etc/X11/xorg.conf for a while.
In this case, the xorg configuration file is needed to specify the fglrx driver.

When the OP removes the file, the system uses the non-proprietary AMD driver.

Quote:
Originally Posted by Shadow_7 View Post
You might need to build the fglrx kernel module and load it manually before starting kde. Depending on stuff (kernel source / video driver source). If you've used the proprietary driver by non distro specific means, you might need to reinstall that driver everytime that the kernel updates.
The OP is using the official method listed in the Debian wiki and has built the kernel module.
http://www.linuxquestions.org/questi...ml#post5369987
 
Old 06-01-2015, 01:19 PM   #38
Amarildo
Member
 
Registered: Jun 2014
Posts: 176

Rep: Reputation: Disabled
Quote:
Originally Posted by Lagamorph View Post
Ok, reinstall done and now to work

Just ran,
[code]sudo aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver
Though this prompted that there were 0 packages to upgrade, install or remove, so looks like it's already been installed as part of the installation process (I did use the non-free image to install), so I'm proceeding with creating the Xorg configuration file, then on with the Steam installation instructions.
It's nearly impossible for that to be installed by default.

Did you add the "contrib" and "non-free" to your /etc/apt/sources.list?

Quote:
Originally Posted by Lagamorph View Post
EDIT - Ok....so I've literally done nothing except the following,
Code:
# apt-get update
# apt-get upgrade

# aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver

# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf
I'm now back to Debian booting straight to command line....
There are a couple of things wrong with that.

First, it seems you didn't install any AMD driver at all.
Second, you created an Xorg.conf file for nothing. If no AMD driver was installed then you don't need an xorg.conf file.
Third, you created that xorg.conf file, didn't configure it, and then rebooted. That's why you booted on tty1.

Quote:
Originally Posted by Lagamorph View Post
EDIT 2 -
Ok, removed the xorg.conf.d directory along with contents, rebooted, and I'm back to GUI mode again.
That's because Xorg automatically configures itself and doesn't require any additional configuration.

Quote:
Originally Posted by Lagamorph View Post
Ok, it seems my system really hates anything to do with an xorg config.

I attempted to open the ATI Catalyst Control Center (When I checked in Synpatic, it was already installed without me needing to do anything) so that I could enable Crossfire on my system, but on attempting to open it I get the following message,

Code:
There was a problem initializing Catalyst Control Center Linux Edition. It could be the following,

No AMD Graphics Driver is installed, or the AMD driver is not functioning properly.
Please install the AMD driver appropriate to your AMD hardware or configure using aticonfig
So I realise I haven't run,
Code:
sudo aticonfig --intial
yet, so I go ahead and run that, then reboot. As soon as I reboot, yep, you guessed it, I'm back to booting into the command line again!
However, if I browse to /etc/X11 and then delete the xorg.conf files (I checked and the file was no present before running the aticonfig) and then reboot again, I'm back to booting into the GUI.

According to Synpatic, the non-free AMD RadeonHD display driver (Package fglrx-driver) is installed.
Please, if you're going to install the non-free AMD drivers the best way to do so is to follow what I described ->

Quote:
Next, lets install the AMD drivers. As the Debian Wiki page says, it's pretty easy:

Add "contrib" and "non free" to your sources.list repository (the file is in /etc/apt/sources.list). So if it looks like this:
Code:
deb http://httpredir.debian.org/debian/ jessie main
make it look like this:
Code:
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
Next, lets tell the system to update and recognize the new packages:
Code:
aptitude update
Good. Now lets install the driver:
Code:
aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver
You will notice that a message will appear while you install the driver, and this message says that "usually running aticonfig --initial is enough", etc. It is.
After install, then, you issue:
Code:
# aticonfig --initial
Notice the "#"? It means you must issue this command as root. Otherwise, do it as your regular user:
Code:
sudo aticonfig --initial
If you get a warning saying your user isn`t in the sudoers file, don't worry:
Code:
# adduser lagamorph sudo
Great, we're almost there!

Now reboot.

After reboot, we are going to install Steam and the 32-bit libraries for your drivers.

Lets tell Debian that we want 32-bit applications available to install:
Code:
dpkg --add-architecture i386
Debian now must refresh its repositories list
Code:
apt-get update
Good. Now let's install Steam:
Code:
apt install Steam
Now, the 32-bit libraries necessary for your(and mine too) driver, but first, forget the "ia-32libs" package (or whatever it is called), this collection is ANCIENT and UNNECESSARY.
Code:
apt install libgl1-fglrx-glx:i386
Done. You don't even need to reboot.

Enjoy your Debian + Steam system And you can even go into Big-Picture mode and pretend it's SteamOS, but this time you actually have an Operating System that is designed to be a Desktop OS.

Cheers.
 
Old 06-01-2015, 04:51 PM   #39
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by Amarildo View Post
There are a couple of things wrong with that.

First, it seems you didn't install any AMD driver at all.
Second, you created an Xorg.conf file for nothing. If no AMD driver was installed then you don't need an xorg.conf file.
Third, you created that xorg.conf file, didn't configure it, and then rebooted. That's why you booted on tty1.
First, yes he did -- `aptitude install fglrx-driver`
Second, it does need an xorg configuration file to specify fglrx rather than xserver-xorg-video-ati
Third, he did configure it -- that's what the `echo` command did.

That command sequence is from the Debian wiki:
https://wiki.debian.org/ATIProprietary
 
Old 06-01-2015, 08:36 PM   #40
Amarildo
Member
 
Registered: Jun 2014
Posts: 176

Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
First, yes he did -- `aptitude install fglrx-driver`
But note that if he didn't put "contrib non-free" to his sources.list then that command will output the same as he reported the output was, which is "0 installed". You can read that in post #38 http://www.linuxquestions.org/questi...ml#post5369987
It's unclear wether he added the "contrib non-free" to his sources.list file, but, considering the results of the command used to install fgrlx, I'd say no fgrlx driver was installed.

Either that or he didn't re-install THE OPERATING SYSTEM and still has some left-over files from the drivers downloaded from AMD's website, which could cause all sorts of problems. I put "THE OPERATING SYSTEM" in bold and italic because on post #33 he said "reinstall done" but didn't mention WHICH re-install he did. Did he install the graphic drivers or the operating system? If he re-installed the operating system then there is only one possibility: that he didn't install any graphic drivers at all.

Quote:
Originally Posted by Head_on_a_Stick View Post
Second, it does need an xorg configuration file to specify fglrx rather than xserver-xorg-video-ati
Yes, when I said X doesn't need a Xorg.conf file I meant that it doesn't need such a file with the free drivers. See:

Quote:
If no AMD driver was installed then you don't need an xorg.conf file


Quote:
Originally Posted by Head_on_a_Stick View Post
Third, he did configure it -- that's what the `echo` command did.
But did he install the driver? That's what I want to know. I'm using only the free amd driver, I don't even have the Firmware installed, and I'll create that conf file to see what happens.
 
Old 06-01-2015, 10:36 PM   #41
Amarildo
Member
 
Registered: Jun 2014
Posts: 176

Rep: Reputation: Disabled
Lagamorph, I think we all missed something here: the model of your card. Example: HD 6450, or R9 270X.

I'm asking this because in your xorg log there are these lines:
Quote:
[ 21.353] (WW) fglrx: No matching Device section for instance (BusID PCI:0@3:0:0) found
[ 21.353] (EE) No devices detected.
 
Old 06-02-2015, 02:50 AM   #42
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,326
Blog Entries: 1

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
Quote:
Originally Posted by Head_on_a_Stick View Post
First, yes he did -- `aptitude install fglrx-driver`
Second, it does need an xorg configuration file to specify fglrx rather than xserver-xorg-video-ati
Third, he did configure it -- that's what the `echo` command did.

That command sequence is from the Debian wiki:
https://wiki.debian.org/ATIProprietary
Technically, not really. Caveat, if you modprobe fglrx beforehand. Implied modprobe -r radeon or blacklisted in /etc/modprobe.d/... Various ways to skin that cat. Although technically yes, for DRI / 3D acceleration to work properly with the prorpietary driver.

Bear in mind that ati "legacy" cards are no longer supported by the proprietary driver, you must use the radeon driver for kernels > 3.4.x for cards that fall into that category. My now deceased ATI/Visiontek HD 4550 was one of those. But the radeon driver was pretty nice. Or option two, use said older kernel(s) and the ati legacy drivers. Kind of a waste to do that though.
 
Old 06-02-2015, 12:27 PM   #43
Amarildo
Member
 
Registered: Jun 2014
Posts: 176

Rep: Reputation: Disabled
Exactly. The same thing happened with my old 9800GT from NVIDIA. September last year NVIDIA issued a new Legacy driver branch (340xx), and I didn't know that. I installed Arch, installed the newer nvidia drivers, and was presented with tty1 on reboot. I suspect this is what is happening here.
 
Old 06-03-2015, 04:52 PM   #44
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
The model of graphics card I have is two 5870 Mobility graphics cards.

But I promise that as soon as I ran,
Code:
sudo aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver
I was informed that there was nothing to install, implying it was already installed, yet this was one of the first things I ran.


As a test, I re-downloaded the installer from the AMD website and ran the .run file, which informed me that an older version of the fglrx driver was indeed already installed. I removed this through Synaptic, rebooted, re-ran the .run file to install the AMD website driver and it installed the driver successfully. I checked the /etc/X11 folder and found that xorg.conf and xord.conf.fglrx-0 files had been created. I rebooted again, which successfully got to the GUI rather than command line, and I can now open the Catalyst Control Center to enable Crossfire.


So for some reason, the only way I seem to be able to install the AMD proprietary driver is to download it from their website :S
The driver I'm downloading is the one AMD lists as compatible with my graphics cards as well, which is version 14.12. The one on the Debian repo appears to be 14.9. It's possible there's some kind of compatibility issue with the older driver, but the 5870 cards have been around for plenty long enough that a 3 month older driver shouldn't really be causing issues I think.


Here's my sources.list,
Code:
# 

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150426-18:53]/ jessie contrib main non-free

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150426-18:53]/ jessie contrib main non-free

deb http://ftp.uk.debian.org/debian/ jessie main non-free contrib
deb-src http://ftp.uk.debian.org/debian/ jessie main non-free contrib

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.uk.debian.org/debian/ jessie-updates main contrib non-free

deb http://dl.google.com/linux/deb/ stable non-free main
The only changes I've made are commenting out the CD lines and adding the Google repo to install Chrome.


The image I used to install was named
Code:
debian-live-8.0.0-amd64-kde-desktop+nonfree
Downloaded from the Debian website.

Last edited by Lagamorph; 06-03-2015 at 05:00 PM.
 
Old 06-03-2015, 08:27 PM   #45
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,326
Blog Entries: 1

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
Perhaps try:

# apt-get install --reinstall fglrx-driver

Maybe some bits on the drive went south and corrupted it. Or other things interrupted the process. It shouldn't hurt anything to do the --reinstall either way.
 
  


Reply

Tags
boot, debian, kde


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB booting into command line Username2 Gentoo 4 10-14-2011 06:08 AM
Booting Into Command Line ChrisWho Linux - General 19 04-14-2010 02:29 AM
Booting to command line? Barrien Linux - Newbie 2 09-04-2009 10:45 AM
Command Line appears after booting khadija Linux - Newbie 6 07-28-2008 08:16 AM
keeps booting Command line Rahk Linux - General 7 07-17-2008 11:29 PM


All times are GMT -5. The time now is 12:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration