LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-08-2009, 08:13 AM   #1
iball8888
Member
 
Registered: May 2009
Posts: 45

Rep: Reputation: 17
Debian/LXDE/IceWeasel Flash Not Working


I installed synaptic and did the nonfree flash plugins but it did not work. How do i get flash to work?
 
Old 10-08-2009, 08:56 AM   #2
zwijse
LQ Newbie
 
Registered: Dec 2006
Posts: 4

Rep: Reputation: 0
What version of Iceweasel are you running ?
And have you tried an older version or even a different browser ?

If I'm not mistaken there are still problems with flash and the current version of firefox , iceweasel will probably have the same issue.
 
Old 10-08-2009, 09:01 AM   #3
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,496

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
open a terminal
as root type
Code:
apt-get install flashplugin-nonfree sun-java6-jre sun-java6-fonts sun-java6-plugin
Code:
update-java-alternatives --set java-6-sun
restart iceweasel

Last edited by repo; 10-08-2009 at 09:34 AM.
 
Old 10-08-2009, 10:48 AM   #4
iball8888
Member
 
Registered: May 2009
Posts: 45

Original Poster
Rep: Reputation: 17
Iceweasel 3.0.14

Ok repo i did what you said...still nothing. Youtube says i either have Java script off or an older version of flash
 
Old 10-08-2009, 10:53 AM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,496

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Quote:
Originally Posted by iball8888 View Post
Iceweasel 3.0.14

Ok repo i did what you said...still nothing. Youtube says i either have Java script off or an older version of flash
in the browser, type
Code:
about:plugins
see if the plugin is installed


Do you have the plugin noscript installed?
If yes allow youtube
Look in
edit=>preferences=>content if javascript is enabled.
 
Old 10-08-2009, 11:17 AM   #6
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,457

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by iball8888 View Post
Iceweasel 3.0.14
just FYI FF 3.0.x did have flash player issues in Linux, 3.5 fixed those issues. You are still running 3.0.x.

remove Iceweasel, install FireFox from mozillia web page and then install your flash players via adobe. things will work. also your add-ons will work as none of the add-ons that are on the mozillia site proper will work with 3.0.x they all require 3.5.x
 
Old 10-08-2009, 11:21 AM   #7
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,496

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Quote:
Originally Posted by lleb View Post
just FYI FF 3.0.x did have flash player issues in Linux, 3.5 fixed those issues. You are still running 3.0.x.

remove Iceweasel, install FireFox from mozillia web page and then install your flash players via adobe. things will work. also your add-ons will work as none of the add-ons that are on the mozillia site proper will work with 3.0.x they all require 3.5.x
I use iceweasel 3.0.14
No problems with flash or plugins
There is a different between iceweasel and firefox
The version numbers are not the same

Last edited by repo; 10-08-2009 at 11:22 AM.
 
Old 10-08-2009, 02:02 PM   #8
iball8888
Member
 
Registered: May 2009
Posts: 45

Original Poster
Rep: Reputation: 17
no plugins installed and Javascript is enabled

*edit* i also want to note that when i click on something to save it...iceweasel doesnt actually save unless i right click the link and do save as.

*edit2* I said screw it and downloaded the Adobe's source and got its dependancies and installed the deb. Works now but i still need help with the whole saving thing

Last edited by iball8888; 10-08-2009 at 03:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fluxbox->LXDE on Debian kushalkoolwal Linux - Software 2 08-03-2009 11:56 AM
Flash player for Debian Etc 4.0r5 wich iceweasel siawash Debian 6 02-27-2009 02:36 PM
cannot install flash player on iceweasel in debian etch parf Linux - Newbie 16 11-23-2008 11:43 PM
Flash not working for my Iceweasel =,( megaprog Debian 5 10-17-2008 10:32 AM
Debian Iceweasel Add-ons Not Working digerati1338 Linux - Desktop 2 01-19-2008 12:58 PM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration