LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-11-2009, 05:24 PM   #1
craig61107
LQ Newbie
 
Registered: Apr 2009
Location: Rockford, Illinois, USA
Distribution: Debian (tower), ASUS Xandros
Posts: 8

Rep: Reputation: 0
Debian kernel modules--cpad, wacom--headers mismatch


I am running Debian 2.6.24-etchnhalf.1-686, and I am having trouble with the cpad and wacom kernel modules. Each time I try to update, upgrade and-or install a new package, I get error messages telling me that the kernel headers don't match the running Linux version. Yet when I ran apt-get install linux-headers-2.6.24-etchnhalf.1-686, the system reported that linux-headers-2.6.24-etchnhalf.1-686 is already the newest version.

Both cpad and wacom post-installation scripts return error code 2. In each case, the problem is line 49: [ $kvers = `uname -r` ] || echo "Warning: kernel headers don't match running $kernel version."

Is this a bug? Should I use Synaptic to remove and reinstall the cpad and wacom modules, then recompile them? This problem is blocking clean updates and upgrades of my system. Thanks for any help.
 
Old 05-12-2009, 04:19 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,497

Rep: Reputation: 90
Quote:
Originally Posted by craig61107 View Post
I am running Debian 2.6.24-etchnhalf.1-686, and I am having trouble with the cpad and wacom kernel modules. Each time I try to update, upgrade and-or install a new package, I get error messages telling me that the kernel headers don't match the running Linux version. Yet when I ran apt-get install linux-headers-2.6.24-etchnhalf.1-686, the system reported that linux-headers-2.6.24-etchnhalf.1-686 is already the newest version.
This is the classical mess you WILL sooner or later encounter when updating, or auto-updating your system. I use Fedora Core, and I -never- auto update - to avoid errors and problems like this. Once I have a stable system state (mostly "as is" off the install DVD or download) I turn off auto-updates and do any updates I need manually.

Quote:
Both cpad and wacom post-installation scripts return error code 2. In each case, the problem is line 49: [ $kvers = `uname -r` ] || echo "Warning: kernel headers don't match running $kernel version."
This error means these drivers (which, since they came from your auto-update source, are most likely already compiled) were compiled for a different kernel version than the one you are running on your system, or for which you have a local source tree. This usually happens when you recompile or change something in your kernel, and you then receive an auto-update from Debian / your update source that is for the same version kernel, but with different compilation settings or a different (even minimally different) configuration.

This can also mean that your kernel itself was patched / updated on a binary level, (with an auto-update) but the kernel source tree found by the scripts isn't the source for that kernel. This is a typical "auto update" screwup situation - and a prime reason why I never use auto-updating.

Quote:
Is this a bug? Should I use Synaptic to remove and reinstall the cpad and wacom modules, then recompile them? This problem is blocking clean updates and upgrades of my system. Thanks for any help.
I don't think it is a bug, rather it is a side-effect of using auto-updates. IMO auto-updates are a Microsoftism that they created to fix the thousands of mistakes they usually make when creating their operating systems. You simply have a mismatch between your kernel source, the wacom and cpad modules' binaries, and your running kernel. It is not surprising that a Microsoft theoretical solution to their problems, applied on a Linux system, causes problems.

I'd suggest removing the modules, and then downloading source versions. Then, also download the source tree for your running kernel (usually just called the kernel source) - the kernel source's version and your running kernel MUST match 100%. Once you are sure you have the correct source package for your running kernel installed, try compiling the modules against that - hopefully it will work.

Word to the wise - never ever use automatic updates. It is more effort to do it manually, granted, but you'll learn useful skills doing it that way, and you'll have much fewer issues in the long run. You know your system and requirements best.

If you have no compelling reason to update, don't - why break something that is working perfectly? My FC10 install at home has 100's of updates pending, but it is not on the internet (thus, security is a non-issue) and it WORKS fine for me - so I will NOT auto-update and mess with things that are already working perfectly.
 
Old 05-12-2009, 08:39 AM   #3
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
I would try the following ...

aptitude update
aptitude install build-essential module-assistant
m-a update
m-a prepare


See if it downloads and installs different headers during the m-a prepare step.. it very well may. using module-assistant to get the proper headers installed is quick and easy..

You are attemptng to install headers by pointing at a specific package, which is more odf a pointer. There may be several security updates. the package you are telling it to install is not the actual kernel version. the system looks at the package version and says hey that package is already the latest version and it stops installation. Package version and kernel version don't always match. Current version actually appears to be 2.6.24-6~etchnhalf.8etch1

to see the actual installed kernel header version.
apt-cache policy linux-headers-2.6.24--etchnhalf.1-686

if you still have issues come back here and post the output of the following commands.

uname -r

apt-cache policy linux-headers-2.6.24-etchnhalf.1-686

apt-cache policy linux-image-2.6.24-etchnhalf.1-686
 
Old 05-14-2009, 01:00 PM   #4
craig61107
LQ Newbie
 
Registered: Apr 2009
Location: Rockford, Illinois, USA
Distribution: Debian (tower), ASUS Xandros
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
if you still have issues come back here and post the output of the following commands.
debian1235jackson# uname -r
2.6.24-etchnhalf.1-686
debian1235jackson# apt-cache policy linux-headers-2.6.24-etchnhalf.1-686
linux-headers-2.6.24-etchnhalf.1-686:
Installed: 2.6.24-6~etchnhalf.8etch1
Candidate: 2.6.24-6~etchnhalf.8etch1
Version table:
*** 2.6.24-6~etchnhalf.8etch1 0
500 http://security.debian.org etch/updates/main Packages
100 /var/lib/dpkg/status
2.6.24-6~etchnhalf.8 0
500 http://ftp.us.debian.org etch/main Packages
2.6.24-6~etchnhalf.7 0
500 cdrom://[Debian GNU/Linux 4.0 r6-etchnhalf _Etch-and-a-half_ - Official i386 NETINST 20081220-23:42] etch/main Packages
debian1235jackson# apt-cache policy linux-image-2.6.24-etchnhalf.1-686
linux-image-2.6.24-etchnhalf.1-686:
Installed: 2.6.24-6~etchnhalf.8etch1
Candidate: 2.6.24-6~etchnhalf.8etch1
Version table:
*** 2.6.24-6~etchnhalf.8etch1 0
500 http://security.debian.org etch/updates/main Packages
100 /var/lib/dpkg/status
2.6.24-6~etchnhalf.8 0
500 http://ftp.us.debian.org etch/main Packages
2.6.24-6~etchnhalf.7 0
500 cdrom://[Debian GNU/Linux 4.0 r6-etchnhalf _Etch-and-a-half_ - Official i386 NETINST 20081220-23:42] etch/main Packages

Unfortunately, the conflict remains. See below:

debian1235jackson# m-a prepare
Getting source for kernel version: 2.6.24-etchnhalf.1-686
Kernel headers available in /lib/modules/2.6.24-etchnhalf.1-686/build
apt-get install build-essential
Reading package lists... Done
Building dependency tree... Done
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up cpad-kernel-source (0.10-3) ...
/var/lib/dpkg/info/cpad-kernel-source.postinst: line 49: [: too many arguments
Warning: kernel headers don't match running Linux version.
Building cpad module for Linux _CODE 13263 (this may take a few minutes)...dpkg: error processing cpad-kernel-source (--configure):
subprocess post-installation script returned error exit status 2
Setting up wacom-kernel-source (0.7.4.1-5) ...
/var/lib/dpkg/info/wacom-kernel-source.postinst: line 49: [: too many arguments
Warning: kernel headers don't match running Linux version.
Building wacom modules for Linux _CODE 13263 (this may take a few minutes)...dpk g: error processing wacom-kernel-source (--configure):
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
cpad-kernel-source
wacom-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)

It appears that I will have to remove, replace and recompile the cpad and wacom modules. Does anyone have any other ideas? Thanks for any help.
 
Old 05-14-2009, 01:27 PM   #5
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Quote:
Warning: kernel headers don't match running Linux version.
Bizarre.. the earlier commands show that your headers DO match the running kernel image. Must be a bug in the source packages. mybe they don't acknowledge the kernels from etchnhalf but would work for the older 2.6.18 etch kernel.

There are definitely old bugs related to this..
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=404471
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=418008

Last edited by farslayer; 05-14-2009 at 01:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel headers & /lib/modules/uname -r/build fof3 Linux - Newbie 4 12-16-2008 03:58 PM
elive/debian: Installed kernel headers and source, still make:65-error ikonqueror Linux - Software 3 08-07-2007 09:58 PM
Post-debian Etch install -- no kernel headers. Nathan1993 Debian 3 03-03-2007 02:42 PM
Pure Debian Kernel-Headers dauphinfay Debian 2 07-13-2006 12:47 AM
"modules shouldn't use kernel headers . . ." cyberclaus Linux - Software 8 10-08-2001 01:20 AM


All times are GMT -5. The time now is 08:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration