LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-16-2016, 05:08 AM   #1
Pelycosaurus
LQ Newbie
 
Registered: Jul 2016
Distribution: Debian 8.5, deepIn
Posts: 21

Rep: Reputation: Disabled
Unhappy Debian isn't booting


When i try to boot Debian, it shows up this:

Quote:
Loading, please wait...
/dev/sda4: recovering Journal
/dev/sda4: clean, 287602/12197888 files, 9247031/4878128 blocks
[ 2.941650] systemd[1]: Job paths.target/start deleted to break ordering cycle starting with basic.target/start
[ 2.941731] systemd[1]: Jobb rpcbind.service/start deleted to break ordering cycle starting with basic.target/start
Then shows a login and that's it. When i login it's just a terminal. Is there any other way fixing this without reinstalling Debian?

I got this when trying to install CUDA when Blender could only render with CPU but not GPU, even though i had an Nvidia card. Then when restarting the system, that's when the error come up.

I was using Debian 8.5.

System specs (if required):
GPU: MSI GTX 970
CPU: Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz 3.40 GHz
 
Old 07-16-2016, 05:12 AM   #2
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,011

Rep: Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621
How did you install the NVIDIA driver?
Please repeat the steps and let us know of any errors shown -- I realise you can't copy and paste but the errors ought to be obvious and please be as explicit as possible.
 
Old 07-16-2016, 05:22 AM   #3
Pelycosaurus
LQ Newbie
 
Registered: Jul 2016
Distribution: Debian 8.5, deepIn
Posts: 21

Original Poster
Rep: Reputation: Disabled
I followed these steps found on http://blender.stackexchange.com/que...ing-for-cycles

Quote:
Please note that this is for Debian Jessie (8), the current stable. For instructions for wheezy, please see https://wiki.debian.org/NvidiaGraphicsDrivers

First, become super user by typing in su and entering in you password when it asks for it, or by preceding all commands with sudo (will still ask for password the first time), assuming you set it up.

Then type in:

nano /etc/apt/sources.list
And add the line deb http://http.debian.net/debian/ jessie main contrib non-free if it's not already there.

Then do an apt-get update, to refresh the package lists on the computer, then finally, install the drivers with:

apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-dkms
To finish up the actual driver installation, create an Xorg configuration file with the following commands:

mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf
Than reboot your computer to blacklist (disable) the open source nouvou driver which is loaded by default.

All that is required afterwards, is to install cuda with the following command:

apt-get install nvidia-cuda-toolkit
 
Old 07-16-2016, 05:37 AM   #4
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,011

Rep: Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621
OK, so what errors did you see when installing? If none then you may need to run nvidia-xconfig as shown on the page linked to.
 
Old 07-16-2016, 05:41 AM   #5
Pelycosaurus
LQ Newbie
 
Registered: Jul 2016
Distribution: Debian 8.5, deepIn
Posts: 21

Original Poster
Rep: Reputation: Disabled
But how if Debian doesn't even boot?
 
Old 07-16-2016, 05:43 AM   #6
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,011

Rep: Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621
Quote:
Originally Posted by Pelycosaurus View Post
But how if Debian doesn't even boot?
Quote:
Originally Posted by Pelycosaurus View Post
When i login it's just a terminal.
Does it boot or not?
The command given is run as root from the terminal, please read the page linked to for more information.
 
Old 07-16-2016, 05:46 AM   #7
Pelycosaurus
LQ Newbie
 
Registered: Jul 2016
Distribution: Debian 8.5, deepIn
Posts: 21

Original Poster
Rep: Reputation: Disabled
I'll try.
 
Old 07-16-2016, 05:55 AM   #8
Pelycosaurus
LQ Newbie
 
Registered: Jul 2016
Distribution: Debian 8.5, deepIn
Posts: 21

Original Poster
Rep: Reputation: Disabled
Command not found.
 
Old 07-16-2016, 06:02 AM   #9
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,011

Rep: Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621
Quote:
Originally Posted by Pelycosaurus View Post
Command not found.
Then you should have seen an error message upon trying to install. Did you? Try carefully following the steps on the page linked to.
 
Old 07-16-2016, 07:04 AM   #10
Pelycosaurus
LQ Newbie
 
Registered: Jul 2016
Distribution: Debian 8.5, deepIn
Posts: 21

Original Poster
Rep: Reputation: Disabled
# jessie-backports
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

# apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')

# apt-get install -t jessie-backports linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')

# apt-get update

# apt-get install -t jessie-backports nvidia-driver

All of these are done.
 
Old 07-16-2016, 07:22 AM   #11
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Quote:
Originally Posted by Pelycosaurus View Post
# jessie-backports
deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

# apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')

# apt-get install -t jessie-backports linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')

# apt-get update

# apt-get install -t jessie-backports nvidia-driver

All of these are done.
Good! You have working nvidia driver then. Anything else we can help with?
 
Old 07-16-2016, 07:22 AM   #12
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,011

Rep: Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621
Perhaps try installing nvidia-xconfig manually. I had thought it was part of the driver installation process but it may be that it is no longer.
 
Old 07-16-2016, 07:24 AM   #13
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Code:
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf
There is no need for nvidia-xconfig if the above is done.
 
Old 07-16-2016, 07:45 AM   #14
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,011

Rep: Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621Reputation: 1621
Quote:
Originally Posted by Emerson View Post
Code:
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf
There is no need for nvidia-xconfig if the above is done.
Probably not but if the guidance was followe to no. Avail then it may work.
I'll be honest here -- I've the same. Card. Running under zisd fine with the NVIDIA drivers from the web site but my X11 configuration files are a few years old and I have an xorg.conf which seems to still be in effect.
 
Old 07-16-2016, 08:13 AM   #15
Pelycosaurus
LQ Newbie
 
Registered: Jul 2016
Distribution: Debian 8.5, deepIn
Posts: 21

Original Poster
Rep: Reputation: Disabled
I believe i did some kind of xorg stuff when it stopped to work.
 
  


Reply

Tags
blender3d, boot err msg., cuda, debian, error message


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
My computer isn't capable of booting smp kernel images, can I delete them? slacker_ Linux - Newbie 2 09-02-2013 11:59 AM
Unix isn't booting after failure HDD severt Other *NIX 1 05-29-2008 05:47 AM
Why isn't Mandrake booting up jremsen Linux - Software 1 03-11-2006 08:03 PM
Help! My Install isn't booting! Garibaldi3489 Slackware 3 12-14-2004 09:15 PM
DarkStar login: why isn't it booting into KDE SysArchitect Linux - Newbie 8 03-17-2004 09:49 PM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration