LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-30-2011, 11:34 PM   #1
mikey6705
LQ Newbie
 
Registered: May 2007
Posts: 13

Rep: Reputation: 0
Debian hates my soul


I am going to get debian working on my computer. I have it installed.
but when you boot, after grub it appears to start xwindows then the screen goes black... I went on the cd in recue mode and tried to install the driver but no luck. The weird thing is once I am in rescue mode and do a startx gnome comes up but I can't use my mouse or keyboard. When you boot up normally I hear a sound through my speakers and the keyboard leds are working so that tells me that the keyboard is working although my monitor isn't.

there isn't a /etc/X11/xorg.conf file which is weird.. I have an integrated nvidia video card so i don't know if this is why I don't have an xorg.conf file or not.

the "video card" is an nvidia 8400gs or something of that nature.

any help would be awesome.
(computer has been down for 2 days :-/
using ubuntu to web surf :-D )

Last edited by mikey6705; 09-30-2011 at 11:39 PM.
 
Old 10-01-2011, 12:33 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,767

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Boot into rescue mode and try these instructions:
http://wiki.debian.org/Xorg?action=s...ect=ConfigureX
http://wiki.debian.org/NvidiaGraphicsDrivers
 
1 members found this post helpful.
Old 10-01-2011, 12:48 AM   #3
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,578

Rep: Reputation: Disabled
Quote:
Originally Posted by mikey6705 View Post

there isn't a /etc/X11/xorg.conf file which is weird.
any help would be awesome.
(computer has been down for 2 days :-/
using ubuntu to web surf :-D )
No, it isn't. Later versions of xserver-xorg do not routinely use xorg.conf. I don't use it on my system. You should have something like this folder however: /usr/share/X11/xorg.conf.d
Have you looked for errors in your /var/log/Xorg.0.log file? These are indicated by a leading (EE). That may be helpful in diagnosing your problem.
ciao,
jdk
 
1 members found this post helpful.
Old 10-01-2011, 03:44 AM   #4
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
it sounds to me like the modules to your kernel aren't loading, but i'm inexperienced in that issue, so someone will have to verify that..
 
Old 10-01-2011, 03:59 AM   #5
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
Quote:
Originally Posted by bigrigdriver View Post
The above should be the correct advice to follow.

Of course it would help if you mention what you have done to fix the problem, and what version of Debian you are running.
 
Old 10-01-2011, 04:14 AM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,230

Rep: Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019Reputation: 1019
Hmmm ....
(potential) Debian users have souls .... ???

Interesting metaphysical conundrum.
 
1 members found this post helpful.
Old 10-01-2011, 09:54 AM   #7
mikey6705
LQ Newbie
 
Registered: May 2007
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by craigevil View Post
The above should be the correct advice to follow.

Of course it would help if you mention what you have done to fix the problem, and what version of Debian you are running.
Your right I tried to keep things short.. version 6 squeeze of debian ( the latest copy off there website 6.0.2.1)

I did the walk threw bluedog posted on this site.
http://forums.debian.net/viewtopic.php?f=5&t=502
(it pretty much installs the driver from aptitude)
( aptitude install nvidia-glx )

I did a reinstall and set the priority for debconf to low so during the install it asked me if I wanted to use non-free software( and selected yes )

I tried to download the drivers off of nvidia's website. I had an error at first but it seems to have been using a wrong version of gcc or something of that nature I changed the variable and it seems to have gotten rid of that error however there is still an error at the end of the install...
 
Old 10-01-2011, 10:03 AM   #8
mikey6705
LQ Newbie
 
Registered: May 2007
Posts: 13

Original Poster
Rep: Reputation: 0
also on a side note does anyone know how to make it so that debian doesn't go into a gui when you boot up. it would be nice to not have to use the rescue cd :-/

Just thought That I would ask
Thanks for the input.
I will try the things bigrigdriver posted tonight.
 
Old 10-01-2011, 10:47 AM   #9
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,578

Rep: Reputation: Disabled
Quote:
Originally Posted by mikey6705 View Post
also on a side note does anyone know how to make it so that debian doesn't go into a gui when you boot up. it would be nice to not have to use the rescue cd :-/

Just thought That I would ask
Thanks for the input.
I will try the things bigrigdriver posted tonight.
In your grub menu (if you're using grub, that is) you should see a recovery mode paired with your normal boot up mode. If you select recovery mode the boot up procedure stops before you reach the gui stage and enables you to log in to a virtual terminal.
ciao,
jdk
 
Old 10-01-2011, 12:31 PM   #10
kasl33
Member
 
Registered: Oct 2004
Location: Bremerton, WA
Distribution: Arch, Debian, Ubuntu, Ubuntu-Server, CentOS, OSX Lion
Posts: 352

Rep: Reputation: 47
Quote:
Originally Posted by mikey6705 View Post
also on a side note does anyone know how to make it so that debian doesn't go into a gui when you boot up. it would be nice to not have to use the rescue cd :-/

Just thought That I would ask
Thanks for the input.
I will try the things bigrigdriver posted tonight.
When you restart the computer, you will get the GRUB boot menu. Instead of pressing enter to boot the system, select the OS you want to load and then press the letter "e" intead. This will allow you to "edit" GRUB's loading parameters.

Next, to boot into runlevel 3, simply put the number 3 (no quotes, no commas, nothing else) at the end of the line. For example (I use Arch, but it should be roughly the same - notice the 3 after vga-773):

Code:
# (0) Arch Linux
title  Arch Linux
root   (hd0,0)
kernel /vmlinuz-linux root=/dev/disk/by-uuid/fc8b7aba-6411-4f67-a7a6-5a0d7f90dc85 ro quiet vga=773 3
initrd /initramfs-linux.img
Next, for Debian, it seems like Nvidia drivers aren't supported out of the box unless you add a repo. For me, I install the drivers from Nvidia's website. To do this, follow these directions:

Code:
Remove your nvidia-glx drivers and download the ones from Nvidia's website:
apt-get remove nvidia-glx #I would guess
If you can't download them, post your video card's exact specs and I'm sure somebody here can give you a link so you can download them in runlevel 3 with the wget command.

Do the rest here as root:

Install Nvidia requirements:
Code:
apt-get install gcc make linux-headers-`uname -r` build-essential
After that, change to runlevel 3 if you aren't there already:
Code:
/etc/init.d/gdm3 stop [Change gmd3 to kdm, or whatever else if you are using them)
Press Alt+Right Directional Key if you get a blank screen instead of the terminal

Now install the nvidia:
Code:
cd /home/[Your username]/Downloads [You need to go to the directory which that file is in, so the path may change]
chmod 770 NVIDIA-Linux-*
./NVIDIA-Linux-*
Now, you might get the error about gcc... Don't abort the installation. Other steps are easy (if you got any errors and didn't know what to do, leave a comment), and as the last step, it will ask something regarding nvidia-xconfig... Choose yes.

Last edited by kasl33; 10-01-2011 at 12:33 PM.
 
Old 10-03-2011, 05:38 AM   #11
mikey6705
LQ Newbie
 
Registered: May 2007
Posts: 13

Original Poster
Rep: Reputation: 0
I got the nvidia driver to install. I did some googling and added a few switches ( sh NVID* -k $(uname -r) )

at the end of the installation it asked if I wanted to edit the xserver config and I said yes.

But it still ain't working.


I have a defective video so I popped that in my computer and i could see that it could get to the desktop. But yeah, its still faulty :-(
if I wasn't so cheap I probably would buy a new one...
 
  


Reply

Tags
black, blank, debian, screen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Save my Soul shaolindragon Linux - Newbie 37 10-05-2011 11:26 PM
How much did it cost...? (when you sold your soul) perry LQ Suggestions & Feedback 9 09-14-2007 08:46 PM
Your Eyes Are The Window To Your Soul puffaddering Linux - Certification 1 07-29-2007 08:43 PM
Debian hates me leedude Debian 2 01-16-2007 07:21 AM
Saving a soul Gurunello Linux - Laptop and Netbook 1 07-31-2005 12:24 PM


All times are GMT -5. The time now is 12:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration