LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-22-2008, 10:43 AM   #1
dainsane1
LQ Newbie
 
Registered: Oct 2008
Posts: 8

Rep: Reputation: 0
debian - eth missing


greetings all,


i setup a basic web server with debian on an pld hp proliant

worked fine until the box died (not sure but no video)

so i changed the processor module with a spare that i had and now i can not get a notwork card to work.

ifconfig will only list lo
ifup will tell me "ignoring unknown interface"
lspci does show all 3 network cards

i just need 1 but have 3 in trying to get one working.

i had eth1 configured to a static ip.

where do i look to get one of these cards to show up as an eth device?
 
Old 10-22-2008, 11:29 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Check dmesg log to see how the system is assigning device names to the cards.

cat /var/log/dmesg | grep -i eth



check the file /etc/udev/rules.d/70-persistent-net.rules for entries related to your NIC cards.. you may want to delete all defined NIC card entries in this file. They should be automatically regenerated on your next boot.

these lines will look like this:

SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:1a:a0:b8:6f:a8", NAME="eth0"
 
Old 10-22-2008, 12:56 PM   #3
dainsane1
LQ Newbie
 
Registered: Oct 2008
Posts: 8

Original Poster
Rep: Reputation: 0
ok i deleted all entries in that file
still nothing but lo


cat /var/log/dmesg says:

8139too Fast Ethernet driver 0.9.27
eth0: RealTek RLT8139 at0x2000, 00:50:ba:b0:20:80, IRQ15
eth0: Identified 8139 chip type 'RLT-8139B'
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
TLAN eth1 irq=0, io=3880, Compaq Netelligent Intergrated 10/100 TX UDP, Rev 16
 
Old 10-22-2008, 01:22 PM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
open your /etc/network/interfaces file and edit it to add the entries for eth0 and eth1

here is an example of what the file might look like with 2 interfaces and static IP's

Quote:
it-etch:/$ cat /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# allow-hotplug eth0
# iface eth0 inet dhcp
auto eth0
iface eth0 inet static
address 192.168.0.4
netmask 255.255.255.0
gateway 192.168.0.1
network 192.168.0.0
broadcast 192.168.0.255



# The secondary network interface
auto eth1
iface eth1 inet static
address 192.168.2.2
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
if this file already exists and you believe it is correct, them please post it here for review..

Last edited by farslayer; 10-22-2008 at 01:24 PM.
 
Old 10-23-2008, 04:57 PM   #5
dainsane1
LQ Newbie
 
Registered: Oct 2008
Posts: 8

Original Poster
Rep: Reputation: 0
thanks

i got that part right

tho i originally only had one NIC in the config file
it was the compaq one which i think might not work
(it is on board and can't remove)

i was able to get the second card running onto dhcp just before i left the office

have not been back to the system yet
will try with the second card as static
 
Old 10-24-2008, 08:45 AM   #6
dainsane1
LQ Newbie
 
Registered: Oct 2008
Posts: 8

Original Poster
Rep: Reputation: 0
It works


i had 'allow-hotplug eth1' in place of 'auto eth1'

was this a big error waiting to happen?

Thanks
 
Old 10-24-2008, 03:10 PM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
I don't think so..

Some systems work fine with allow-hotplug, others don't
I'm not sure what dictates the use of auto vs allow-hotplug I guess I've never bothered to look into it.

It's probably in the man page though

Quote:
Lines beginning with the word "auto" are used to identify the physical
interfaces to be brought up when ifup is run with the -a option. (This
option is used by the system boot scripts.)
Physical interface names
should follow the word "auto" on the same line. There can be multiple
"auto" stanzas. ifup brings the named interfaces up in the order
listed.

Lines beginning with "allow-" are used to identify interfaces that
should be brought up automatically by various subsytems. This may be
done using a command such as "ifup --allow=hotplug eth0 eth1", which
will only bring up eth0 or eth1 if it is listed in an "allow-hotplug"
line. Note that "allow-auto" and "auto" are synonyms.
I wonder if dhclient is one of those subsystems that would use the allow-hotplug. hrmm...

Quote:
The problem of using auto is that the booting gets stuck until
dhclient3 timeouts, if you lack network support while booting the
system. If you use allow-hotplug it doesn't happen.

Last edited by farslayer; 10-24-2008 at 03:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
missing eth...very common problem... markomarko Linux - Hardware 2 06-25-2007 12:06 PM
Debian Planet gone missing? James4coffee Debian 3 11-29-2006 02:09 PM
where are the eth in debian ? jabka Debian 3 10-15-2006 02:37 AM
Debian eth pulling DHCP even after Static is assigned pork_salad Linux - Networking 2 03-30-2006 06:46 PM
Bonding Eth - debian nogetfx Linux - Networking 1 03-14-2005 12:40 PM


All times are GMT -5. The time now is 02:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration