LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-10-2013, 06:45 PM   #1
aquafinity
LQ Newbie
 
Registered: Apr 2012
Posts: 10

Rep: Reputation: Disabled
Debian Dependencies Hopelessly Broken


As the title says, my dependencies are hopelessly broken.

sudo aptitude upgrade gets me:

Code:
(stuff)
Resolving dependencies...                
Unable to resolve dependencies for the upgrade: no solution found.
Unable to safely resolve dependencies, try running with --full-resolver.
sudo aptitude upgrade --full-resolver gets me:

Code:
The following NEW packages will be installed:
  apache2-bin{ab} apache2-data{ab} aptitude-common{a} cmap-adobe-japan1{a} cpp-4.8{ab} fonts-droid{a} g++-4.8{ab} gcc-4.8{ab} gir1.2-glib-2.0{a} gir1.2-gnomekeyring-1.0{a} git-man{a} 
  gs-cjk-resource{a} libapt-inst1.5{a} libapt-pkg4.12{a} libasan0{a} libatomic1{a} libbind9-90{a} libcppunit-1.13-0{a} libcupsfilters1{ab} libdns95{ab} libelfg0{a} libfftw3-double3{a} 
  libfftw3-single3{a} libgcc-4.8-dev{a} libgirepository-1.0-1{a} libglib2.0-bin{a} libglib2.0-data{a} libgnome-keyring-common{a} libgs9{ab} libgs9-common{a} libijs-0.35{a} libisc92{a} 
  libisccc90{a} libisccfg90{a} libitm1{a} liblua5.1-0{a} liblwres90{a} libp11-kit0{a} libpython2.7-minimal{a} libpython2.7-stdlib{a} libquadmath0{a} libstdc++-4.8-dev{a} libtsan0{a} python2.7{a} 
  python2.7-minimal{a} 
The following packages will be REMOVED:
  apache2.2-bin{u} libjson0{u} 
The following packages will be upgraded:
  apache2{b} apache2-doc apache2-mpm-prefork apache2-utils apache2.2-common{b} apt apt-utils aptitude{b} base-files bind9 bind9-host bind9utils binutils cpp dbus{b} deb-multimedia-keyring 
  deluge-common deluge-console deluge-web deluged g++ gcc gcc-4.7-base gcc-4.8-base ghostscript git git-core gitweb gzip ifupdown info install-info ldap-utils libapache2-mod-php5 libbind-dev 
  libbind9-60 libcppunit-dev libcups2{b} libcupsimage2 libdbus-1-3 libdns69 libfftw3-3 libgcc1 libglib2.0-0 libglib2.0-dev{b} libgmp10 libgnome-keyring-dev libgnome-keyring0 libgnutls26 libgomp1 
  libisc62 libisccc60 libisccfg62 libldap-2.4-2 libldap2-dev liblwres60 libnfnetlink0 libpq5{b} libpulse-mainloop-glib0 libpulse0{b} libssl-dev libssl0.9.8 libstdc++6 libtdb1 libwbclient0 
  linux-libc-dev openssh-client{b} openssh-server{b} openssl php5 php5-cli{b} php5-common{b} php5-curl python python-mako python-minimal{b} python-twisted-core{b} python-twisted-web python-xdg 
  samba-common samba-common-bin{b} ssh sudo syslinux syslinux-common tzdata vim{b} vim-common vim-runtime 
The following packages are RECOMMENDED but will NOT be installed:
  apt-xapian-index libparse-debianchangelog-perl xauth 
89 packages upgraded, 45 newly installed, 2 to remove and 0 not upgraded.
Need to get 116 MB of archives. After unpacking 151 MB will be used.
The following packages have unmet dependencies:
  openssh-server: Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.8.3+dfsg-4squeeze6 is installed.
  python-minimal: Breaks: python-support (< 1.0.10ubuntu2) but 1.0.10 is installed.
  g++-4.8: Depends: libcloog-isl4 (>= 0.17) which is a virtual package.
           Depends: libisl10 (>= 0.10) which is a virtual package.
           Depends: libmpfr4 (>= 3.1.1) but 3.1.0-5 is installed.
  libcupsfilters1: Depends: libjpeg8 (>= 8c) but 8b-1 is installed.
                   Depends: libtiff4 (> 3.9.5-3~) but 3.9.4-5+squeeze8 is installed.
  python-zope.interface: Depends: python (< 2.7) but 2.7.3-13 is to be installed.
  libdns95: Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.8.3+dfsg-4squeeze6 is installed.
  python-libtorrent: Depends: python (< 2.7) but 2.7.3-13 is to be installed.
  aptitude: Depends: libboost-iostreams1.49.0 (>= 1.49.0-1) which is a virtual package.
  python-apt: Depends: libapt-inst1.2 which is a virtual package.
              Depends: libapt-pkg4.10 which is a virtual package.
              Breaks: python (>= 2.7) but 2.7.3-13 is to be installed.
  gcc-4.8: Depends: libcloog-isl4 (>= 0.17) which is a virtual package.
           Depends: libisl10 (>= 0.10) which is a virtual package.
           Depends: libmpfr4 (>= 3.1.1) but 3.1.0-5 is installed.
  apache2: Conflicts: apache2.2-common but 2.2.16-6+squeeze11 is to be installed.
  dbus: Depends: libsystemd-login0 (>= 31) which is a virtual package.
  apache2.2-common: Depends: apache2.2-bin (= 2.2.16-6+squeeze11) but it is not going to be installed.
  libcups2: Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.8.3+dfsg-4squeeze6 is installed.
  libept1: Depends: libapt-pkg4.10 which is a virtual package.
  openssh-client: Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.8.3+dfsg-4squeeze6 is installed.
  php5-suhosin: Depends: phpapi-20090626 which is a virtual package.
  libglib2.0-dev: Depends: libpcre3-dev (>= 1:8.31) but it is not going to be installed.
  python-twisted-core: Depends: python-zope.interface (>= 3.6) but 3.5.3-1+b1 is installed.
  python-simplejson: Depends: python (< 2.7) but 2.7.3-13 is to be installed.
  libgs9: Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1 is installed.
          Depends: libjpeg8 (>= 8c) but 8b-1 is installed.
          Depends: liblcms2-2 which is a virtual package.
          Depends: libtiff4 (> 3.9.5-3~) but 3.9.4-5+squeeze8 is installed.
  vim: Depends: libacl1 (>= 2.2.51-8) but 2.2.49-4 is installed.
  apache2-bin: Depends: libaprutil1 (>= 1.4.0) but 1.3.9+dfsg-5 is installed.
               Conflicts: apache2.2-common but 2.2.16-6+squeeze11 is to be installed.
  libpq5: Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.8.3+dfsg-4squeeze6 is installed.
  python-markupsafe: Depends: python (< 2.7) but 2.7.3-13 is to be installed.
  cpp-4.8: Depends: libcloog-isl4 (>= 0.17) which is a virtual package.
           Depends: libisl10 (>= 0.10) which is a virtual package.
           Depends: libmpfr4 (>= 3.1.1) but 3.1.0-5 is installed.
  libpulse0: Depends: libjson0 (>= 0.10) but it is not going to be installed.
  apache2-data: Conflicts: apache2.2-common but 2.2.16-6+squeeze11 is to be installed.
  samba-common-bin: Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.8.3+dfsg-4squeeze6 is installed.
                    Depends: libkrb5-3 (>= 1.10+dfsg~) but 1.8.3+dfsg-4squeeze6 is installed.
                    Depends: libtalloc2 (>= 2.0.4~git20101213) but 2.0.1-1 is installed.
  php5-cli: Depends: libedit2 (>= 2.11-20080614-4) but 2.11-20080614-2 is installed.
  php5-common: Depends: psmisc (>= 22.15-1~) but 22.11-1 is installed.
               Conflicts: php5-suhosin but 0.9.32.1-1 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                                                      
1)      apache2                                                                           
2)      apache2-mpm-prefork                                                               
3)      apache2.2-common                                                                  
4)      aptitude                                                                          
5)      bind9                                                                             
6)      bind9-host                                                                        
7)      bind9utils                                                                        
8)      build-essential                                                                   
9)      cpp                                                                               
10)     dbus                                                                              
11)     deluge-common                                                                     
12)     deluge-console                                                                    
13)     deluge-web                                                                        
14)     deluge-webui                                                                      
15)     deluged                                                                           
16)     g++                                                                               
17)     gcc                                                                               
18)     ghostscript                                                                       
19)     host                                                                              
20)     krb5-config                                                                       
21)     libapache2-mod-php5                                                               
22)     libbind-dev                                                                       
23)     libcups2                                                                          
24)     libcupsimage2                                                                     
25)     libept1                                                                           
26)     libglib2.0-dev                                                                    
27)     libgnome-keyring-dev                                                              
28)     libgs8                                                                            
29)     libpam-krb5                                                                       
30)     libphonon4                                                                        
31)     libpq5                                                                            
32)     libpulse-mainloop-glib0                                                           
33)     libpulse0                                                                         
34)     libqt4-dev                                                                        
35)     libqt4-opengl-dev                                                                 
36)     libqt4-webkit                                                                     
37)     libtool                                                                           
38)     lsb-release                                                                       
39)     openssh-client                                                                    
40)     openssh-server                                                                    
41)     php5                                                                              
42)     php5-cli                                                                          
43)     php5-common                                                                       
44)     php5-curl                                                                         
45)     php5-suhosin                                                                      
46)     python-apt                                                                        
47)     python-chardet                                                                    
48)     python-debian                                                                     
49)     python-libtorrent                                                                 
50)     python-mako                                                                       
51)     python-markupsafe                                                                 
52)     python-openssl                                                                    
53)     python-simplejson                                                                 
54)     python-support                                                                    
55)     python-twisted-core                                                               
56)     python-twisted-web                                                                
57)     python-zope.interface                                                             
58)     samba-common-bin                                                                  
59)     ssh                                                                               
60)     vim                                                                               

      Keep the following packages at their current version:                               
61)     apache2-bin [Not Installed]                                                       
62)     cpp-4.8 [Not Installed]                                                           
63)     g++-4.8 [Not Installed]                                                           
64)     gcc-4.8 [Not Installed]                                                           
65)     gs-cjk-resource [Not Installed]                                                   
66)     libbind9-90 [Not Installed]                                                       
67)     libcupsfilters1 [Not Installed]                                                   
68)     libdns95 [Not Installed]                                                          
69)     libgs9 [Not Installed]                                                            
70)     libisccfg90 [Not Installed]                                                       

      Leave the following dependencies unresolved:                                        
71)     dpkg-dev recommends build-essential                                               
72)     groff recommends ghostscript                                                      
73)     libltdl-dev recommends libtool                                                    
74)     openssh-blacklist recommends openssh-client                                       
75)     psutils recommends ghostscript                                                    
76)     python-debian recommends python-apt                                               
77)     libqtgui4 recommends libcups2                                                     
78)     apache2-doc recommends apache2                                                    
79)     aptitude-common recommends aptitude                                               
80)     libdbus-1-3 recommends dbus                                                       
81)     git recommends ssh-client                                                         
82)     samba-common recommends samba-common-bin                                          
83)     vim-common recommends vim | vim-gnome | vim-gtk | vim-athena | vim-nox | vim-tiny 
84)     vim-runtime recommends vim | vim-gnome | vim-gtk | vim-athena | vim-nox | vim-tiny


Accept this solution? [Y/n/q/?]
What to do about the "let's uninstall all of your important stuff like aptitude, deluge, gcc, vim and everything else you really need" thing?

Help is much appreciated.
 
Old 03-10-2013, 07:43 PM   #2
rigor
Member
 
Registered: Sep 2011
Posts: 213

Rep: Reputation: Disabled
aquafinity,

It almost looks as though your "package database" is corrupt, or at least doesn't have an accurate idea of with what packages are actually installed.
Did you keep an install log and also keep the packages around, so that you might reconstruct what the state of the system should be?
Have you noticed any disk errors or other problems, shortly before you noticed the package problem? Are there any disk errors reported in the system logs?
Are there any other errors reported in the system logs?

Inquiring minds want to know. Seriously though, additional details would help us help you better.
 
Old 03-10-2013, 09:06 PM   #3
dreamwalking
Member
 
Registered: Dec 2005
Distribution: Slackware 14
Posts: 106

Rep: Reputation: 30
What was the package you tried to install before you got this problem? The apt output looks like you tried to install a lower version package, while all your dependencies for it are already installed and higher version.

If that is indeed the case, maybe you can try deleting the file of the problem from /var/cache/apt/archives and run an apt-get -f install

Or try dpkg --audit , if I remember well it should output the problem packages.

If you were just try to update though, maybe try an apt-get clean all and after repeat an apt-get update
 
Old 03-10-2013, 09:08 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Do you have by any chance chance repositories of different Debian versions (or even mixed Ubuntu repositories in)?
I would like to see your /etc/apt/sources.list and, if they exist, content of files in /etc/apt/sources.list.d to see your basic configuration, this looks like you have broken your system with mixing stable and experimental repositories.
 
Old 03-10-2013, 09:32 PM   #5
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I experienced the same problem while upgrading from squeeze to wheezy. My solution was to use apt-get upgrade followed by apt-get dist-upgrade
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hopelessly stuck on making Nvidia Driver work on Debian chui1989 Linux - Laptop and Netbook 3 09-23-2012 05:16 AM
How Can I Fix Broken Dependencies Ted Asner Linux - Software 1 09-04-2009 03:15 PM
Broken Dependencies - Bash lolwtfnoob Debian 14 04-24-2009 10:51 AM
Apt-Get i need help fixing broken dependencies turkenator02 SUSE / openSUSE 2 05-11-2006 05:36 AM
New to apt-get and have broken dependencies aquaboot Debian 9 08-21-2005 03:09 AM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration