LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2011, 07:58 PM   #1
jogl_z_8
Member
 
Registered: Oct 2005
Location: SW Ontario Canada
Distribution: Debian
Posts: 106

Rep: Reputation: Disabled
Debian Box Dying.


I am running Debian 6.0. System is an AMD Athlon dual core processor on an ASRock N68C-GS UCC motherboard, 4 gig ram, 500 gig hd.

I have had it for a few months and it has never been right. It has recently taken a turn for the worst locking up after running for only a few minutes.

I swapped in a different hard drive with the same results.

It appears to be running but when I try to open an app in Gnome it says "Could not launch menu item, Failed to execute child process... (input/output error)"

Also, if I go to a terminal console and try to log on it just does nothing but grind for a bit and then go back to the prompt.

I can not even log out, have to power down.

Where should I start in trying to isolate this problem?

When I restart I can get into a console and check /var/log/messages, etc.

Thanks,
JP.
 
Old 04-03-2011, 08:37 PM   #2
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 703

Rep: Reputation: 97
I would start by testing the hardware. This could easily be a
problem with a cpu overheating or some kind of memory errors.

Start by getting a system rescue cd and run memtest86. Let it run
for a couple of hours and see if you get any memory errors. If you
still don't see any errors, try booting normally and check the output
of "cat /proc/acpi/thermal_zone/*/temperature" to see if any of the
temperatures go up.

If it still fails, take the case apart and reseat all the chips,
cables and memory sticks. Check the fans while you have it open.
 
1 members found this post helpful.
Old 04-06-2011, 08:38 PM   #3
jogl_z_8
Member
 
Registered: Oct 2005
Location: SW Ontario Canada
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: Disabled
Reseated everything, cleaned heat sink, new heat sink compound, re-assembled and 50 hrs of run now with no problems.
 
Old 04-07-2011, 07:24 AM   #4
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 703

Rep: Reputation: 97
Very cool. Thanks for the update. It's great to know that it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Quota in a Debian box brgsousa Linux - Software 0 12-10-2009 03:40 PM
Advice wanted on moving dying Windows XP box to dual boot pwalden Linux - General 14 11-10-2008 03:10 AM
Politics and Software, Is Debian dying? aldimeneira Debian 14 10-13-2006 12:27 PM
Cannot ssh to debian box from Gentoo box or Putty, but I can from Cygwin? Pengus Linux - Networking 2 01-20-2006 01:47 PM
Debian box freezes aliensub Linux - General 0 02-06-2003 06:41 PM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration