LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2015, 04:16 PM   #1
DebianUserAmin
LQ Newbie
 
Registered: Oct 2015
Location: Denmark
Posts: 4

Rep: Reputation: Disabled
Debian boot error


Hi LQ

Iam all new to this forum and linux in general.

I have just tried to install Debian.gnome.amd64 on my machine for the second time. I have installed Windows countless times and a single linux system before, so i thougt installing Debian would be peice of cake, i was wrong.

After the fist install i got an error while booting and a freze, i didnt think much of it and restarted the installation process. Now the second time i get another error while booting stating that: 'Radeon kernel modesetting for r600 or later requires firmware-linux-nonfree' after this message the computer refuses to respond to any input - just like the first time.

How do i solve this problem and what am i doing wrong? Thanks!

(Not english native)
 
Old 10-08-2015, 04:56 PM   #2
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Try installing again using one of the unofficial ISO images that already contain the non-free firmware:
http://cdimage.debian.org/cdimage/un...ding-firmware/
 
Old 10-08-2015, 06:18 PM   #3
cynwulf
Senior Member
 
Registered: Apr 2005
Location: The Black Country, UK
Posts: 1,742
Blog Entries: 1

Rep: Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774Reputation: 774
Reinstalling seems like the sledgehammer solution.

Boot the kernel with the nomodeset parameter. Add non-free to your sources, install the non-free firmware and reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Grub Error with Mint Debian over Ubuntu 12.04 with Win7 Dual Boot Grub Error mariose Linux - Newbie 8 07-01-2013 09:31 PM
Debian 5.05 Boot up Error (Won't Boot) harley51 Debian 1 07-12-2010 02:00 AM
Boot messg error on Debian "eth0: Error while getting interface flags: No such device gatorade03 Linux - Newbie 6 01-09-2010 08:33 PM
Boot Error and Boot Log (Debian) jef3189 Linux - Software 2 11-20-2008 06:10 PM
Debian Sarge - Grub Boot Error 16: arunkk Debian 3 05-16-2006 02:15 PM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration