LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2007, 06:49 AM   #1
jchambers
Member
 
Registered: Aug 2007
Location: California
Distribution: Debian
Posts: 127

Rep: Reputation: 15
Debian / amd64 / install libsqlite3 ?


My main goal is to get libqt4-headers installed.

Code:
# apt-get -s install libsqlite3-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libqt4-dev: Depends: libxrandr-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
              Depends: libsm-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
              Depends: libxmu-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
              Depends: libice-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
              Depends: libxt-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
              Depends: libxrender-dev but it is not going to be installed
              Depends: libxcursor-dev but it is not going to be installed
              Depends: libxinerama-dev but it is not going to be installed
              Depends: libxi-dev but it is not going to be installed
              Depends: libmng-dev (>= 1.0.3) but it is not going to be installed
              Depends: libxft-dev but it is not going to be installed
              Depends: libaudio-dev but it is not going to be installed
              Depends: libpq-dev but it is not going to be installed
              Depends: libglib2.0-dev but it is not going to be installed
              Depends: libsqlite0-dev but it is not going to be installed
  libqt4-qt3support: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not going to be installed
                     Depends: libsqlite0 (>= 2.8.17) but it is not going to be installed
  libqt4-sql: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not going to be installed
              Depends: libsqlite0 (>= 2.8.17) but it is not going to be installed
  qt4-designer: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not going to be installed
                Depends: libsqlite0 (>= 2.8.17) but it is not going to be installed
  qt4-qtconfig: Depends: libmysqlclient15off (>= 5.0.27-1) but it is not going to be installed
                Depends: libsqlite0 (>= 2.8.17) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Would anyone have any suggestions for this.
Is there a repo I could add or do I need to install these one by one?

I have been working on this for a while now without success...
 
Old 09-19-2007, 07:24 AM   #2
jchambers
Member
 
Registered: Aug 2007
Location: California
Distribution: Debian
Posts: 127

Original Poster
Rep: Reputation: 15
Update

My list is growing....

Code:
# dpkg -i ./*.deb
(Reading database ... 92826 files and directories currently installed.)
Preparing to replace libaudio-dev 1.9-2+b1 (using .../libaudio-dev_1.9-2+b1_amd64.deb) ...
Unpacking replacement libaudio-dev ...
Preparing to replace libglib2.0-dev 2.14.0-2 (using .../libglib2.0-dev_2.14.0-2_amd64.deb) ...
Unpacking replacement libglib2.0-dev ...
Preparing to replace libgstreamer0.8-0 0.8.12-2 (using .../libgstreamer0.8-0_0.8.12-2_amd64.deb) ...
Unpacking replacement libgstreamer0.8-0 ...
Preparing to replace libice-dev 2:1.0.4-1 (using ./libice-dev_1.0.4-1_amd64.deb) ...
Unpacking replacement libice-dev ...
Preparing to replace libmng-dev 1.0.9-1 (using ./libmng-dev_1.0.9-1_amd64.deb) ...
Unpacking replacement libmng-dev ...
Preparing to replace libpq-dev 8.2.4-2 (using ./libpq-dev_8.2.4-2_amd64.deb) ...
Unpacking replacement libpq-dev ...
Preparing to replace libqt4-dev 4.3.1-2 (using ./libqt4-dev_4.3.1-2_amd64.deb) ...
Unpacking replacement libqt4-dev ...
Preparing to replace libqt4-qt3support 4.3.1-2 (using .../libqt4-qt3support_4.3.1-2_amd64.deb) ...
Unpacking replacement libqt4-qt3support ...
Preparing to replace libqt4-sql 4.3.1-2 (using ./libqt4-sql_4.3.1-2_amd64.deb) ...
Unpacking replacement libqt4-sql ...
Preparing to replace libsm-dev 2:1.0.3-1+b1 (using .../libsm-dev_1.0.3-1+b1_amd64.deb) ...
Unpacking replacement libsm-dev ...
Preparing to replace libsqlite0 2.8.17-3 (using .../libsqlite0_2.8.17-3_amd64.deb) ...
Unpacking replacement libsqlite0 ...
Preparing to replace libsqlite0-dev 2.8.17-3 (using .../libsqlite0-dev_2.8.17-3_amd64.deb) ...
Unpacking replacement libsqlite0-dev ...
Preparing to replace libx11-dev 2:1.0.3-7 (using ./libx11-dev_1.0.3-7_amd64.deb) ...
Unpacking replacement libx11-dev ...
Preparing to replace libxcursor-dev 1:1.1.9-1 (using .../libxcursor-dev_1.1.9-1_amd64.deb) ...
Unpacking replacement libxcursor-dev ...
Preparing to replace libxext-dev 1:1.0.3-2 (using .../libxext-dev_1.0.3-2_amd64.deb) ...
Unpacking replacement libxext-dev ...
Preparing to replace libxft-dev 2.1.12-2 (using .../libxft-dev_2.1.12-2_amd64.deb) ...
Unpacking replacement libxft-dev ...
Preparing to replace libxi-dev 2:1.1.3-1 (using ./libxi-dev_1.1.3-1_amd64.deb) ...
Unpacking replacement libxi-dev ...
Preparing to replace libxinerama-dev 1:1.0.2-1 (using .../libxinerama-dev_1.0.2-1_amd64.deb) ...
Unpacking replacement libxinerama-dev ...
Preparing to replace libxmu-dev 1:1.0.3-1 (using ./libxmu-dev_1.0.3-1_amd64.deb) ...
Unpacking replacement libxmu-dev ...
Preparing to replace libxrandr-dev 2:1.1.0.2-5 (using .../libxrandr-dev_1.1.0.2-5_amd64.deb) ...
Unpacking replacement libxrandr-dev ...
Preparing to replace libxrender-dev 1:0.9.3-1 (using .../libxrender-dev_0.9.3-1_amd64.deb) ...
Unpacking replacement libxrender-dev ...
Preparing to replace qt4-designer 4.3.1-2 (using .../qt4-designer_4.3.1-2_amd64.deb) ...
Unpacking replacement qt4-designer ...
Preparing to replace qt4-dev-tools 4.3.1-2 (using .../qt4-dev-tools_4.3.1-2_amd64.deb) ...
Unpacking replacement qt4-dev-tools ...
Preparing to replace qt4-qtconfig 4.3.1-2 (using .../qt4-qtconfig_4.3.1-2_amd64.deb) ...
Unpacking replacement qt4-qtconfig ...
Setting up libaudio-dev (1.9-2+b1) ...
dpkg: dependency problems prevent configuration of libglib2.0-dev:
 libglib2.0-dev depends on libglib2.0-0 (= 2.14.0-2); however:
  Version of libglib2.0-0 on system is 2.14.1-2.
dpkg: error processing libglib2.0-dev (--install):
 dependency problems - leaving unconfigured
Setting up libgstreamer0.8-0 (0.8.12-2) ...
Setting up libice-dev (2:1.0.4-1) ...
dpkg: dependency problems prevent configuration of libmng-dev:
 libmng-dev depends on liblcms1-dev; however:
  Package liblcms1-dev is not installed.
dpkg: error processing libmng-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpq-dev:
 libpq-dev depends on libpq5 (= 8.2.4-2); however:
  Version of libpq5 on system is 8.2.4-3.
 libpq-dev depends on libssl-dev; however:
  Package libssl-dev is not installed.
 libpq-dev depends on libkrb5-dev; however:
  Package libkrb5-dev is not installed.
 libpq-dev depends on comerr-dev; however:
  Package comerr-dev is not installed.
dpkg: error processing libpq-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-dev:
 libqt4-dev depends on libxt-dev (>= 4.3.0.dfsg.1-4); however:
  Package libxt-dev is not installed.
 libqt4-dev depends on libmng-dev (>= 1.0.3); however:
  Package libmng-dev is not configured yet.
 libqt4-dev depends on libpq-dev; however:
  Package libpq-dev is not configured yet.
 libqt4-dev depends on libglib2.0-dev; however:
  Package libglib2.0-dev is not configured yet.
dpkg: error processing libqt4-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-qt3support:
 libqt4-qt3support depends on libmysqlclient15off (>= 5.0.27-1); however:
  Package libmysqlclient15off is not installed.
dpkg: error processing libqt4-qt3support (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-sql:
 libqt4-sql depends on libmysqlclient15off (>= 5.0.27-1); however:
  Package libmysqlclient15off is not installed.
dpkg: error processing libqt4-sql (--install):
 dependency problems - leaving unconfigured
Setting up libsm-dev (2:1.0.3-1+b1) ...
Setting up libsqlite0 (2.8.17-3) ...
Setting up libsqlite0-dev (2.8.17-3) ...
dpkg: dependency problems prevent configuration of libxcursor-dev:
 libxcursor-dev depends on libxfixes-dev; however:
  Package libxfixes-dev is not installed.
dpkg: error processing libxcursor-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxft-dev:
 libxft-dev depends on libfontconfig1-dev; however:
  Package libfontconfig1-dev is not installed.
dpkg: error processing libxft-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxinerama-dev:
 libxinerama-dev depends on x11proto-xinerama-dev; however:
  Package x11proto-xinerama-dev is not installed.
dpkg: error processing libxinerama-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxmu-dev:
 libxmu-dev depends on libxt-dev; however:
  Package libxt-dev is not installed.
 libxmu-dev depends on libxmu-headers; however:
  Package libxmu-headers is not installed.
dpkg: error processing libxmu-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxrandr-dev:
 libxrandr-dev depends on libxrandr2 (= 2:1.1.0.2-5); however:
  Version of libxrandr2 on system is 2:1.2.2-1.
 libxrandr-dev depends on x11proto-randr-dev; however:
  Package x11proto-randr-dev is not installed.
dpkg: error processing libxrandr-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxrender-dev:
 libxrender-dev depends on libxrender1 (= 1:0.9.3-1); however:
  Version of libxrender1 on system is 1:0.9.4-1.
 libxrender-dev depends on x11proto-render-dev; however:
  Package x11proto-render-dev is not installed.
dpkg: error processing libxrender-dev (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qt4-designer:
 qt4-designer depends on libmysqlclient15off (>= 5.0.27-1); however:
  Package libmysqlclient15off is not installed.
 qt4-designer depends on libqt4-qt3support (>= 4.3.1); however:
  Package libqt4-qt3support is not configured yet.
 qt4-designer depends on libqt4-sql (>= 4.3.1); however:
  Package libqt4-sql is not configured yet.
 qt4-designer depends on libqt4-dev; however:
  Package libqt4-dev is not configured yet.
dpkg: error processing qt4-designer (--install):
 dependency problems - leaving unconfigured
Setting up qt4-dev-tools (4.3.1-2) ...
dpkg: dependency problems prevent configuration of qt4-qtconfig:
 qt4-qtconfig depends on libmysqlclient15off (>= 5.0.27-1); however:
  Package libmysqlclient15off is not installed.
 qt4-qtconfig depends on libqt4-qt3support (>= 4.3.1); however:
  Package libqt4-qt3support is not configured yet.
 qt4-qtconfig depends on libqt4-sql (>= 4.3.1); however:
  Package libqt4-sql is not configured yet.
dpkg: error processing qt4-qtconfig (--install):
 dependency problems - leaving unconfigured
Setting up libxext-dev (1:1.0.3-2) ...
Setting up libx11-dev (2:1.0.3-7) ...
Setting up libxi-dev (2:1.1.3-1) ...
Errors were encountered while processing:
 libglib2.0-dev
 libmng-dev
 libpq-dev
 libqt4-dev
 libqt4-qt3support
 libqt4-sql
 libxcursor-dev
 libxft-dev
 libxinerama-dev
 libxmu-dev
 libxrandr-dev
 libxrender-dev
 qt4-designer
 qt4-qtconfig

I downloaded the other packages from http://packages.debian.org indidually, but this list is getting out-of-hand...

the replacements are because I ran it twice hoping for magic
 
Old 09-19-2007, 10:43 AM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 69
You want http://snapshot.debian.net to get the exact version number of the packages causing the errors like the one I show below you want to install with dpkg -i package.deb package2.deb ... then try installing the others making sure to do a dpkg --configure -a at the end to get an unconfigured packages that may be left over.

Code:
dpkg: dependency problems prevent configuration of libglib2.0-dev:
 libglib2.0-dev depends on libglib2.0-0 (= 2.14.0-2); however:
  Version of libglib2.0-0 on system is 2.14.1-2
Edit: BTW what version of Debian are you running and why are you not just getting these installed through normal means with apt-get or aptitude??
 
Old 09-19-2007, 11:06 AM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
Have you run apt-get -f install like it says?

Post your /etc/apt/sources.list.

(as above) What version of Debian and why can't you install all those packages via apt-get ?

Last edited by AlucardZero; 09-19-2007 at 11:11 AM.
 
Old 09-19-2007, 11:58 AM   #5
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
did you forget to update before you installed ?

If your object is to install libqt4-headers why is your command apt-get install libsqlite3-dev ?

Also interesting I see libqt3-headers package but not a libqt4-headers package..
it looks like the libqt4-headers have been merged with the libqt4-dev package

aptitude update
aptitude keep-all
aptitude install libqt4-dev

Last edited by farslayer; 09-19-2007 at 12:03 PM.
 
Old 09-19-2007, 03:17 PM   #6
jchambers
Member
 
Registered: Aug 2007
Location: California
Distribution: Debian
Posts: 127

Original Poster
Rep: Reputation: 15
Getting closer...

2.6.21-2-amd64

Should I not be using the newest kernel image?

# apt-get update
After I make a change to the sources.list file.


Update....

So I did dpkg --purge [package name] on all the files I downloaded manually. Then I updated and used apt-get and it worked!



But I am stuck again...

Code:
# dpkg -l | grep qt
ii  libqt3-mt                            3:3.3.7-7                  Qt GUI Library (Threaded runtime version), V
ii  libqt4-core                          4.3.1-2                    Qt 4 core non-GUI functionality runtime libr
ii  libqt4-dev                           4.3.1-2                    Qt 4 development files
ii  libqt4-gui                           4.3.1-2                    Qt 4 core GUI functionality runtime library
ii  libqt4-qt3support                    4.3.1-2                    Qt 3 compatibility library for Qt 4
ii  libqt4-sql                           4.3.1-2                    Qt 4 SQL database module
ii  python-qt3                           3.17.3-2                   Qt3 bindings for Python


Now and am trying to configure vlc with qt.

./configure --enable-old-dbus --enable-release --enable-v4l --enable-pvr --with-x --with-ffmpeg-mp3lame --with-ffmpeg-x264 --with-ffmpeg-zlib --with-a52-fixed --disable-mad --disable-libmpeg2 --enable-qte --enable-mozilla
Code:
checking qt.h usability... no
checking qt.h presence... no
checking for qt.h... no
configure: error: echo "Cannot find QT Embedded development headers."
Doesn't libqt4-dev have the headers in it?

# find / -name qt.h
gives no results.



Thank you all for your responses!
 
Old 09-19-2007, 04:06 PM   #7
jchambers
Member
 
Registered: Aug 2007
Location: California
Distribution: Debian
Posts: 127

Original Poster
Rep: Reputation: 15
One more update...


Code:
# dpkg -l | grep qt
ii  libqt3-headers                       3:3.3.7-8                  Qt3 header files
ii  libqt3-mt                            3:3.3.7-7                  Qt GUI Library (Threaded runtime version), V
ii  libqt4-core                          4.3.1-2                    Qt 4 core non-GUI functionality runtime libr
ii  libqt4-dev                           4.3.1-2                    Qt 4 development files
ii  libqt4-gui                           4.3.1-2                    Qt 4 core GUI functionality runtime library
ii  libqt4-qt3support                    4.3.1-2                    Qt 3 compatibility library for Qt 4
ii  libqt4-sql                           4.3.1-2                    Qt 4 SQL database module
ii  python-qt3                           3.17.3-2                   Qt3 bindings for Python
ii  qt4-dev-tools                        4.3.1-2                    Qt 4 development tools
I added qt3-headers and qt4-dev-tools


So first I made a symbolic link to qt4/qt.h --> /usr/include/qt3/qt.h and tried again, no go.

Code:
n# find / -name qt.h
/usr/include/qt3/qt.h
/usr/include/qt4/qt.h
Next I tried to add both qt3 and qt4 for the path.
./configure --enable-old-dbus --enable-release --enable-v4l --enable-pvr --with-x --with-ffmpeg-mp3lame --with-ffmpeg-x264 --with-ffmpeg-zlib --with-a52-fixed --disable-mad --disable-libmpeg2 --enable-qte --enable-mozilla --with-qte=/usr/include/qt3

But that did not work either?
 
Old 09-19-2007, 08:04 PM   #8
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
Is installing VLC the actual goal here?

Have you run apt-get -f install like it says?

Post your /etc/apt/sources.list.

What version of Debian (Etch/4.0? Lenny? Sid??) and why can't you install all those packages via apt-get ?
 
Old 09-19-2007, 08:57 PM   #9
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
VLC should just be an apt-get away..

if you add debian-multimedia to your sources list.

for etch the source would be
Code:
deb http://www.debian-multimedia.org etch main
then

apt-get update
apt-get install vlc mozilla-plugin-vlc


reference http://www.videolan.org/vlc/download-debian.html
 
Old 09-20-2007, 01:45 AM   #10
jchambers
Member
 
Registered: Aug 2007
Location: California
Distribution: Debian
Posts: 127

Original Poster
Rep: Reputation: 15
Ok, so here it is....

Lenny

My apologies for the confusion.


Yes the goal is to install vlc 0.9.0-svn with h264 support.
Currently I have to use the vlc nightlies to get that done.
I was also told on the vlc forum that I should use the src and build it myself.

I was also told I had to install the newest source for ffmpeg to enable h264 as well. I did that and the printout told me h264 was now supported.

I have also tried installing vlc through apt-get but it did not support h264 either. This is why I was trying to get qt4 installed as I think h264 use it. I may be wrong on that though...

So at this point I am ready to scrap the system which has installs from sarge, etch, sid, etc...

I am thinking I should reinstall Etch this time and only use Etch repos.
For me finding the and using the repos is the hardest part, which is probably a breeze for most.


Here is my current source.list
Though I used others at one point
Code:
# /etc/apt/sources.list 
# Sun's Java is now in the Official Debian Unstable non-free repo.
# The AMD-64 repositories from Debian are now in the normal Sid repos.
# I run Debian Sid, however this list covers Stable, Testing and Sid
# please use only the repos that apply to your release.

###########
## Sid ####
###########
#####(My Debian Sid/Sidux sources.list)###########
# Unstable Sid
 deb http://http.us.debian.org/debian/ unstable main contrib non-free 
# Unstable Sources
 deb-src http://http.us.debian.org/debian/ unstable main contrib non-free 

# sidux http://sidux.com/files/misc/sources.list
deb http://sidux.com/debian/ sid main contrib non-free firmware fix.main fix.contrib fix.non-free
deb-src http://sidux.com/debian/ sid main contrib non-free firmware fix.main fix.contrib fix.non-free

#xadras sidux repo -siduxcc, autostart,sidux-kio,klamp
 deb http://62.75.168.124/sidux binary/ 

# Marillat Mirror
deb http://debian.three-dimensional.net/debian-multimedia/ unstable main 
deb-src http://debian.three-dimensional.net/debian-multimedia/ unstable main

# Compiz Fusion for Debian Sid/sidux
# For more info see: http://www.linuxsmokersclub.com/?p=95
# deb http://download.tuxfamily.org/shames/debian-sid/desktopfx/unstable/ ./

# Beryl-svn daily repo for Debian Sid/sidux Beryl is dead please see cf.

############### End Sid sources.list ##################


#######################
## Multi-media Repos ##
#######################
# Marillat For info visit http://www.debian-multimedia.org
# Unstable
#deb http://www.debian-multimedia.org sid main
#deb-src http://www.debian-multimedia.org sid main

# Experimental
# deb http://www.debian-multimedia.org experimental main 

# RareWares/Debian Multi-Media Repository for Unstable
# Info http://www.rarewares.org/debian.html
deb http://www.rarewares.org/debian/packages/unstable/ ./
# RareWares/Debian Multi-Media Repository for Unstable - Experimental Staging
deb http://www.rarewares.org/debian/packages/experimental/ ./ 

#VLC's latest packaged version is always in the official Debian unstable branch. 
#However you should still use our apt-get line if you need libdvdcss:
 deb http://download.videolan.org/pub/videolan/debian sid main
 deb-src http://download.videolan.org/pub/videolan/debian sid main 

#Vlc [nightly builds], add: 
#deb http://nightlies.videolan.org/build/sid-i386/arch ./ , to #/etc/apt/sources.list [/sid-amd64/ for 64-bit]; 
#then: gpg --keyserver #wwwkeys.eu.pgp.net --recv-keys AA5F4DE6 
#&& apt-key add /root/.gnupg/pubring.gpg

# My Media System http://mymediasystem.org/
# deb http://www.prodeia.de/mms/sid binary/ 
# deb-src http://www.prodeia.de/mms source/

# Tovid http://tovid.wikia.com/wiki/Installing_tovid/Debian
# deb     http://tovid.sourceforge.net/download/debian unstable contrib
# deb-src http://tovid.sourceforge.net/download/debian unstable contrib

# Google software repository http://www.google.com/linuxrepositories/apt.html
# deb http://dl.google.com/linux/deb/ stable non-free 

# IVTV #
# deb http://dl.ivtvdriver.org/ubuntu/ edgy ivtv
# deb-src http://dl.ivtvdriver.org/ubuntu/ edgy ivtv

# Debians semi-official multimedia repo. 
deb http://mirror.home-dn.net/debian-multimedia/ stable main

# This Repo contains misc stuff, some is outdated, but in the last time I noticed updates made to the repo.
deb http://ftp.debian-unofficial.org/debian/ stable main contrib non-free restricted



####################
## Debian Testing ##
####################
# Testing 
#deb http://ftp.debian.org/debian/ testing main contrib non-free
#deb-src http://ftp.debian.org/debian/ testing main contrib non-free
#Testing Security updates
#deb http://security.debian.org/ testing/updates main contrib
#deb-src http://security.debian.org/ testing/updates main contrib

##################
## Experimental ##
##################
# Debian experimental
#deb http://ftp.debian.org/debian/ experimental main contrib non-free  

# Debian experimental kernels #
# deb http://kernel-archive.buildserver.net/debian-kernel/ trunk main


###################
## Stable Etch ####
###################
# Wine
# Debian Etch (4.0):
#sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/etch.list -O #/etc/apt/sources.list.d/winehq.list

#Stable 
deb http://http.us.debian.org/debian/ stable main contrib non-free 
#Stable Sources
deb-src http://http.us.debian.org/debian/ stable main contrib non-free 
#Security Updates Stable
#deb http://security.debian.org/ stable/updates main contrib non-free 

# Debian Stable Backports 
# For information visit 
# http://www.backports.org/dokuwiki/doku.php?id=instructions
# If you need the backports key, try
# gpg --recv-keys 16BA136C
# gpg --export |apt-key add -
deb http://www.backports.org/debian etch-backports main contrib non-free

# Debian Unofficial Repository  
# For more info visit http://debian-unofficial.org/
deb http://ftp.debian-unofficial.org/debian stable main contrib non-free restricted
deb-src http://ftp.debian-unofficial.org/debian stable main contrib non-free restricted

# Backports of various packages for Debian 4.0 Etch
# Updated versions of Firefox and Thunderbird
# For more information visit http://debian.stdout.at/
# deb http://debian.stdout.at/ ./

#########  End of suggested Stable repos ###########


########################
### EXTERNAL SOURCES ###
########################

## Desktops ###
# Debian's XFCE Group http://pkg-xfce.alioth.debian.org/
# deb http://debian.corsac.net unstable/
# deb-src http://debian.corsac.net unstable/

# ROX Desktop
# For info see: http://rox.sourceforge.net/desktop/node/86
# deb ftp://ftp.berlios.de/pub/rox4debian binary/

# Enlightenment E17
# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 7E5D69A103CA4243
# deb http://www.edevelop.org/debian unstable main

# LG3D - Project Looking Glass
# deb http://javadesktop.org/lg3d/debian stable contrib
# deb http://javadesktop.org/lg3d/debian testing contrib
# deb http://javadesktop.org/lg3d/debian unstable contrib

## Web Browsers ###
# Swiftfox - Firefox builds for your CPU
# deb http://getswiftfox.com/builds/debian unstable non-free

# The Opera Web Browser Official packages.
# Etch/Sid packages are available: http://www.opera.com/
### Example apt source configuration (uncomment the version you want)
# Opera Browser - Production release
#deb http://deb.opera.com/opera/ stable non-free
#deb http://deb.opera.com/opera/ testing non-free
#deb http://deb.opera.com/opera/ unstable non-free
# Opera Browser - Beta release
#deb http://deb.opera.com/opera-beta/ stable non-free
#deb http://deb.opera.com/opera-beta/ testing non-free
#deb http://deb.opera.com/opera-beta/ unstable non-free

### Miscellaneous ###
# Star Control II - The Ur Quan Masters A really cool game!!
# deb http://uqm.debian.net/ unstable/ 

# Official site for latest version of Skype.
# deb http://download.skype.com/linux/repos/debian/ stable non-free

# TOR http://wiki.noreply.org/noreply/TheOnionRouter/TorOnDebian
# deb http://mirror.noreply.org/pub/tor sid main
# deb-src http://mirror.noreply.org/pub/tor sid main

#wine
# deb http://wine.sourceforge.net/apt/ binary/ 

# Unofficial Debian packages
# http://packages.kirya.net/
# deb http://packages.kirya.net/debian/ unstable main contrib non-free
# deb-src http://packages.kirya.net/debian/ unstable main contrib non-free

# X drivers for sis vga chips.Unstable (sid).
# deb http://www.winischhofer.net/sis/debian/unstable/ ./
# deb-src http://www.winischhofer.net/sis/debian/unstable/ ./ 

# ndsiwraper wireless driver
# deb http://ndiswrapper.sourceforge.net/debian/ ./ 




deb http://snapshot.debian.net/archive pool glib2.0
deb-src http://snapshot.debian.net/archive pool glib2.0
I dont't mind strating over if I'm learing something.
I'll wait to hear back before I do anything drastic.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Debian AMD64 Etch install - need help to run Quake 4 demo BigVig Debian 1 10-15-2006 03:24 PM
Debian AMD64 Etch cannot install KDE shrabok Debian 4 07-07-2006 11:10 PM
Install 32 Bit Firfox/Plugins on AMD64 Debian pafinator11 Debian 1 01-29-2006 10:23 PM
debian install on MSI K8N NEO2 (amd64) dgrego Debian 1 06-08-2005 08:47 AM
How to install 32 bit libraries under AMD64 debian? ssobeht Debian 0 02-11-2005 11:14 AM


All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration