LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-06-2006, 04:09 AM   #1
stdio.h
LQ Newbie
 
Registered: Sep 2006
Location: Australia
Distribution: Debian Etch
Posts: 8

Rep: Reputation: 0
Debian: ALSA and network lose settings on startup.


Okay. This is a problem that has plagued me with a Sarge and Etch based install of Debian.

Every time I start up, I need to rerun alsaconf and dhclient.

There's a little more to it than that.

During startup, it does do the alsa loading, but says <none loaded>

It also does the whole dhcp thing, gets the ip address too.

However, by the time I get to login, the networking has evaporated. I need to run dhclient to get it back.

I also need to rerun alsaconf too.

What on earth is going on?

Thanks.
 
Old 09-06-2006, 12:09 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,520

Rep: Reputation: 70
Quote:
Originally Posted by stdio.h
Okay. This is a problem that has plagued me with a Sarge and Etch based install of Debian.

Every time I start up, I need to rerun alsaconf and dhclient.

There's a little more to it than that.

During startup, it does do the alsa loading, but says <none loaded>

It also does the whole dhcp thing, gets the ip address too.

However, by the time I get to login, the networking has evaporated. I need to run dhclient to get it back.

I also need to rerun alsaconf too.

What on earth is going on?

Thanks.

Once having done the alasconf run as well the alsactl store to store the settings it is supposed to do this on shutdown but obviously not in your case. For the dhcp problem not sure there what client are you using if the dhcp3-client is installed remove it and try with the dhcp-client installed also what is in your /etc/network/interfaces file.
 
Old 09-06-2006, 11:10 PM   #3
stdio.h
LQ Newbie
 
Registered: Sep 2006
Location: Australia
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
Very interesting. I was unfamiliar with alsactl store
It says it saves alsa mixer settings during shutdown, but I guess that's kind of different.

I'm using dhcp-client. It successfully gets an IP from the router, then loses it somewhere.

/etc/network/interfaces
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
I hope I'm using the right tags. I'm so bad with forums

Thankyou for your help so far HappyTux.
 
Old 09-06-2006, 11:40 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,520

Rep: Reputation: 70
Quote:
Originally Posted by stdio.h
Very interesting. I was unfamiliar with alsactl store
It says it saves alsa mixer settings during shutdown, but I guess that's kind of different.
Well a lot of people think that they need to run the alsaconf when it is only the mixer settings needed because sometimes alsa defaults the volumes to mute for some stupid reason.. So your saying that the modules never get loaded for your sound card on boot?? If so check you /etc/modprobe.d/sound file it should look something like this.

Code:
alias snd-card-0 snd-emu10k1
options snd-emu10k1 index=0
I seen a couple of times where alsaconf did not create the file if this happened create it using the module name of your card in place snd-emu10k1 then as root /etc/init.d/alsa reload.
Quote:
I'm using dhcp-client. It successfully gets an IP from the router, then loses it somewhere.
Try this for the file I've never seen the option you have in there hotplug should already find the module for the card you just need the auto eth0 to bring it up on boot.
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp
Oh and if your using that damn udev upgrade to latest available version you can.
 
Old 09-07-2006, 04:26 AM   #5
stdio.h
LQ Newbie
 
Registered: Sep 2006
Location: Australia
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
I'll have a try later tonight.

First I think I'll go back to a 2.4 kernel. 2.6 has proven to be a nightmare for me.

That allow-hotplug option is a mystery to me too.
 
Old 09-07-2006, 11:09 AM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,520

Rep: Reputation: 70
Quote:
Originally Posted by stdio.h
I'll have a try later tonight.

First I think I'll go back to a 2.4 kernel. 2.6 has proven to be a nightmare for me.

That allow-hotplug option is a mystery to me too.
Ok if you end up needing the alsa part then if I remember it right you need to edit /etc/modprobe/alsa or even the aliases file if you wanted to put the lines into then run update-modules to have the information entered into the /etc/modules.conf for use on boot.
 
Old 09-08-2006, 01:55 AM   #7
stdio.h
LQ Newbie
 
Registered: Sep 2006
Location: Australia
Distribution: Debian Etch
Posts: 8

Original Poster
Rep: Reputation: 0
Gone back to a 2.4 now.
After a little tweaking etc to get things working again something happened.

I had to install the 2.4 alsa modules then run alsaconf, as one does. Alsa now seems to come back on startup (or during Gnome startup). I say that because during init is still says (none loaded) for when its loading ALSA.

I removed the allow-hotplug option from interfaces. no luck still.

Now once I get networking happening on its own, I'll be a little happier. Still have to fix DRI/DRM for my mach64. Had it working on the old harddrive too. But thats another matter entirely. Thats been fairly well documented anyway.

Back to the network.
Just as I was typing this I noticed I missed the auto eth0 line. My apologies.
I'll do a restart and see if it worked. Thankyou again.

edit:

Tried the change to interfaces. That works fine now.

...now I have two more issues. The mouse seems to have a 50% chance of working on startup, and the cd-rom isn't there. Sigh. I might just have to do another install at this rate.

Last edited by stdio.h; 09-08-2006 at 07:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Distribute updates to settings on a Debian based network (Lots of opinions wanted) amon Debian 0 04-11-2006 05:54 PM
save network interface settings on debian with kde 3.5 sunpascal Linux - Newbie 2 02-03-2006 09:54 PM
SUSE lose Network Connection RatonCrispiN Linux - Networking 3 09-08-2005 10:16 AM
Sound Working but lose settings after Reboot JoshSmith41 Linux - Hardware 1 01-14-2004 11:55 PM
lose settings in new kernel contrasutra Linux - Software 5 04-11-2003 10:07 PM


All times are GMT -5. The time now is 05:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration