LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-08-2015, 09:36 PM   #1
glinkels
LQ Newbie
 
Registered: May 2012
Location: /home/glinkels
Distribution: Debian
Posts: 12

Rep: Reputation: Disabled
Debian 8 PulseAudio/Alsa Mic picking up no sound


I have recently come across my microphone suddenly not working on my computer and I checked, it seems the microphone isn't picking anything up. I know I have no extra information here, but I'm just 12 and I'm not really that well at linux, thanks!
 
Old 08-08-2015, 09:59 PM   #2
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 15 , Slackel 14.1, ChromeOS
Posts: 4,713
Blog Entries: 19

Rep: Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970
Type in
Code:
alsamixer
and make sure the mic is not muted in there. F5 key shows all the slider controls.

Thats the 1st thing to check if it was working before. Next thing I would check is that you did not mute anything accidentally via the hotkeys on your keyboard for mic.

The user manual for your laptop online will tell how to mute and unmute it.
 
Old 08-08-2015, 10:19 PM   #3
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,361
Blog Entries: 12

Rep: Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751
I think Debian uses pulse. In addition to checking the alsamixer settings, install pavucontrol, the pulse mixer application (it's in the repos), if it's not already present, and check the settings in it.

Also, if you haven't not already done so, check the mic in another device to make sure the mic hasn't gone west and, if the mic has a battery (I have one that does in the extension), check the battery.
 
Old 08-08-2015, 10:36 PM   #4
glinkels
LQ Newbie
 
Registered: May 2012
Location: /home/glinkels
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rokytnji View Post
Type in
Code:
alsamixer
and make sure the mic is not muted in there. F5 key shows all the slider controls.

Thats the 1st thing to check if it was working before. Next thing I would check is that you did not mute anything accidentally via the hotkeys on your keyboard for mic.

The user manual for your laptop online will tell how to mute and unmute it.
I've tried that, and I do not use a laptop, I use a PC I built myself.

Thanks, though
 
Old 08-08-2015, 10:37 PM   #5
glinkels
LQ Newbie
 
Registered: May 2012
Location: /home/glinkels
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
I think Debian uses pulse. In addition to checking the alsamixer settings, install pavucontrol, the pulse mixer application (it's in the repos), if it's not already present, and check the settings in it.

Also, if you haven't not already done so, check the mic in another device to make sure the mic hasn't gone west and, if the mic has a battery (I have one that does in the extension), check the battery.
I already have pavucontrol and I have checked, it knows it's there, it just doesn't pick up any sound.
I tried it on my mother's Linux Mint and it works.

Thanks, though

Last edited by glinkels; 08-09-2015 at 12:39 PM.
 
Old 08-08-2015, 11:04 PM   #6
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 15 , Slackel 14.1, ChromeOS
Posts: 4,713
Blog Entries: 19

Rep: Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970Reputation: 1970
Then all I have to offer is how I fixed a my personal mic problem the hard way.

http://antix.freeforums.org/eeepc-90...-11-t3433.html

I don't use pulseaudio though. Just alsa. I don't skype. Which requires pulse audio as I understand it now.
 
Old 08-08-2015, 11:05 PM   #7
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,361
Blog Entries: 12

Rep: Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751Reputation: 2751
It's a long shot, but try booting to a Live CD of something not Debian based and test to make sure that the sound card mic input still works.

I've found that it's important to rule out hardware problems; no amount of tinkering with software can fix a hardware problem.
 
Old 08-09-2015, 06:57 AM   #8
glinkels
LQ Newbie
 
Registered: May 2012
Location: /home/glinkels
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
It's a long shot, but try booting to a Live CD of something not Debian based and test to make sure that the sound card mic input still works.

I've found that it's important to rule out hardware problems; no amount of tinkering with software can fix a hardware problem.
I forgot to tell you that when I plug it out and back in it works for a few seconds and then it stopped.
Does that mean it works? I mean, it worked before I came home from my 3/4 week vacation. (As did my sound, but I fixed that now)
But, hey, it's worth a try, thank you.
(edit)
I forgot, whenever I removed pulseaudio and configured alsa, it did work.
So it is a pulseaudio problem.

Last edited by glinkels; 08-09-2015 at 07:03 AM.
 
Old 08-09-2015, 06:59 AM   #9
glinkels
LQ Newbie
 
Registered: May 2012
Location: /home/glinkels
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rokytnji View Post
Then all I have to offer is how I fixed a my personal mic problem the hard way.

http://antix.freeforums.org/eeepc-90...-11-t3433.html

I don't use pulseaudio though. Just alsa. I don't skype. Which requires pulse audio as I understand it now.
Well, skype doesn't require pulseaudio, as I used alsa untill I was 9 and then I switched to pulseaudio since my father told me I could hear more than one sound. Then again, when I removed pulseaudio, my microphone worked fine.
Any fixes that still let me use pulseaudio?
 
Old 08-21-2015, 08:20 PM   #10
glinkels
LQ Newbie
 
Registered: May 2012
Location: /home/glinkels
Distribution: Debian
Posts: 12

Original Poster
Rep: Reputation: Disabled
I guess nobody wants to help, if you come across this thread, I've given up.
Thanks, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] My sound card is not being detected by Debian 8 (Alsa and Pulseaudio) glinkels Linux - Newbie 8 08-08-2015 02:23 PM
Issues setting up sound and mic with ALSA FracisZ450 Linux - Software 2 07-01-2015 12:58 AM
[SOLVED] Enable mic in Skype. Using Alsa sound. Please help. disco_slack Slackware 5 05-23-2011 03:43 PM
sound is very faint (alsa and pulseaudio, Fedora 10) bach-fiend Linux - Newbie 3 02-16-2009 04:11 PM
USB Sound (Mic) not working in Fedora 9 pulseaudio MikeyCarter Linux - Software 0 07-30-2008 11:01 AM


All times are GMT -5. The time now is 01:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration