LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2012, 05:36 PM   #1
Ravenslair
LQ Newbie
 
Registered: Feb 2012
Location: California, USA
Distribution: Fedora 16
Posts: 18

Rep: Reputation: 0
Debian 6.0.4 not starting on multiboot system


I recently started down the road of a multiboot system. I currently have the following installed (and almost working right):

/dev/sda1 - Windows XP
/dev/sda2 - Grub bootloader
/dev/sda4 - Large ext4 partition that contains the Linux installs noted below
/dev/sda5 - swap
/dev/sda6 - ext4 - Ubuntu 11.10 installed here with the boot loader installed in the same partition *****Works*****
/dev/sda7 - ext4 - Fedora 16 KDE installed here with the boot loader installed in the same partition *****Works*****
/dev/sda8 - ext4 - Fedora 16 Gnome installed here with the boot loader installed in the same partition *****Works*****
/dev/sda9 - ext4 - OpenSUSE 12.1 Gnome installed here with the boot loader installed in the same partition *****Network not working*****
/dev/sda10 - ext4 - CentOS 6.2 installed here with the boot loader installed in the same partition *****Works*****
/dev/sda11 - ext4 - Debian 6.0.4 installed here with the boot loader installed in the same partition *****Not booting*****
/dev/sda12 - ext4 - Mandriva installed here with the boot loader installed in the same partition *****Network not working*****
/dev/sda13 - ext4 - Unused right now
/dev/sda14 - ext4 - Unused right now
/dev/sda15 - ext4 - Unused right now
/dev/sda16 - ext4 - Common /home directory

My problem is with Debian right now. When I select it, it gives me the following error almost immediately after selecting it in my Grub2 bootloader (/dev/sda2):

error: invalid signature.
Press any key to continue...


Any key results in me back at my Grub2 bootloader (/dev/sda2). Here is the grub.cfg that I use to launch my various distro installations:

set default="0"

set timeout=10

menuentry "Windows XP" {
set root=(hd0,1)
chainloader +1
}

menuentry "Ubuntu" {
set root=(hd0,6)
chainloader +1
}

menuentry "Fedora" {
set root=(hd0,7)
chainloader +1
}

...........all the way to the Debian command

menuentry "Debian 6.0.4" {
set root=(hd0,11)
chainloader+1
}

Any ideas? I can attach my grub.cfg file located in the grub directory of the Debian installation if that helps. Thanks.
 
Old 03-05-2012, 05:56 PM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Your entry for Debian does not have a space between chainloader and +1. If that is just a typo, you should probably download and run the bootinfoscript from the site below and post the results.txt file which should contain all the necessary information for someone to point out what the problem might be:

http://sourceforge.net/projects/bootinfoscript/
 
Old 03-05-2012, 06:23 PM   #3
Ravenslair
LQ Newbie
 
Registered: Feb 2012
Location: California, USA
Distribution: Fedora 16
Posts: 18

Original Poster
Rep: Reputation: 0
The lack of a space between chainloader and +1 was a typo. I ran bootinfocript. Here is the output. Even to a newbie like myself, the lack of a Boot sector type and Boot sector info is a bad sign that something did not install correctly. I have attached the results.txt file for completeness.

sda11: _________________________________________________________________________

File system: ext4
Boot sector type: -
Boot sector info:
Operating System: Debian GNU/Linux 6.0
Boot files: /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

Thanks for the quick reply.
Attached Files
File Type: txt RESULTS.txt (49.9 KB, 9 views)
 
Old 03-05-2012, 11:38 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Which Grub do you have in the master boot record? I mean from which system, Ubuntu, Fedora, other?
You might try just running sudo update-grub from that system if you haven't already.
It doesn't look like Grub was installed to the partition on which you have Debian. If you are chainloading, you need Grub there so you could try installing it again to that partition. Section 12 at the link below explains how to do this.

https://help.ubuntu.com/community/Grub2
 
Old 03-06-2012, 12:09 AM   #5
Ravenslair
LQ Newbie
 
Registered: Feb 2012
Location: California, USA
Distribution: Fedora 16
Posts: 18

Original Poster
Rep: Reputation: 0
I installed Grub2 (version 1.99) into /dev/sda2 using the grub installer I downloaded directly from ftp://ftp.gnu.org/gnu/grub/. I ran the grub-install file I had downloaded while running a Ubuntu LiveCD. Just confirming I could run Ubuntu (or any other distro) and follow the steps in Section 12 to reinstall/install Grub into /dev/sda11 where I have Debian installed? Thanks.
 
Old 03-06-2012, 10:15 AM   #6
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Since you are intending to install the Debian Grub, I would suggest you use the Debian CD to install. It should definitely be the same version of Grub2. There are Grub2 versions 1.97, 1.98, 1.99. Might work with the Ubuntu, I'm really not sure.
 
Old 03-06-2012, 05:19 PM   #7
Ravenslair
LQ Newbie
 
Registered: Feb 2012
Location: California, USA
Distribution: Fedora 16
Posts: 18

Original Poster
Rep: Reputation: 0
I did a complete reinstall of Debian using the advanced option this time. When asked where to install Grub, I installed it to (hd0,11), which is where Debian resides. I reran boot_info_script and have attached the results. I am lost at this point. I have no idea why Debian will not boot.
The following is from RESULTS.TXT regarding the fstab file (there is an error for /, but I am not sure what it means):

=============================== sda11/etc/fstab: ===============================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda11 during installation
UUID=18121205-77fd-4eb7-aa43-32958ed31d1c / ext4 errors=remount-ro 0 1
# /home was on /dev/sda16 during installation
UUID=1697e1fb-5c75-469d-85b6-336453a7cd35 /home ext4 defaults 0 2
# swap was on /dev/sda5 during installation
UUID=146b36ba-59f9-4e08-95a9-c79731cb9da5 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
Attached Files
File Type: txt RESULTS.txt (60.2 KB, 19 views)

Last edited by Ravenslair; 03-06-2012 at 05:21 PM.
 
Old 03-06-2012, 07:49 PM   #8
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Are you still able to boot all other systems, other than Debian?
Do you see the boot menu? and are then able to make a selection? everything else boots?
I notice you have two grub.cfg files on sda2?? Should only need one, /boot/grub/grub.cfg
I don't really see anything other than the fact that all other partitions with Grub show information in Boot sector type and Boot Sector info and Debian shows nothing. It does show the grub boot files?
I don't have any other suggestions. Maybe someone who is familiar with Debian will have some idea.
 
Old 03-06-2012, 08:49 PM   #9
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,904

Rep: Reputation: 261Reputation: 261Reputation: 261
to boot debian at the grub prompt the following should allow you to boot to reinstall debian grub
Quote:
set root=(hd0,11)
linux /vmlinuz root=/dev/sda11
initrd /initrd.img
 
Old 03-06-2012, 10:45 PM   #10
Ravenslair
LQ Newbie
 
Registered: Feb 2012
Location: California, USA
Distribution: Fedora 16
Posts: 18

Original Poster
Rep: Reputation: 0
I am still able to boot all the other systems. Debian is the only one that will not boot.

I will try to reinstall using colorpurple21859's note. Once at the prompt, will the following commands work?

sudo mkdir /mnt/sda11
sudo mount /dev/sda11 /mnt/sda11
sudo grub-install --root-directory=/mnt/sda11 /mnt/sda
sudo umount /dev/sda11
sudo rmdir /mnt/sda11
exit

These are the steps I was given when I needed to reinstall grub in /dev/sda2 (which is where my chainloading bootloader resides).

Thanks.
 
Old 03-07-2012, 10:37 AM   #11
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Quote:
I will try to reinstall using colorpurple21859's note. Once at the prompt, will the following commands work?
I doubt those commands will work at the grub prompt. What colorpurple21859 is suggesting is you use the commands he posted when you boot and see the menu and select Debian. Go to the link I posted earlier, the Ubuntu Grub2 link and go to Section 8 which explains doing this at the grub boot prompt.

The commands you have listed above should work from Ubuntu or one of your other systems. If you are intending to install Debian Grub to the root partition (sda11) you would need to change the third command you have listed as the way you have it, it would install Debian Grub to the mbr. Since your Debian Grub is problematic, it doesn't seem like a good idea. Change line 3 to:

Quote:
sudo grub-install --root-directory=/mnt/sda11 /mnt/sda11
If that doesn't work, you can go to the ubuntu site again and read Section 12.4 and try the chroot method.
 
Old 03-07-2012, 11:11 AM   #12
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,904

Rep: Reputation: 261Reputation: 261Reputation: 261
What I suggested should boot debian if you hit the "e" at the grub menu when the computer first starts and enter the commands mentioned above . The op can then reinstall debian grub to sda11 from within the debian system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help setting up multiboot system vspellen Linux - Software 3 01-29-2009 05:58 AM
Debian Testing + XP Multiboot 2 HD's whitster Debian 1 02-08-2007 04:19 PM
multiboot system swap part ? Mandle Linux - Newbie 2 04-28-2006 12:22 PM
Multiboot with Debian, Windows XP, and FreeDOS RodWC Linux - General 1 10-31-2005 10:35 AM
swap partitions on multiboot system gargamel Linux - General 5 05-23-2004 07:28 PM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration